MozillaZine

Phoenix / Firebird DOES NOT BUILD from Moz 1.3 on Debian PPC

Discussion about official Mozilla Firefox builds
UnixJessica
 
Posts: 12
Joined: April 15th, 2003, 12:52 pm

Post Posted April 15th, 2003, 1:21 pm

Hi all.

Tried downloading Mozilla 1.3 sources (mozilla-source-1.3.tar.bz2) to my Debian/PPC box (it's a G4/450 with a nice new install of Debian 3.0, a.k.a. Woody, running the stock 2.4.18-newpmac kernel). Tried creating the .mozconfig file in /usr/src/mozilla (the base directory for the untarred mozilla-source-1.3.tar.bz2) as specified on the tutorial at http://lxr.mozilla.org/mozilla/source/b ... EADME.html :

--------------------------------------------
export MOZ_PHOENIX=1
mk_add_options MOZ_PHOENIX=1
ac_add_options --enable-crypto
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --disable-mailnews
ac_add_options --disable-composer
ac_add_options --enable-optimize=-O2
ac_add_options --disable-ldap
ac_add_options --disable-mailnews
ac_add_options --enable-extensions=default,-inspector,-irc,-venkman,-content-packs,-help
ac_add_options --enable-plaintext-editor-only
--------------------------------------------

I then ran:
make -f client.mk build &> mozbuild.txt

It no worky. It spews a bunch of errors ending in:

--------------------------------------------
make[4]: Entering directory `/usr/src/mozilla/xpinstall/stub'
make[4]: Nothing to be done for `export'.
make[4]: Leaving directory `/usr/src/mozilla/xpinstall/stub'
make[4]: Entering directory `/usr/src/mozilla/xpinstall/cleanup'
../../config/nsinstall -R -m 644 InstallCleanupDefines.h ../../dist/include/xpinstall
/usr/bin/perl -I../../config ../../config/build-list.pl ../../dist/include/xpinstall/.headerlist InstallCleanupDefines.h
make[4]: Leaving directory `/usr/src/mozilla/xpinstall/cleanup'
make[4]: Entering directory `/usr/src/mozilla/xpinstall/wizard/libxpnet'
make[5]: Entering directory `/usr/src/mozilla/xpinstall/wizard/libxpnet/src'
../../../../config/nsinstall -R -m 644 nsFTPConn.h nsHTTPConn.h nsSocket.h ../../../../dist/include/xpnet
/usr/bin/perl -I../../../../config ../../../../config/build-list.pl ../../../../dist/include/xpnet/.headerlist nsFTPConn.h nsHTTPConn.h nsSocket.h
make[5]: Leaving directory `/usr/src/mozilla/xpinstall/wizard/libxpnet/src'
make[4]: Leaving directory `/usr/src/mozilla/xpinstall/wizard/libxpnet'
make[4]: Entering directory `/usr/src/mozilla/xpinstall/wizard/unix/src2'
make[4]: Nothing to be done for `export'.
make[4]: Leaving directory `/usr/src/mozilla/xpinstall/wizard/unix/src2'
make[3]: Leaving directory `/usr/src/mozilla/xpinstall'
make[3]: Entering directory `/usr/src/mozilla/l10n'
make[4]: Entering directory `/usr/src/mozilla/l10n/langpacks'
make[4]: Nothing to be done for `export'.
make[4]: Leaving directory `/usr/src/mozilla/i10n/langpacks'
make[3]: Leaving directory `/usr/src/mozilla/l10n'
make[3]: Entering directory `/usr/src/mozilla/toolkit'
make[3]: *** No rule to make target `export'. Stop.
make[3]: Leaving directory `/usr/src/mozilla/toolkit'
make[2]: *** [tier_9] Error 2
make[2]: Leaving directory `/usr/src/mozilla'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/usr/src/mozilla'
make: *** [build] Error 2
arwen:/usr/src/mozilla#
-------------------------------------------

Complete error-spewage log is at:

http://jb.twu.net/mozbuild.txt (approx 250KB)

Can someone please help me on this? Am I doing something drastically wrong, or is this just yet another issue of Unix Software Just Not Working Out Of The Box(TM)? I love Unix and all, but this sort of thing is EXTREMELY frustrating. I followed the tutorial... why on earth is it breaking? :(

mrdeep
 
Posts: 2
Joined: April 18th, 2003, 10:54 am

Post Posted April 18th, 2003, 11:00 am

I get the same error, but I'm running debian (unstable) on a non-ppc (P3-M 700 ... well ... 696 to be exact), and the file I was working from was "mozilla-source.tar.bz2" - as per instructions from phoenix.ragweed.net.

Building it without the .mozconfig file works fine (that was a waste of 3 hours), but that doen't give me any of the good stuff now does it? I'm somewhat glad to see it isn't just me

cdn

User avatar
 
Posts: 999
Joined: November 4th, 2002, 5:47 pm
Location: UK

Post Posted April 18th, 2003, 12:57 pm

you cannot build Px w/o browser and toolkit, hence your error

this is why cvs is recommended

browser and toolkit from 20030128 - this may well not build w/ Mozilla 1.3 source, but there is nothing stopping you trying

Return to Firefox Builds


Who is online

Users browsing this forum: Lurtz and 4 guests