Mouse Rocker Navigation

Talk about add-ons and extension development.

User avatar
Posts: 215
Joined: November 4th, 2002, 10:44 pm
Location: NJ

Post Posted December 9th, 2002, 1:00 pm


"BTW I assume this doesn't work on Mozilla? Do you think you could get this working on Mozilla?"

On linux Mouse gestures are totally flaky and I can't use my right mouse button(preferred) because gestures never captures its input. Selecting a left mouse modifier kinda works "O.K", but I highlight a lot of text and that kinda screws things up.

Posts: 19
Joined: November 21st, 2002, 7:53 am

Post Posted December 9th, 2002, 1:20 pm

Tried to install the new mouse rocker extension..... I click on the link, and get an Error 999. No text though... Am assumming it is because I have the OLD/original mouse rocker extension. I tried to delete it from the Preferences form, but all it lets me do is disable it, which didn't help....

Also, as a side node, I often get a wrong-sized window when trying to install an extension. I click on the link for an extension, and Phoenix pops up a window asking me if I want to install or cancel. THAT window is around 20 to 30 pixels too short, I can barely see the OK and CANCEL buttons. The window pops up close to the center of the screen, so there is plenty of screen space for the window to be properly sized....

Any ideas on how I can fix either one of these issues...?


Posts: 19
Joined: November 17th, 2002, 8:50 pm

Post Posted December 11th, 2002, 9:22 am

I posted this first elsewhere, but I guess it probably belongs here.

I downloaded the rocker extension yesterday when I upgraded to 0.5, but it has been completely unusable for me. For some reason when it is enabled everything behaves strangely. I'll click on an arbitrary link in a page and the browser will go back a page for some reason and other times I click on links and absolutely nothing happens at all. The actual 'rocking' does work but i have to be very slow and deliberate about it to make it work, and sometimes it goes in the wrong direction anyway. It's all very strange.

I don't know if this because of a conflict with another extension or what but all the problems definitely go away when I just disable the rocker extension in preferences.


User avatar
Posts: 2208
Joined: November 6th, 2002, 11:29 pm
Location: hickville, south dakota

Post Posted December 11th, 2002, 10:27 am

i believe i read on another thread that .5 differs enough from the previous nightlies/releases that the mouse rocker doesn't work right. i'm sure the author will be fixing it soon, though.

Posts: 3275
Joined: November 6th, 2002, 12:07 pm
Location: Federal Republic of Germany

Post Posted December 14th, 2002, 3:01 pm

hey, I just installed it from Phoenix Help, using the 1210 nightly and it works.. like it :)
<i>Latest Firefox Trunk & Thunderbird 1.0</i>

Posts: 129
Joined: November 5th, 2002, 3:39 am

Post Posted December 14th, 2002, 5:15 pm

it worked as advertised for me on all the post-0.5 nightlies that i tried it on. problem is, it doesn't work with radial context or mouse gestures, so it's mostly useless to me.


User avatar
Posts: 12609
Joined: November 5th, 2002, 2:19 pm
Location: .nl

Post Posted December 14th, 2002, 5:22 pm

shimage wrote:it worked as advertised for me on all the post-0.5 nightlies


Return to Extension Development

Who is online

Users browsing this forum: No registered users and 0 guests