MozillaZine

Bookmark toolbar icons keep corrupting

User Help for Mozilla Firefox
Exiled_077
 
Posts: 11
Joined: November 13th, 2017, 4:34 pm

Post Posted October 25th, 2018, 8:42 pm

Okay, it seems as though it was a temporary fix as the problem is back.

lasardo
 
Posts: 182
Joined: September 9th, 2018, 1:41 pm

Post Posted October 25th, 2018, 9:12 pm

According to here https://www.reddit.com/r/firefox/commen ... nd_i_cant/ the reddit enhancement suite could cause them to be replaced with reddit icons.
I glanced at bugzilla and did not see losing favicons shown. What antivirus and extensions do you have?

Exiled_077
 
Posts: 11
Joined: November 13th, 2017, 4:34 pm

Post Posted October 26th, 2018, 10:29 pm

Creating a new profile seems to have fixed my problem for good this time, I'm guessing that what Firefox updated to v63 it somehow corrupted my profile or something I'm not really sure.....anyway a new profile sorted the issue right out.

tomatoshadow2

User avatar
 
Posts: 393
Joined: May 11th, 2017, 9:52 am

Post Posted October 31st, 2018, 2:21 am

@Exiled_077 Could also have been a possible bad extension.

Exiled_077
 
Posts: 11
Joined: November 13th, 2017, 4:34 pm

Post Posted November 3rd, 2018, 4:02 pm

It actually started happening again even after creating a new profile, but I've managed to fix it again for good (this time for real). I managed to pinpoint the problem to Firefox Account Sync, every time Firefox performed a sync (which I believe is periodically) it would remove the site icons on the bookmarks that the issue was happening with but other bookmark icons would remain untouched. What I did was change the URL of all the bookmarks that it was happening to then performed a manual sync, then changed them back again and did again manual sync, and now everything seems to be working properly.

bender01
 
Posts: 11
Joined: August 12th, 2015, 7:49 am

Post Posted November 7th, 2018, 2:16 am

Bookmarks favicons keep disappearing, they become the default globe and I need to load the site to make the favicon come back. It started since the last 10-15 days. It happens with the same few bookmarks.

Moving places.sqlite and favicons.sqlite only worked for 2-3 days then the issue came back.

Exiled_077 wrote:I managed to pinpoint the problem to Firefox Account Sync

What if I don't use a Firefox account? How do you do a manual sync?

DanRaisch
Moderator

User avatar
 
Posts: 121426
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted November 7th, 2018, 4:45 am

More info needed to answer that question. How many computers would you be synching? What would you intend to synch? Just bookmarks or also history, passwords, etc?

bender01
 
Posts: 11
Joined: August 12th, 2015, 7:49 am

Post Posted November 7th, 2018, 5:51 am

But I don't use the Synch. That's why I was asking: how can I do the solution indicated by Exiled_077 if I don't use the Synch or the Firefox account?

DanRaisch
Moderator

User avatar
 
Posts: 121426
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted November 7th, 2018, 7:06 am

The questions would remain the same.

bender01
 
Posts: 11
Joined: August 12th, 2015, 7:49 am

Post Posted November 7th, 2018, 7:31 am

I don't use the Sync so it's just one computer. And I don't know about the rest, I only know that Exiled_077 talked about doing a manual sync, but I assume it's just for the bookmarks.

Maybe his fix won't do for me since I never used the Sync.

jscher2000

User avatar
 
Posts: 10578
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted November 7th, 2018, 9:06 am

bender01 wrote:I don't use the Sync so it's just one computer. And I don't know about the rest, I only know that Exiled_077 talked about doing a manual sync, but I assume it's just for the bookmarks.

Maybe his fix won't do for me since I never used the Sync.

Sync caused the problem in that case, so a hacky workaround related to Sync was used in that case. Please check all the other suggestions in the thread.

bender01
 
Posts: 11
Joined: August 12th, 2015, 7:49 am

Post Posted December 15th, 2018, 7:19 am

I created a new profile, it took me over a half hour to manually backup e reenter all the settings, preferences, bookmarks and extensions... But it was useless. Some favicons disappear once I reload Firefox (not always, randomly). It only happens with some specific bookmarks, like this one:
Code: Select all
https://store.steampowered.com/explore/new/

I'm pretty sure it started with version 63.
Does anyone else have this problem?

Exiled_077
 
Posts: 11
Joined: November 13th, 2017, 4:34 pm

Post Posted December 15th, 2018, 11:35 pm

bender01 wrote:I created a new profile, it took me over a half hour to manually backup e reenter all the settings, preferences, bookmarks and extensions... But it was useless. Some favicons disappear once I reload Firefox (not always, randomly). It only happens with some specific bookmarks, like this one:
Code: Select all
https://store.steampowered.com/explore/new/

I'm pretty sure it started with version 63.
Does anyone else have this problem?

Sadly it started happening to me again too, and I have noticed to that this only started with v63, I no longer think that its connected to Sync as you're experiencing it also and have stated previously that you aren't signed-in to a Firefox account. I'm positive that its a bug with the v63 code-base for Firefox that happens on some h/w configurations because I recently reinstalled Windows 10 and like I said it started happening again, and like you seems to happen at random.

tpaulr
 
Posts: 419
Joined: June 22nd, 2004, 8:01 am

Post Posted December 16th, 2018, 5:57 am

This has been an on-going problem for me since 60.

I believe this is also the cause of my most recent issues, also posted here, the inability to manage my download history.

There are no icons for downloads or for the few remaining bookmarks I still keep in Firefox.

I believe having no icons for my downloads are causing the issues, just like with my bookmarks, although I solved the problem by using a 3rd. party service.

I too have tried everything recommended here for both my issues, including looking at possible hardware issues. BTW, I don't use Sync, never have.

I have created 10 new profiles since 60, they work for a couple days, then it reverts to a corrupted state.

I have this corrupted favicons file that always comes back aptly named favicons.sqlite.corrupt.

When I check the integrity of Places, I always get this as the first line: Unable to check favicons.sqlite integrity: Error: Error(s) encountered during statement execution: .

I may not be a Firefox SME, but I'm not dumb enough to believe this is all just a coincidence starting with FF60.

I can't fix this issue no matter what I've tried, every single recommendation that has been documented I have performed, including the 10 new profiles.

I rebuild my profiles from scratch, I don't use any existing preferences, I delete everything before I start, except for the few bookmarks I have left which I import, I start over completely.

It's a pain but I know it's a clean installation.

Portable Firefox - now my default - runs without any issues, as well as my 5 laptops, no issues of any kind - only this one installation, my desktop. These are identical set-ups, same operating systems, same set-ups, same browser preferences.

I'm at a loss - I have no idea what to do next. :?

lasardo
 
Posts: 182
Joined: September 9th, 2018, 1:41 pm

Post Posted December 16th, 2018, 1:12 pm

Other ideas:
1: As mentioned in the other thread, making another new profile and setting Firefox to run in permanent private browsing mode should prevent any download history from ever being stored and may fix your immediate problem.
2: You have laptops where things work. Instead of making a new profile on the troubled desktop, try copying in a profile from one of those working laptops. If you copy the whole appdata\Mozilla\Firefox folder tree, that will include a profiles.ini file so everything should just work without additional setup.
3: Uninstall your antivirus and/or firewall and use Windows Defender.
4: You say you are using a new profile and doing little beyond importing a few bookmarks. I assume that is using the import function, not restore, from an html bookmarks file? Regardless, try not doing that. Just recreate the few bookmarks instead of importing anything.
5: If you have few bookmarks, maybe you don't need favicons at all. It used to be the favicons feature could be turned off, I don't know if or why that would help with download history.
6: If you do not have the right permissions to the folders where the firefox program folder and profile are stored, strange issues with reading and writing files can occur. It is probably too painful of a possible solution, but you could:
Uninstall Firefox. Create a new windows user account. The new user account has its own appdata folder which will start off empty and with the right permissions. In that new user account, install Firefox, and it will start with a new profile. If this profile does work, rebuilding the permissions to your normal user account could help, however I have no idea how to do so. Worst case you can install all your normal software and move your files into the new user account.
7: I think there is a clunky way to make Portable Firefox into a default browser and use it as if it was a normal Firefox. It has some caching disabled, but I think you may be able to turn some of that back on to improve performance.
8: List all extensions you are using with your new profile, if any.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 12 guests