SMS to e-mail problems with iPhone on AT&T

User Help for Mozilla Thunderbird
Posts: 14
Joined: October 4th, 2016, 6:43 am

Post Posted July 11th, 2018, 10:54 am

I routinely communicate with other people from my e-mail account by sending an e-mail message to their phone as a text message. I do this using the SMS gateway provided by the carrier.

As an example, I send an e-mail, from Thunderbird (not a text message, a regular e-mail message) to an address that looks like this:

where the sequence before the @ symbol is the ten-digit mobile phone number. The SMS gateway converts the e-mail message into a text message (or multimedia message) for delivery to the phone.

All of the major carriers have this type of gateway. For Verizon, it is

And the phone user can reply. And when they do, I receive an e-mail from the address described above.

This has worked well for years. Only now have I begun to experience problems when receiving messages sent from an AT&T iPhone.

The message arrives in my inbox, and it appears to be blank. It shows the originating e-mail address, as described above, but no text or other data appears in the body of the message.

But if I click Forward in Thunderbird, then the text of the message magically appears in the body of the forwarded message.

Anyone have any ideas on what might be causing this? I am experiencing this with more than one user, and they both have an iPhone on the AT&T network.

Clearly the message IS getting delivered, but for some reason it is not displaying properly in Thunderbird. My guess is that it has something to do with the formatting...

FYI: changing the view from "original HTML" TO "simple HTML" to "plain text" does not resolve the issue.

Environment: Win 7 Pro 32 bit; Thunderbird Portable version 45.8.0

Additional info that I suspect might help solve this mystery: My e-mail is IMAP on the Godaddy network. It is NOT gmail, Yahoo, AOL,, or any of those. It is my own domain.
When I check my e-mail using Godaddy Webmail (not Office 365, legacy webmail) the message does not display in the body of the e-mail, but it comes in as a text file attachment, which I have to open using Notepad. And I can read it that way with no problem...



User avatar
Posts: 45678
Joined: July 30th, 2003, 5:06 pm

Post Posted July 11th, 2018, 11:08 am

I've seen a similar problem with a iphone sending me a SMS over Verizon about a year ago. I deleted the message but found a old post where I mentioned it. Perhaps you are seeing the message body when forwarding due to the attachment becoming part of the message body when you using the inline version of forwarding.

"I recently received what I suspect was a SMS sent from a iPhone. It showed up as a email message with a blank message body. That was due to the Content-Type: header being set to multipart/mixed; type="application/smil"; and the actual plain text message being stored in an attachment (which was also not visible). The From: address was the phone number with a domain"

Posts: 14
Joined: October 4th, 2016, 6:43 am

Post Posted July 11th, 2018, 2:32 pm


Your experience, in the quoted post, sounds exactly like what is happening to me. And it looks like you solved the problem. When I go to <view> and check <Display Attachments Inline>, the text appears in the body of the message!

It still leaves an unanswered question: Why, when the option to <Display Attachments Inline> is NOT checked, does the text NOT show up as a genuine attachment, in the form of a .txt file, as it does when I use Godaddy webmail?

Put another way, why is the attachment not visible unless I choose to <Display Attachments Inline>?



User avatar
Posts: 45678
Joined: July 30th, 2003, 5:06 pm

Post Posted July 11th, 2018, 3:35 pm

I found the message (it was in a different account). I don't understand what in the headers caused Thunderbird not to recognize the attachment. However, the MIME parser in Thunderbird tends to make assumptions that it shouldn't and not deal with errors well.

The Content-ID: <0> header is invalid. It is supposed to be a globally unique string that includes a '@' (just like the Message-ID: header) I also wouldn't expect a HTTP Content-Location: header in a email message, though that is probably harmless. ... -id-header ... t-Location

Message-ID: <212358592469517936@-212358592469517937>
Date: Mon, 10 Apr 2017 13:54:29 +0000
Content-Type: multipart/mixed;

Content-Type: text/plain; charset=us-ascii
Content-ID: <0>
Content-Disposition: attachment;
Content-Location: text_0.txt

The actual text that was typed, which you expect to see as the message body

Posts: 14
Joined: October 4th, 2016, 6:43 am

Post Posted July 11th, 2018, 4:31 pm

Interesting... some of this is over my head. I've looked at the headers on the messages in question, both in Thunderbird and in the Godaddy webmail platform. I don't see a Content-ID anywhere. But everything else you're saying makes sense. It definitely seems to have something to do how iPhones are formatting MMS. This does not happen when the message is raw text. When it is raw text, it comes from an address like, or When it is MMS, it comes from or, and those are the messages where the attachment is not visible as a downloadable file.

But if I tick Display Attachments Inline, at least I can read the message in Thunderbird, without having to create a forwarded message.

I remember now why I don't normally display attachments inline. I sometimes get photos that are very hi res, and very large files, like 4.5 MB, and it makes the e-mail messages unwieldy. I would rather just click to download them than have them displayed.

Thank you for your assistance.


Return to Thunderbird Support

Who is online

Users browsing this forum: No registered users and 5 guests