MozillaZine

How to block remote images in messages after turned on?

User Help for Mozilla Thunderbird
SMCorp
 
Posts: 110
Joined: September 6th, 2007, 9:26 pm
Location: USA

Post Posted May 17th, 2018, 3:41 am

For computer OS reasons, I'm using Mozilla Thunderbird version 2.0.0.23 (20090812) and won't upgrade it.

When I see an e-mail in the inbox, there is a light yellow area at the top of the message that says, "To protect your privacy, Thunderbird has blocked remote images in this message.", on the right side is a gray button that says, "Load Images", and on the left side is a link that says, "Click here to always load remote images from (email address)", to approve that sender forever more.

Though this was very, very helpful ten years ago in blocking spam engines from using remote images to confirm my e-mail was valid, I ended up clicking the "Click here to always load remote images from (email address)" for most of my mailing list e-mails that I needed to look at quickly, so I wouldn't have to click that same "Load Images" button again and again.

My problem now is I don't see a way to UN-DO that setting.

Years ago, I'd clicked it for e-mails that used to be just honest e-mails and all I was letting through were graphics to see what it was and to make it more readable, but in later years they started to have massive adware working on them, so just clicking that mail (without even opening it) makes my browser blow up with error boxes like, "Alert - Thunderbird can't connect securely to (whatever domain) because the site uses a security protocol that isn't enabled."

This is an unuseful message, because it doesn't involve anything needing security, just part of the dumb trend that EVERY PAGE ON THE INTERNET is now an SSL site that loads 50x slower for no potential benefit to the visitor ("Oh my god, better secure this connection with 128-bit SSL encryption so no one but me can read this CNN fake news article!").

Some mails, like eBay daily search mails, used to be honest mails, they couldn't tell if I was getting or reading them or not, but now EACH ONE (of 30-50/day) blows up with 11 error boxes one after the other. I would not have clicked that link years ago if I'd known this would happen.

How can I (easily, without hacking the system registry, etc.) un-do this setting for some of my senders? This way, the "Load Images" button and other link would reappear, and I wouldn't click it again.

Thank you.

morat
 
Posts: 3926
Joined: February 3rd, 2009, 6:29 pm

Post Posted May 17th, 2018, 4:59 am

I don't know if the solution works with Thunderbird 2.0. I can't check the Gecko 1.8.1 source since it isn't online anymore.

Changing your mind about "show remote content"
viewtopic.php?f=39&t=2744597

Undoing "Show remote content in this message"
viewtopic.php?f=39&t=2864297

LIMPET235
Moderator

User avatar
 
Posts: 39237
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted May 17th, 2018, 5:03 am

Hi,
I am not a Thunderbird guru but after a bit of a search of the "Prefs/about:config" page,
I found this reference to Loading images.
> permissions.default.image
Open Thunderbird & go to, Tools > Options > Advanced > General.
There should be a button for the Config Editor.
The above pref's default is one. (1) This is what mine is set to.
(I use version 2.0.0 24.)
&, I can see all the "Options" for loading images at the top.

Please ref; the options...
1 (default): Allow all images to load, regardless of origin. This also enables the "Show Remote Content" button.
2: Block all images from loading.
3: Prevent third-party images from loading.

Reset it to two. (2)

Close & reopen Thunderbird & see what happens next time an image is emailed to you.
Again, I am not a Thunderbird expert, so there may be another setting.
Wait for someone more knowledgeable perhaps?

Moving this to Thunderbird Support...
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-62.0-70.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.12.
W.M.Y.C.
(Always choose the "Custom" Install.)

SMCorp
 
Posts: 110
Joined: September 6th, 2007, 9:26 pm
Location: USA

Post Posted May 17th, 2018, 5:24 am

Thank you very much for your replies, morat and LIMPET235.

I saw them both at the same time, and the first link in the first one solved it.

morat, I'm sorry you had to do my searching for me! I looked a few weeks ago and couldn't find a solution, then today before my post. Maybe my subject title is better and people can find it in the future.

For anyone else who has this problem and finds my subject title first, here's what fixed it for me:

Find the contact for that address in your address book, select properties, and uncheck "allow remote content".

In my case, it was ebay@ebay.com, and was fixed by clicking on that entry in my address book, then it opens the box titled "Edit Card for eBay.", then I fixed it by unchecking "Allow remote images in HTML mail."

This is a lot of work in the background I didn't know about. I never made a card for ebay@ebay.com, and I never checked that box, Thunderbird itself added that card and checked that box when I hit the "Load Images" button years ago.

Now I can quickly click through dozens of e-mails, no errors.

Thanks everyone.

LIMPET235
Moderator

User avatar
 
Posts: 39237
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted May 17th, 2018, 6:01 am

&, a big, Thank You for the feedback.
It may just help others that strike the same problem.
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-62.0-70.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.12.
W.M.Y.C.
(Always choose the "Custom" Install.)

SMCorp
 
Posts: 110
Joined: September 6th, 2007, 9:26 pm
Location: USA

Post Posted July 8th, 2020, 10:50 pm

2020 now, I am the original poster on this thread. The problem got really bad this week, with some messages spawning 7, 10, or even more than 30 errors I have to okay before I can delete them, and I experimented with everything on this page and similar pages so much that ALL my spams that don't get filtered to junk are going to open ALL remote images in them and thus confirm my address as valid and get me more spam.

What limpet235 said above seems to have no effect.

For about:config
permissions.default.image user set integer 2

It's set to "2" and restarted, and it loads ALL remote images.

How do I get this back to stock default settings where NO remote images come through unless I click to accept them?

Also, like I said in the OP, for computer OS reasons, I'm using Mozilla Thunderbird version 2.0.0.23 (20090812) and won't upgrade it.

Where morat says

* tools > options > privacy > mail content > exceptions

That's not valid in 2.0.0.23 (20090812), there IS no mail content > exceptions to click on.

I'm not able to make an address book entry for every spam I get and BTW, that doesn't work anymore even on the usual ones I have (my banks, newsletters, etc.).

How do I get this back to stock default settings where NO remote images come through unless I click to accept them?

Thank you.

SMCorp
 
Posts: 110
Joined: September 6th, 2007, 9:26 pm
Location: USA

Post Posted July 9th, 2020, 3:49 am

Okay girls, thanks for nobody coming to my rescue on this, if it weren't for you, I'd end up lazy and coddled.

So far what I have found out just by screwing around---and recall this is 2.0.0.23 (20090812) and will not apply to all versions in fact most versions will be newer and have an easier way to do this---is to make a change in the config editor, a different one than others have referred to in this and other strings.

Here's what I did:

Running Thunderborg 2.0.0.23 (20090812), go to Tools> Options

then press the gear icon on the far right for Advanced,

then making sure it's clicked on the General tab on the far left (folder tab, not the General icon above that at the top), click the lower right Config Editor button.

That opens up the box about:config, then in the Filter box at the top, type in image and see the list of items that have the word image in them, and ignoring "permissions.default.image user set integer 2" which others have talked about and didn't help me this time, see the one that says

mailnews.message_display.disable_remote_image

In my case when I was having the problem, I THINK it said

mailnews.message_display.disable_remote_image user set boolean false

and I double clicked that entry, and it toggled to

mailnews.message_display.disable_remote_image default boolean true

I'm not sure how fast this worked or if it needed restarting, but I did close and restart, now so far it APPEARS that the problem is solved on most (but not all e-mails), and I'm again seeing that gray "Load Images" button on the top right of every e-mail, with the left side offering me to make it permanent "Click here to always load remote images from xxxxxxxx@xxxxxx.com.". This is what I was striving for.

On a few senders, it was still loading, but I know I'd whitelisted them before. I went in and deleted the multiple address book entries for them, and added one, making sure that "Allow remote images in HTML mail" was not checked on that address card, then that one was fixed also, and I wasn't loading any remote images anywhere, I think.

This was bad because dozens of spammers got their images loaded over the last few days, confirming my address and guaranteeing I'll get more from them.

DanRaisch
Moderator

User avatar
 
Posts: 123551
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted July 9th, 2020, 4:11 am

Locking due to the age of the original posts (2 years). Given that MS dropped support for Win 98 in 2006 and TB version 2.0.0.23 has been obsolete for almost 5 years this is a rather case specific issue. The thread will be available for reading but no new posts will be accepted.

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 9 guests