MozillaZine

After browser upgrade autostart setting file ignored

User Help for Mozilla Firefox
abcuser
 
Posts: 261
Joined: March 12th, 2007, 11:19 pm

Post Posted March 15th, 2018, 8:54 am

Hi,
I was using Firefox 58 on Ubuntu 16.04 now and in profile directory I have my Firefox settings in file: $HOME/.mozilla/firefox/<profile>/user.js
Up until now for years this was working fine. But few minutes ago my Firefox has upgraded to Firefox 59 and now my settings file looks like not getting recognized any more, because non of the setting from this file is applied to Firefox when it starts-up.

To be sure. I have copied user.js file to save location, closed down Firefox, deleted directory $HOME/.mozilla/ and reopened Firefox. Firefox created clean profile. I have closed down Firefox and I copied my setting file back to $HOME/.mozilla/firefox/<profile>/user.js and started Firefox again. It just does nothing with my setting file - it does not apply the settings.

Has there changed something regarding the auto-start commands or is there a bug?
Regards
Last edited by abcuser on May 11th, 2018, 11:57 am, edited 5 times in total.

therube

User avatar
 
Posts: 19116
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted March 16th, 2018, 12:23 pm

Maybe this (fixed in FF 60)?

If a line with bad syntax is added to prefs.js by the user, then the entire file is ignored.
(And then I look at the dates & :rolleyes:.)

Or maybe not.

Test in a new, clean Profile (which it appears you've already done).
Create some dummy pref, saved in user.js.

user_pref("DUMYPREF.TEST", "XXXXXXXXXXXXXXXXXXXXX");
(Only that single pref, not whatever you may have in your existing user.js.)

Load that Profile.
Open, about:config, & see if DUMYPREF.TEST shows up in there?


Bug 1428233 user.js does not override about:config in some cases
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

abcuser
 
Posts: 261
Joined: March 12th, 2007, 11:19 pm

Post Posted March 17th, 2018, 6:17 am

@therube, I have deleted the content of user.js file and inserted only text:
Code: Select all
user_pref("DUMYPREF.TEST", "XXXXXXXXXXXXXXXXXXXXX");

and restarted Firefox. I can clearly see DUMYPREF.TEST in about:config now, so user.js file at least is not ignored.

Now I have emptied content of user.js file and only added one of my many settings to turn browser into Private Browsing by default:
Code: Select all
lockPref("browser.privatebrowsing.autostart", true);

and restarted Firefox. I searched for browser.privatebrowsing.autostart in about:config and it is still on default false.

Setting is ignored. Is there any way to find out WHY was it ignored or maybe even overwritten by something else?
P.S. Today browser was updated to 59.0.1 and problem is the same. I use default Ubuntu distribution version of Firefox.
Last edited by abcuser on March 17th, 2018, 6:46 am, edited 2 times in total.

abcuser
 
Posts: 261
Joined: March 12th, 2007, 11:19 pm

Post Posted March 17th, 2018, 6:44 am

Now I have downloaded Firefox 60 (currently in beta) directly from Mozilla web site: https://download.mozilla.org/?product=f ... lang=en-US

In my user.js file there is still one single line:
Code: Select all
lockPref("browser.privatebrowsing.autostart", true);


I started "Firefox 60 beta" from terminal using: ./firefox command and it displayed:
/home/<user>/.mozilla/firefox/oczh8kdb.default/user.js:1: prefs parse error: unknown keyword


At least Firefox 60 displays some error. Bravo! But my settings looks fine. I have searched for this string in about:config and this settings should be correct. Don't know what is wrong. Any idea?

EDIT: Additional test I have added all of my settings in user.js and in Firefox 60 all of the settings are recognized with the same above "unknown keyword" error.

abcuser
 
Posts: 261
Joined: March 12th, 2007, 11:19 pm

Post Posted March 18th, 2018, 2:43 am

Now I have only changed lockPref to user_pref in my user.js, so from:
Code: Select all
lockPref("browser.privatebrowsing.autostart", true);

with no effect to
Code: Select all
user_pref("browser.privatebrowsing.autostart", true);

and setting gets accepted by Firefox.

I prefer to have lockPref vs. user_pref, because if lockPref is used:
a) in about:config this kind of setting is marked italic and it is very easy to find out which settings I have done versus the setting some extension or similar is done,
b) the setting can't be changed by user or any other way like some extension, I just want to permanently disable it.

It looks to me that something is wrong with lockPref? Any idea is lockPref still supported or is there a bug in Firefox 59?

therube

User avatar
 
Posts: 19116
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted March 19th, 2018, 10:17 am

Did lockPref work, was it valid in user.js in the past?

Maybe something here?
MDN: A brief guide to Mozilla preferences
KB: Locking preferences
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

abcuser
 
Posts: 261
Joined: March 12th, 2007, 11:19 pm

Post Posted March 20th, 2018, 10:37 am

@therube, I have checked your links, but I have this implemented for several years. It just stopped working in Firefox 59. Can you check if this works for you?

Can you do two tests:
1. normal user_pref:
Code: Select all
user_pref("browser.privatebrowsing.autostart", true);

and start Firefox and check if this settings is changed in about:config
2. change setting to lockPref:
Code: Select all
lockPref("browser.privatebrowsing.autostart", true);

and start Firefox and check if this settings is changed in about:config

It looks to me:
a) a bug in Firefox,
b) something has been changed intentionally,
c) something I don't understand.

atlanto
 
Posts: 58
Joined: March 7th, 2015, 4:19 pm
Location: Japan

Post Posted March 20th, 2018, 8:12 pm

"default Ubuntu distribution version of Firefox" is being modified for the distro.
Ubuntu – Details of package firefox in xenial -> Ubuntu Changelog

Try "locked_pref" instead of "lockPref".

dickvl

User avatar
 
Posts: 52416
Joined: July 18th, 2005, 3:25 am

Post Posted March 20th, 2018, 9:00 pm

user.js is parsed and only accepts user_pref() lines AFAIK similar to prefs.js that is parsed as well.
If you want to use lockPref() then you need to use a mozilla.cfg file in the Firefox program folder.
mozilla.cfg is run as a JavaScript file and thus can have other code in the file.
https://developer.mozilla.org/en-US/Fir ... deployment Enterprise_deployment_before_60

abcuser
 
Posts: 261
Joined: March 12th, 2007, 11:19 pm

Post Posted March 21st, 2018, 8:24 am

atlanto wrote:Try "locked_pref" instead of "lockPref".

Excellent. This works! Thanks

dickvl

User avatar
 
Posts: 52416
Joined: July 18th, 2005, 3:25 am

Post Posted March 21st, 2018, 5:51 pm

See also:
Bug 440908 - Allow .js preference files to set locked prefs [60]

therube

User avatar
 
Posts: 19116
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted March 22nd, 2018, 8:14 am

So it was lock_Pref used in a mozilla.cfg file that worked for you?


(Just reposting Dick's links.)
Deploying Firefox in an enterprise environment (60+)
Deploying Firefox in an enterprise environment (before Firefox 60 ESR)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

abcuser
 
Posts: 261
Joined: March 12th, 2007, 11:19 pm

Post Posted March 22nd, 2018, 10:31 am

@therube. No, the only file I have is user.js (I don't have mozilla.cfg file) in my Firefox profile directory.
Firefox version 58 and bellow settings the following setting worked:
Code: Select all
lockPref("browser.privatebrowsing.autostart", true);

but since Firefox 59 I needed to change setting to:
Code: Select all
locked_pref("browser.privatebrowsing.autostart", true);


Thanks a lot to everybody for you suggestions, tips, links etc. Really appreciated it.

abcuser
 
Posts: 261
Joined: March 12th, 2007, 11:19 pm

Post Posted May 11th, 2018, 11:56 am

TWO MONTHS LATER.

In Firefox 58 and Firefox 59 autostart settings were working fine. Today browser was upgraded to Firefox 60 on Ubuntu 16.04 and this problem reappeared.

The only file I have related to autostart is saved in location: /home/myuser/.mozilla/firefox/oczh8kdb.default/user.js

Any idea what has changed and how to fix a problem again?

Code: Select all
// My config file

// Disable 'passive' mixed content
locked_pref("security.mixed_content.block_display_content", true);

// Set browser to 'private browsing' mode
locked_pref("browser.privatebrowsing.autostart", true);

// Disables "Press Esc to leave full screen"
locked_pref("full-screen-api.warning.timeout", 0);

// Disable 3DES cipher
locked_pref("security.ssl3.rsa_des_ede3_sha", false);

// Disable "I promise I will be careful" when entering about:config
locked_pref("general.warnOnAboutConfig", false);

Starting Firefox from terminal with command "firefox" and I get the following output:
Code: Select all
/home/myuser/.mozilla/firefox/oczh8kdb.default/user.js:4: prefs parse error: unknown keyword
/home/myuser/.mozilla/firefox/oczh8kdb.default/user.js:7: prefs parse error: unknown keyword
/home/myuser/.mozilla/firefox/oczh8kdb.default/user.js:10: prefs parse error: unknown keyword
/home/myuser/.mozilla/firefox/oczh8kdb.default/user.js:13: prefs parse error: unknown keyword
/home/myuser/.mozilla/firefox/oczh8kdb.default/user.js:16: prefs parse error: unknown keyword
alloc factor 0,900000 0,900000
alloc factor 0,900000 0,900000
alloc factor 0,900000 0,900000
alloc factor 0,900000 0,900000

therube

User avatar
 
Posts: 19116
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted May 12th, 2018, 5:37 am

You may need the ESR version of FF 60, no sure?

(There are differences between 60 & 60 ESR relating to things like the ability to use unsigned extensions, so maybe something here too?
Or maybe they just nixed locked_pref [or changed its name]?
60 also brings with it "group policy" support, so maybe just a general overhaul now affecting what used to be?

What a horrendous, IMO, way to present information.
Starting here, Deploying Firefox in an enterprise environment :cry:.
And yet another joke, Firefox for Enterprise.)

A New Preferences Parser for Firefox
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 12 guests