'400 Bad Request' - Firefox Only

User Help for Mozilla Firefox

User avatar
Posts: 19
Joined: May 13th, 2011, 12:58 pm

Post Posted March 9th, 2013, 10:03 pm

Got a new Actiontec C1000A modem. When using the modem's built-in website (, experienced the following problems with Firefox:

* Clicking links often results in a '400 Bad Request' (No request found) error
* Attempting to save configuration changes does not work, but does not report any error

These problems NEVER occur using Chrome or IE - just with Firefox!

I've seen numerous threads on the '400 Bad Request' on this and other forums. Have tried all suggestions - problems persist. Steps taken:

* Cleared cookies
* Cleared cache
* Run Firefox in Safe Mode
* Disabled all plugins
* Run Firefox with a new profile
* Disabled 'Tell websites I do not want to be tracked'
* Disabled IPv6

I'm out of ideas. Any NEW suggestions are appreciated...

UPDATE - Very odd. If I launch Fiddler Web Debugger, problems disappear! Close Fiddler and problems return.

UPDATE - Problems DO NOT occur in Safari or Opera either.
Last edited by claytoncarney on March 10th, 2013, 11:35 am, edited 1 time in total.


User avatar
Posts: 10433
Joined: October 24th, 2010, 8:51 am

Post Posted March 9th, 2013, 10:39 pm

Maybe Fiddler Web Debugger has changed the Default Proxy settings in Firefox so that it must be used to make a connection. Check Tools > Options > Advanced > Network and remove any Fiddler settings and choose "no proxy" and see what happens. I dont use any proxy so this is only a guess.
"The trouble with quotes on the internet is you never know if they are genuine" ...Abraham Lincoln

Posts: 763
Joined: December 30th, 2009, 11:25 pm

Post Posted March 9th, 2013, 10:45 pm

Fiddler is a web proxy and there must be some difference between the http request headers sent by Fiddler and those by Firefox. You can see the
request headers from Firefox by opening Firefox Button > Developer Tools > Web Console and clicking on the request line. Couldn't say how you
get the same info from Fiddler.


User avatar
Posts: 19
Joined: May 13th, 2011, 12:58 pm

Post Posted March 10th, 2013, 8:23 am

Thanks JayhawksRock: tried it with 'no proxy' - same results.

Thanks kreemoweet: Had not tried the Web Console before. Some interesting stuff there - need to investigate further...

BREAKING NEWS!!! Testing with previous versions conclusively proves that these problems were introduced between FF 14.0.1 and FF 15.0.

Does that fact clue anyone in on what's going wrong?


User avatar
Posts: 19
Joined: May 13th, 2011, 12:58 pm

Post Posted March 10th, 2013, 9:10 pm

OK, more info...

The C1000A modem uses micro_httpd for its HTTP server. The source code is about 300 lines. The only place where micro_httpd throws a 400 error is in the following snippet:

Code: Select all
if ( fgets( line, sizeof(line), stdin ) == (char*) 0 )
   send_error( 400, "Bad Request", (char*) 0, "No request found." );

This suggests that Firefox is sending an empty line in the request (or perhaps even a completely empty request), does it not?

This is really odd. Sometimes this occurs, other times not. When it does occur, hitting refresh will always fetch the page without error. Also, when a page successfully loads, if I click the link for the same page again, it always results in a 400 error.

The modem's website performs a connection status refresh via XHR every 3 seconds and there are sporadic 400 errors on those requests as well.

I have hammered IE, Chrome, Safari, and Opera and have NEVER received the 400 error (nor the failure to update configuration changes). It only happens in Firefox 15 and above.

BREAKING NEWS AGAIN!!! Using the Web Developer extension, if I select 'Cache -> Disable Cache -> Disable Entire Cache' OR I select 'Cache -> Disable Cache -> Check For Newer Version Of Page -> Check For Newer Version Of Page Every Time', both problems disappear completely.

Also, using the Firebug extension, if I select Net -> Disable Browser Cache, both problems disappear completely.

And finally, after setting about:config -> network.http.use-cache = false, both problems disappear completely.

What's up with that?!!! Looks like a bug in the browser cache.

P.S. - Sadly, I must report the same problem with Aurora!


User avatar
Posts: 19
Joined: May 13th, 2011, 12:58 pm

Post Posted March 14th, 2013, 9:24 am

CORRECTION - Even after setting network.http.use-cache to false, I still get 400 errors. Just not as frequently...

Same is true with Fx on Ubuntu 12 and Mint 14 VMs.

Same is true with a new install of Fx on a virgin, patched cloned VM of Windows 7.

Wits end here! I've been loyal to this browser ever since it was called FireBird. However, since about Fx 12, every week it's another new anomalous behavior. And every time, I can go to Chrome (or Safari, or Opera, or even IE) and have no problem.


Return to Firefox Support

Who is online

Users browsing this forum: Google [Bot] and 14 guests