MozillaZine

UI speed

Discussion of general topics about Mozilla Firefox
Lours
 
Posts: 1
Joined: November 10th, 2002, 5:53 am
Location: France

Post Posted November 10th, 2002, 6:00 am

Hello,

some may already have complained about this, but testing Phoenix I noticed that operating the UI (pressing buttons, opening menus, switching tabs, and so on) is extremely slow (as slow as NS6 is at such tasks to be precise) on my machine (a bi celeron 366 with 128Mb RAM under win2000).

Browsing and scrolling HTML document operates at a reasonable speed however every operation involving the UI elements is awfully slow (something like half or quarter of a second for each operation).

So I would like to know three things :
- is it normal ?
- what is it due to ? (XUL I presume and its loads of data for just 3 buttons and a menu bar)
- is it something that you plan to work on and enhance ?

Many thanks in advance and sorry if I am not posting to the right forum.

Regards,
Laurent

Thumper

User avatar
 
Posts: 8037
Joined: November 4th, 2002, 5:42 pm
Location: Linlithgow, Scotland

Post Posted November 10th, 2002, 6:05 am

I haven't seen this - on my old machine (P3 550) Phoenix was noticably faster than Mozilla in responding to UI events, and I've used it successfully on a P75 which took in excess of a minute to load Mozilla.

- Chris
Last edited by Thumper on November 10th, 2002, 8:48 am, edited 1 time in total.

penrou
 
Posts: 13
Joined: November 10th, 2002, 12:17 am

Post Posted November 10th, 2002, 8:18 am

Same results as Chris here. I'm running Phoenix as my primary browser on this machine (a P3-500 laptop), with no noticeable slowdown of any sort. I also have Netscape 7 installed on a P166 (don't blame me, I would have installed Phoenix/K-Meleon/Moz 1.2b myself), and although it loads slow as all heck, once it's loaded I have no problems browsing as usual.

Laptop is running Windows 2000, the P166 is on Windows 98.

penrou

Stefan

User avatar
 
Posts: 2051
Joined: November 5th, 2002, 2:46 am

Post Posted November 10th, 2002, 10:15 am

Lours wrote:So I would like to know three things :
- is it normal ?


No it's not normal, but it seems to happen to the occasional user.
I'm not sure if the developers have managed to track down exactly why this is though.

- what is it due to ? (XUL I presume and its loads of data for just 3 buttons and a menu bar)


XUL requires more resources then a native solution would, but slugishness of those proportions depends on something else.

You could try K-Meleon though, which might not have these problems on your setup.
http://kmeleon.sourceforge.net/

Return to Firefox General


Who is online

Users browsing this forum: No registered users and 6 guests