MozillaZine

SOLVED: v68.0 Makes My Videos Autoplay (YouTube and other)

Discussion of general topics about Mozilla Firefox
thechamlin
 
Posts: 237
Joined: June 13th, 2005, 8:47 pm

Post Posted July 14th, 2019, 9:15 pm

Solved this back in v63 with the about:config settings. As soon as v68.0 installed, my YT videos (and others) are autoplaying. Can anyone help?

1. I've got FF set to "block autoplay" in the general settings section.

2. My about:config settings are as follows:

dom.media.autoplay.... default boolean false

media.autoplay.allow-extension-background-pages ... default boolean true

media.autoplay.allow-muted modified boolean false

media.autoplay.blacklist-override-default default boolean true

media.autoplay.block-event.enabled default boolean false

media.autoplay.block-webaudio default boolean false

media.autoplay.default default integer 1

media.autoplay.enabled modified boolean false

media.autoplay.enabled.user-gestures-needed default boolean true

media.block-autoplay-until-in-foreground default boolean true

services.sync.prefs.sync.media.autoplay.default default boolean true
Last edited by thechamlin on July 15th, 2019, 9:07 am, edited 1 time in total.

baerd
 
Posts: 18
Joined: June 6th, 2004, 11:36 pm

Post Posted July 15th, 2019, 7:16 am


thechamlin
 
Posts: 237
Joined: June 13th, 2005, 8:47 pm

Post Posted July 15th, 2019, 9:06 am

The same initial solution that worked for the reddit poster worked for me as well: SOLVED: media.autoplay.enabled.user-gestures-needed = false Thanks, baerd, that thread has good info. Pasting it here for forum user ease.


Video autoplay blocking in Firefox 69 and newer:

Block Audio and Video in Options/Preferences for Autoplay (partial solution):

https://www.ghacks.net/2019/06/18/block ... -natively/

https://www.reddit.com/r/firefox/commen ... and_video/

Try all these settings in about:config to block video autoplay completely (with sound and no sound):

media.autoplay.default = 5 (corresponds to Block Audio and Video in Options/Preferences for Autoplay (link))

media.autoplay.block-webaudio = true

media.autoplay.enabled.user-gestures-needed = false (link, link)

media.autoplay.enabled (link, link) and media.autoplay.allow-muted (link) were removed

Video autoplay blocking in Firefox 63 and newer:

Try all these settings in about:config to block video autoplay completely (with sound and no sound):

media.autoplay.default = 1

media.autoplay.allow-muted = false

media.autoplay.block-webaudio = true

media.autoplay.enabled.user-gestures-needed = false (link, link)

media.autoplay.enabled was available in earlier versions but it has been removed in Firefox 63 (link)

Install add-on Disable HTML5 Autoplay (link).

(Source/explanation for settings: https://www.ghacks.net/2018/09/21/firef ... -blocking/)

Return to Firefox General


Who is online

Users browsing this forum: No registered users and 2 guests