MozillaZine

YouTube keeps going back to new layout

Discussion of general topics about Mozilla Firefox
max2
 
Posts: 251
Joined: September 17th, 2011, 5:37 pm

Post Posted January 27th, 2018, 3:35 am

Thanks again I really needed this!

L.A.R. Grizzly

User avatar
 
Posts: 5343
Joined: March 15th, 2005, 5:32 pm
Location: Akron, Ohio, USA

Post Posted March 28th, 2018, 12:37 pm

I recently noticed that FX and SM are now displaying the new YouTube layout. I had previously selected the old layout in both browsers. I tried Frank's general user agent switch on the previous page, but it doesn't work. I don't have a YouTube account to be able to change it in the page settings. One thing I notice is that Pale Moon still serves up the old layout. I tried using the PM user agent for YouTube, but that didn't work either. Am I stuck with the new layout if I choose NOT to have a YouTube account? Any help would be appreciated! [-o<
Win7 Pro SP1 64 Bit
Comodo Internet Security
Pale Moon 28.2.1, Firefox 52.9.0esr, SeaMonkey 2.48, FossaMail 38.9.4 and Thunderbird 52.9.1

Frank Lion

User avatar
 
Posts: 20080
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted March 28th, 2018, 2:04 pm

L.A.R. Grizzly wrote:Am I stuck with the new layout if I choose NOT to have a YouTube account? Any help would be appreciated! [-o<

I don't have an account there, so this is what I do....I have cookies set to expire after session or however they phrase. For YouTube, I brought up the site and then I left clicked the urlbar favicon to bring up Page Info and selected 'Allow Cookies', i.e. just for that site.

You then select the old layout and disable Autoplay and it then just remembers that 'forever'. The site will also set a couple more cookies, but as I'm not using any account there, then I'm not bothered.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

L.A.R. Grizzly

User avatar
 
Posts: 5343
Joined: March 15th, 2005, 5:32 pm
Location: Akron, Ohio, USA

Post Posted March 28th, 2018, 3:13 pm

Frank Lion wrote:You then select the old layout and disable Autoplay and it then just remembers that 'forever'. The site will also set a couple more cookies, but as I'm not using any account there, then I'm not bothered.


I allowed the cookies for YouTube as you described. How do you select the old layout? I see no links to doing so unless you have an account.
Last edited by L.A.R. Grizzly on March 28th, 2018, 4:15 pm, edited 2 times in total.
Win7 Pro SP1 64 Bit
Comodo Internet Security
Pale Moon 28.2.1, Firefox 52.9.0esr, SeaMonkey 2.48, FossaMail 38.9.4 and Thunderbird 52.9.1

Frank Lion

User avatar
 
Posts: 20080
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted March 28th, 2018, 4:11 pm

L.A.R. Grizzly wrote:I allowed the cookies for YouTube as you described. How do you select the old layout? I see no links to doing so unless you have an account.

When I did it, there was a Settings or maybe a 3 line Hamburger in the top right and I changed it there, without signing in.

In the old layout, the Hamburger is up in the top left. It's possible they've changed something since I did it.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

L.A.R. Grizzly

User avatar
 
Posts: 5343
Joined: March 15th, 2005, 5:32 pm
Location: Akron, Ohio, USA

Post Posted March 28th, 2018, 4:15 pm

Frank Lion wrote:When I did it, there was a Settings or maybe a 3 line Hamburger in the top right and I changed it there, without signing in.


That is now gone. In the upper right corner, there is a link to Settings which directs you to sign in to YouTube through Google or Create and Account (which I don't want to do)

I found the answer here: https://www.youtube.com/watch?v=qeAgxcM9tIk

You have to edit a cookie using the Web Developer Inspector Tool. You need to edit the "PREF" cookie. That worked for both FX and SM. Now I have the old layout back (until March 2020 when the cookie expires).
Win7 Pro SP1 64 Bit
Comodo Internet Security
Pale Moon 28.2.1, Firefox 52.9.0esr, SeaMonkey 2.48, FossaMail 38.9.4 and Thunderbird 52.9.1

Return to Firefox General


Who is online

Users browsing this forum: No registered users and 1 guest