MozillaZine

HTML File Opening troubles w/Phoenix

Discussion of general topics about Mozilla Firefox
rincewind1013
 
Posts: 5
Joined: November 25th, 2002, 3:31 pm

Post Posted November 25th, 2002, 3:32 pm

So I have an annoying little problem
Here are some pictures, then I'll explain
Image
Image
Image
Basically if an html file is in a directory containing a space, like desktop, which is in C:\Documents and Settings\user\Desktop, Phoenix goes screwy and the results are seen above. I'm pretty sure this is happening b/c I was messing around with File Types this morning to get that pretty icon you see, and I might have messed with the 'open' action and really messed things up w/o knowing.

Here's what I've done to fix the situation
Deleted HTM HTML file types.
Gave control to IE as default browser. Made sure everything was ok, opening files and everything.
Then installed Mozilla 1.2b, set it as default. Again, made sure everything was ok, opening files with no troubles.
Then installing the latest nightly, 20021119, of Phoenix, which I've used since the 19th and it has been dandy. But, I'm greeted with the same window, The file /C:/Documents cannot be found. Please check the location and try again. :(

Isn't the parentheses around the %1 supposed to fix that problem?
So I don't know what to do? Any ideas? Please?

RAF
Moderator

User avatar
 
Posts: 12606
Joined: November 5th, 2002, 2:19 pm
Location: .nl

Post Posted November 25th, 2002, 3:42 pm

I have no idea how to solve this but I have exactly the same problem...

rincewind1013
 
Posts: 5
Joined: November 25th, 2002, 3:31 pm

Post Posted November 25th, 2002, 4:08 pm

Well, someone told me it was a bug introduced with the 20021118 nightly, if you go back to the 20021114 nightly, all is fixed.
You can get it here, http://seb.delahaye.net/phoenix/

flii

User avatar
 
Posts: 2208
Joined: November 6th, 2002, 11:29 pm
Location: hickville, south dakota

Post Posted November 25th, 2002, 4:50 pm

i manually changed the edit myself. just hit the browse button when edit is selected and find your fav text editor. if you tried that and it didn't work, sorry. :( it worked for me.


winme, 11-14 nightly, context text editor (utilizing the "replace notepad" option, which in this case shouldn't matter, though)

djst
Moderator

User avatar
 
Posts: 2826
Joined: November 5th, 2002, 1:34 am
Location: Sweden

Post Posted November 25th, 2002, 5:48 pm

rincewind1013 wrote:So I have an annoying little problem
Here are some pictures, then I'll explain
Basically if an html file is in a directory containing a space, like desktop, which is in C:\Documents and Settings\user\Desktop, Phoenix goes screwy and the results are seen above. I'm pretty sure this is happening b/c I was messing around with File Types this morning to get that pretty icon you see, and I might have messed with the 'open' action and really messed things up w/o knowing.


This was a <a href="http://bugzilla.mozilla.org/show_bug.cgi?id=181018">known bug</a>, and it has been fixed in the latest nightly.

ehume

User avatar
 
Posts: 6743
Joined: November 17th, 2002, 12:33 pm
Location: Princeton, NJ, USA

Post Posted November 25th, 2002, 7:54 pm

"....\Phoenix.exe" "-url" "%1"

Any spaces in the address (e.g.--"Program Files") have to be enclosed in the first set of quotes--all one string. Then each command must be enclosed by a quote.

Ed

Return to Firefox General


Who is online

Users browsing this forum: No registered users and 5 guests