MozillaZine

Can't Stop Videos from Playing

Discussion of general topics about Mozilla Firefox
tommyk
 
Posts: 109
Joined: July 7th, 2005, 11:03 am

Post Posted November 19th, 2020, 2:57 pm

I've clicked on block Audio/Video from playing but videos keep playing.

What other options do I have?

DanRaisch
Moderator

User avatar
 
Posts: 123881
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted November 19th, 2020, 3:03 pm

Could you identify a specific site where you are seeing this issue?

BobbyPhoenix

User avatar
 
Posts: 176
Joined: April 24th, 2014, 5:58 am

Post Posted November 19th, 2020, 4:24 pm

Not all sites respect it. I have a couple that always autoplay no matter what I try.
Do, or do not. There is no try.

tommyk
 
Posts: 109
Joined: July 7th, 2005, 11:03 am

Post Posted November 22nd, 2020, 8:26 am

Sorry, just got back onto this after time away.

Most websites auto play their videos that I've go to including ESPN, The Hill and too many others to mention.

I don't want to have to enter all websites on the Block Audio/Video option since they'll be too many to list!

WaltS48

User avatar
 
Posts: 4522
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted November 22nd, 2020, 10:01 am

Then set "Block Audio and Video" in the Autoplay setting as the default and only allow the ones you want.

No videos autoplay for me at ESPN.
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

tommyk
 
Posts: 109
Joined: July 7th, 2005, 11:03 am

Post Posted November 23rd, 2020, 10:48 am

WaltS48 wrote:Then set "Block Audio and Video" in the Autoplay setting as the default and only allow the ones you want.

No videos autoplay for me at ESPN.


I've done that and the videos still play.

Do I have to enter all websites that play videos?

Shouldn't the Auto Block work on any and all websites that have videos?

BobbyPhoenix

User avatar
 
Posts: 176
Joined: April 24th, 2014, 5:58 am

Post Posted November 23rd, 2020, 11:14 am

It "should" work on all websites, but the websites don't respect the option. Like others have said it's not a 100% solution. Same like the good ol' "Do Not Track". Websites just don't care. ESPN for me is the worst. Even if I go into the setting on ESPN, and disable autoplay, it only lasts for that visit. Next time there they are again. UGH
Do, or do not. There is no try.

tommyk
 
Posts: 109
Joined: July 7th, 2005, 11:03 am

Post Posted November 23rd, 2020, 1:45 pm

So it's useless and I'm stuck with loud and obnoxious videos playing at any time!?

WaltS48

User avatar
 
Posts: 4522
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted November 24th, 2020, 7:36 am

You can't click the Mute icon in the tab, right-click and select Mute Tab, close the videos or other options?
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

tommyk
 
Posts: 109
Joined: July 7th, 2005, 11:03 am

Post Posted November 26th, 2020, 8:37 am

I can click on the mute button once they start playing but they start playing without any notice while I'm reading an article. It's a nuisance to have to keep muting the video all the time!

If Firefox has a block audio/video option and I click it why doesn't it work?

4td8s
 
Posts: 710
Joined: June 24th, 2009, 1:07 pm

Post Posted Today, 4:39 am

tommyk wrote:
I've done that and the videos still play.

Do I have to enter all websites that play videos?

Shouldn't the Auto Block work on any and all websites that have videos?


those ESPN videos do not autoplay on my end when I have both Noscript & uBO (ublock origin) addons installed & enabled in the Firefox 78.5 ESR browser that I'm using :D

guess that happens when you don't have either one or both of those essential addons installed

Return to Firefox General


Who is online

Users browsing this forum: No registered users and 3 guests