MozillaZine

2.53 unofficial and gecko version

Discussion about Seamonkey builds
frg
 
Posts: 731
Joined: December 15th, 2015, 1:20 pm

Post Posted February 24th, 2019, 3:42 pm

I got tired of lousy websites telling me to upgrade to a later version. Updated Gecko from 56 to 60 in the unofficial builds. The next one tomorrow should have it. Does not help for google because they really also do some sh*tty user agent sniffing only.

github should be ok now. At least no longer gives me the finger.

If it breaks too many sites I will back it out. Let me know how it goes.

FRG

4td8s
 
Posts: 638
Joined: June 24th, 2009, 1:07 pm

Post Posted March 2nd, 2019, 9:10 pm

if it's the SM 2.53 build from wg9s then that's the one I'm using on another PC running Win7 x64.

Sometime in July 2019 (most likely when Mozilla releases a new Firefox ESR version, 68), I will run only SM 2.53 or higher versions and will discontinue using any SM 2.49.x version for good

ndebord

User avatar
 
Posts: 767
Joined: December 7th, 2002, 9:53 am

Post Posted March 3rd, 2019, 5:58 am

4td8s wrote:if it's the SM 2.53 build from wg9s then that's the one I'm using on another PC running Win7 x64.

Sometime in July 2019 (most likely when Mozilla releases a new Firefox ESR version, 68), I will run only SM 2.53 or higher versions and will discontinue using any SM 2.49.x version for good


4td8s,

Yes, 2.53 works mainly for me too, aside from a few extensions.
-N-
Early Blue, Dell D420, Windows 7 Ultimate, AvastFree, Scotty is on Patrol and MalwareBytesPremium
Quis custodiet ipsos custodes

therube

User avatar
 
Posts: 19757
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted May 5th, 2019, 4:50 am

aside from a few extensions

Which?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

4td8s
 
Posts: 638
Joined: June 24th, 2009, 1:07 pm

Post Posted May 19th, 2019, 1:47 am

ndebord is still not talking which extensions didn't work for him in SM, therube
looking at wg9s's SM 2.53 builds lately, which have not been updated since 4/25/2019

Rob_S
 
Posts: 691
Joined: December 13th, 2007, 8:54 am
Location: Vancouver Island BC

Post Posted June 5th, 2019, 9:08 pm

JUst FYI, i tried installing a copy of version 2.53 64 bit over my existing 2.49.5. Doing this gave me two copies of seamonkey installed, both running on the same profile. Since I did not realize this, I used the old version next run, and lost my history. No big problem.

I also had to re-install Lightning for it to work with 2.49 again, as I could not find a lightning version to work with 2.53. Does anyone have lightning working on 2.53?

frg
 
Posts: 731
Joined: December 15th, 2015, 1:20 pm

Post Posted June 6th, 2019, 2:32 am

> JUst FYI, i tried installing a copy of version 2.53 64 bit over my existing 2.49.5.

Probably an x86 and x64 mismatch aka. you ran the 32 bit 2.49.5 side by side with 2.53 64 bit. Uninstall 2.49.5 before you install 2.53. Lightining is included in 2.53. If it does not show up uninstall Lightning and clear all extensions.installedDistroAddon.* keys in about:config.

TPR75
 
Posts: 744
Joined: July 25th, 2011, 8:11 am
Location: Poland

Post Posted June 6th, 2019, 4:39 am

frg wrote:I got tired of lousy websites telling me to upgrade to a later version. Updated Gecko from 56 to 60 in the unofficial builds.


How about official "interim" SeaMonkey 2.53? Gecko will be 56 or newer 60?

4td8s
 
Posts: 638
Joined: June 24th, 2009, 1:07 pm

Post Posted June 7th, 2019, 9:19 am

TPR75 wrote:
frg wrote:I got tired of lousy websites telling me to upgrade to a later version. Updated Gecko from 56 to 60 in the unofficial builds.


How about official "interim" SeaMonkey 2.53? Gecko will be 56 or newer 60?


SM 2.53 from wg9s is based on Gecko 56. 2.57 from him is based on Gecko 60

TPR75
 
Posts: 744
Joined: July 25th, 2011, 8:11 am
Location: Poland

Post Posted June 7th, 2019, 10:55 am

4td8s wrote:
TPR75 wrote:
frg wrote:I got tired of lousy websites telling me to upgrade to a later version. Updated Gecko from 56 to 60 in the unofficial builds.


How about official "interim" SeaMonkey 2.53? Gecko will be 56 or newer 60?


SM 2.53 from wg9s is based on Gecko 56. 2.57 from him is based on Gecko 60


Are you sure about this...?

Code: Select all
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 SeaMonkey/2.53
Build identifier: 20190605152305


:-"

frg
 
Posts: 731
Joined: December 15th, 2015, 1:20 pm

Post Posted June 8th, 2019, 3:22 am

2.53 uses Gecko 56 with many many backports. Says 60 just to please the growing numbers of dumb websites doing idiotic user agent sniffing.

Feature wise not yet 60 but surpassed 56 a while ago. TLS 1.3 and NSS support is even beyond 60.

LordOfTheBored
 
Posts: 282
Joined: December 7th, 2005, 8:36 pm

Post Posted June 8th, 2019, 10:33 pm

frg wrote:2.53 uses Gecko 56 with many many backports. Says 60 just to please the growing numbers of dumb websites doing idiotic user agent sniffing.
Ordinarily, I'd be concerned about the precedent this sets, but... in this case I fully approve of lying about version numbers. If websites are going to be stupid and try to lock out browsers, we just have to be even stupider so they're left dumbfounded.

Heck, that's the same reason almost every useragent starts with "mozilla/", regardless of whether it is descended from Netscape Navigator. The string has a long and proud tradition of lying to defeat poorly-coded sites.

Rob_S
 
Posts: 691
Joined: December 13th, 2007, 8:54 am
Location: Vancouver Island BC

Post Posted June 13th, 2019, 8:57 am

"Uninstall 2.49.5 before you install 2.53. Lightining is included in 2.53"

Thank you very much, this seems to have solved all my problems so far

Rob_S
 
Posts: 691
Joined: December 13th, 2007, 8:54 am
Location: Vancouver Island BC

Post Posted June 16th, 2019, 9:07 pm

Pretty much all is well here with 2.53 64 bit, except Flashgot is not working for me.

It displays the dialog of available downloads, but I am not able to check-select the ones I might want.

Any ideas or suggestions for that issue?

therube

User avatar
 
Posts: 19757
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 17th, 2019, 3:09 am

Are you using 1.5.6.14rc1?

It may or may not work particularly well (generally not) on Youtube, but otherwise should be working just fine everywhere.
(Hasn't been updated in ages & except for YT, no issues.)

https://www.youtube.com/watch?v=PVimPk0 ... adio=1&t=4
All I see there is a single audio .m4a & a single video .m4a.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Return to SeaMonkey Builds


Who is online

Users browsing this forum: No registered users and 2 guests