MozillaZine

Border colors are broken in the UI

Discussion about Seamonkey builds
Pim

User avatar
 
Posts: 2205
Joined: May 17th, 2004, 2:04 pm
Location: Netherlands

Post Posted February 1st, 2018, 2:03 am

The latest SeaMonkey, 2.57a1, now works again, mostly. It still has issues, but it's functional!
One thing I notice is that the Modern theme is broken, obviously because the properties -moz-border-top-colors, -moz-border-right-colors, -moz-border-bottom-colors and -moz-border-left-colors no longer work. All the UI elements have thick black borders now.

In https://developer.mozilla.org/en-US/Firefox/Releases/59 I read that these properties have been disabled, which would account for the problem. Now someone needs to redesign this theme; so far so good.
However, the same page also says that these properties "have been limited to usage in chrome code only".
That's where I get confused. Has something gone wrong? I mean, a theme is chrome code, right? Doesn't that mean it should still work?
Groetjes, Pim

frg
 
Posts: 628
Joined: December 15th, 2015, 1:20 pm

Post Posted February 2nd, 2018, 1:44 am

Known problem but I think there is no bug yet. All the breakage is a bit overwhelming. The moz-border colors are gone in 2.57 / 60 and need to be replaced with border derivates. Unfortunately not 1:1 in all cases.

Pim

User avatar
 
Posts: 2205
Joined: May 17th, 2004, 2:04 pm
Location: Netherlands

Post Posted February 2nd, 2018, 1:57 am

Thanks. That's what I gather, yes, but what got me confused is that the linked page specifically says

The proprietary -moz-border-top-colors, -moz-border-right-colors, -moz-border-bottom-colors, and -moz-border-left-colors properties have been limited to usage in chrome code only

which sounds like it should keep working for themes. That's why I asked.
Groetjes, Pim

Return to SeaMonkey Builds


Who is online

Users browsing this forum: No registered users and 2 guests