MozillaZine

100% CPU while loading image

Discussion of bugs in Seamonkey
coffeebreaks
 
Posts: 14
Joined: November 8th, 2002, 7:16 am

Post Posted December 18th, 2002, 2:50 am

WARNING will hang your mozilla

go to read http://lwn.net/Articles/18297/
Click on link# 19: http://www.microcomaustralia.com.au/debian/net-1440.img
Boom.

Using Mozilla 1.2.1
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021208 Debian/1.2.1-2

Anybody can reproduce this?
No sig. is a sig.

Ploum

User avatar
 
Posts: 245
Joined: November 11th, 2002, 3:14 am

Post Posted December 18th, 2002, 3:03 am

I reproduce it with mozilla 1.1 under Debian woody !
Image

jgraham

User avatar
 
Posts: 558
Joined: November 28th, 2002, 10:20 am
Location: Cambridge, UK

Post Posted December 18th, 2002, 6:52 am

Well, clicking on the link you provided to the .img file didn't hang 2002121308/win98. In fact all you get is a load of random characters - it appears to be a disk image(? without looking at the screen), and I guess it should be sent as application/octet-stream rather than text/plain. This would cause the file download dialog to appear, rather than displaying the file.

In any case, if it really does hang with 1.1/1.2.1 then the bug appears to be fixed now. However, I suspect that the mime type of the file needs to be changed at the server end.

ThomasB
 
Posts: 20
Joined: November 5th, 2002, 4:20 am

Post Posted December 18th, 2002, 8:29 am

no hang on moz 1.1 / win98. as jgraham said, just a bunch of char's ...

ghola
 
Posts: 191
Joined: December 1st, 2002, 1:57 pm

Post Posted December 18th, 2002, 1:54 pm

Does not hang with 1.2.1 on W2K, but it's close: Very high CPU load when M attempts to display the binary data and slow response.

Return to SeaMonkey Bugs


Who is online

Users browsing this forum: No registered users and 1 guest