MozillaZine

UserAgent Site Specific Overrides bug

Discussion of bugs in Seamonkey
TPR75
 
Posts: 588
Joined: July 25th, 2011, 8:11 am
Location: Poland

Post Posted February 7th, 2017, 4:11 am

I've noticed some strange behavior in SeaMonkey 2.46 and it looks like a bug.

I'm not using Firefox compatibility mode because I don't want to imitate Fx and make thus false statistics. Unfortunately, some sites are requesting specific browsers (instead of functions). For such sites I'm using "UserAgent Site Specific Overrides" function.

I've been informed about one bank in Poland with strange behavior when SM is using override function when trying to login:
https://secure.getinbank.pl/
1) if user have SeaMonkey UA then is informed about "wrong browser"
2) if override function is set up (via "about:config"):
Code: Select all
user_pref("general.useragent.override.getinbank.pl", "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0 SeaMonkey/2.46");

... then above site is reloading all the time and without pause, immediately.
3) only compatibility mode works correct.
I'm not their client/customer so I can't complain about "wrong browser".

But I was curious how it is possible for website to not detect UA... and after some testing (new profiles, different systems, portable versions) it looks like a bug in SeaMonkey 2.46 (both Windows and Linus version; Linux Mint 18 Sarah) because version 2.40 works correct. I've set up in SM 2.40 the same UA like for 2.46 (see: above code) and bank's website loaded correctly.

I don't know how it is possible because User Agent override works correct for UA recognition site like:
http://www.whatsmyip.org/more-info-about-you/

I hope it's just a bug that can be fixed not some "Fx code castration's fallout"... [-o<

isaacschemm
 
Posts: 212
Joined: January 20th, 2015, 12:29 pm

Post Posted February 7th, 2017, 6:52 am

It's possible that a website could be checking the "rv:" number inside the parentheses. I don't know if that's the case here though. (Anyway, such behavior is probably discouraged ever since IE 11 decided to use "rv:" too and kept getting detected as Firefox 11...)

barbaz
 
Posts: 1664
Joined: October 1st, 2014, 3:25 pm

Post Posted February 7th, 2017, 10:14 am

Site-specific overrides are partially broken in 2.46 - viewtopic.php?f=6&t=3021425
*Always* check the changelogs BEFORE updating that important software!

therube

User avatar
 
Posts: 17529
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted February 7th, 2017, 10:53 am

(That's weird. Initially the override seemed to work. Then I opened the site in a new window & after that, now I just get the looping.)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Return to SeaMonkey Bugs


Who is online

Users browsing this forum: No registered users and 1 guest