MozillaZine

stylesheet link title attribute bug

Discussion of bugs in Seamonkey
cdwright
 
Posts: 6
Joined: December 11th, 2002, 2:58 pm

Post Posted December 15th, 2002, 9:30 am

I've looked in BugZilla but I couldn't find any reference to it.

Mozilla 1.2.1
Phoenix 0.5

I'm going to switch from titles to ids for my use of them but...

I have a page with 4 rel="stylesheet" links.
If one of these links has a non-empty title (ie neither title="" nor unspecified)
attribute then all the stylesheets are ok.
However if more than one link has a non-empty title the 2nd
to nth stylesheets are disabled.

Here's a link to some basic test pages

http://cdwright.icraftedit.com/css/cssnotitles.htm

Does anyone know of a BugZilla for it that I couldn't find?

WeSaySo
 
Posts: 475
Joined: November 5th, 2002, 8:22 am
Location: Earth

Post Posted December 15th, 2002, 10:47 am

cdwright wrote:I have a page with 4 rel="stylesheet" links.
If one of these links has a non-empty title (ie neither title="" nor unspecified)
attribute then all the stylesheets are ok.
However if more than one link has a non-empty title the 2nd
to nth stylesheets are disabled.

Here's a link to some basic test pages

http://cdwright.icraftedit.com/css/cssnotitles.htm

Does anyone know of a BugZilla for it that I couldn't find?


Read HTML4 sec 14.3 (and 14.3.2). It deals with alternate stylesheets and how to differentiate them by using the title attribute. This is why you are seeing your 'bug'.
Ad astra

cdwright
 
Posts: 6
Joined: December 11th, 2002, 2:58 pm

Post Posted December 16th, 2002, 5:29 am

Thank you. I had looked at the W3C but didn't see that section.

Seems like a hack to me. :-)

rel="preferred <thing>" would be better. Oh well.

Lack of support in IE then. :-)

Return to SeaMonkey Bugs


Who is online

Users browsing this forum: No registered users and 1 guest