MozillaZine

[Ext]Show Parent Folder

Announce and Discuss the Latest Theme and Extension Releases.
bugblatter
 
Posts: 56
Joined: June 21st, 2005, 12:31 am

Post Posted September 8th, 2016, 9:03 am

Just a minor bug note: (I know alice isn't supporting this anymore but if anyone else is interested)

If you have it set to reverse hierarchy (so lowest parent first), then if the first parent folder shown starts with an 's', that letter gets chopped off.
So "shopping<things to do<atlantis" is displayed as "hopping<things to do<atlantis"

If you want to fix it, this seems to work.
Go to showParentFolder@alice.xpi\chrome\content\overlay3.7.js: line 56:
Code: Select all
                folderTitle = folderTitle.replace(/^\s/,""); \

Then change '\s' to ' '; that is, replace those two characters (\s) with a single space.
Code: Select all
                folderTitle = folderTitle.replace(/^ /,""); \

I suspect there is some unexpected extra backslash processing going on.

Alice0775

User avatar
 
Posts: 2428
Joined: October 26th, 2007, 11:25 pm
Location: OSAKA

Post Posted September 11th, 2016, 1:16 pm

Thanks @ bugblatter
Please try Version 2.1.1(not yet reviewed) if still interested
Mozilla products are unreliable!!!!

If it ain't broke, don't fix it. Stop rapid release without automated test!
Now, Firefox lacks reliability. Storm of regression bugs. Let's switch to Chrome.

bugblatter
 
Posts: 56
Joined: June 21st, 2005, 12:31 am

Post Posted September 12th, 2016, 12:22 pm

Just tested it out. Works great now. Thanks.

davidhedlund
 
Posts: 2
Joined: October 30th, 2015, 7:00 am

Post Posted October 15th, 2016, 12:52 pm

Alice0775 wrote:Thanks @ bugblatter
Please try Version 2.1.1(not yet reviewed) if still interested


I want to help you by adding Swedish locale. Please send what you need to be translated.

keithy397

User avatar
 
Posts: 2334
Joined: August 29th, 2004, 6:49 pm
Location: North Wales, UK.

Post Posted March 10th, 2017, 2:28 am

I have just noticed SPF isn't working for me. Is it anything to do with the fact Firefox has just been upgraded to 52?
Cheers,
Keith

bugblatter
 
Posts: 56
Joined: June 21st, 2005, 12:31 am

Post Posted March 10th, 2017, 4:50 pm

It's working for me on ff52. Have you tried any debug? Maybe I can help.

keithy397

User avatar
 
Posts: 2334
Joined: August 29th, 2004, 6:49 pm
Location: North Wales, UK.

Post Posted March 11th, 2017, 4:34 am

bugblatter wrote:It's working for me on ff52. Have you tried any debug? Maybe I can help.

I wouldn't know where to start!! Your help would be appreciated, thank you. :wink:
Cheers,
Keith

DanRaisch
Moderator

User avatar
 
Posts: 115064
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted March 11th, 2017, 5:00 am

Did you confirm that you have the latest version of the extension?
Does ot work if you disable all extensions except SPF?

bugblatter
 
Posts: 56
Joined: June 21st, 2005, 12:31 am

Post Posted March 11th, 2017, 6:39 am

Like Dan said. I have SPF 2.1.1 (Sept'16). Could be a conflict with another bookmark/library-related extension, so I would try disabling those first (before disabling them all).

keithy397

User avatar
 
Posts: 2334
Joined: August 29th, 2004, 6:49 pm
Location: North Wales, UK.

Post Posted March 11th, 2017, 8:54 am

What a wally! I forgot to enable it from the 'View' menu.....

Thanks for your help, sorry for my poor memory...!
Cheers,
Keith

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 1 guest