MozillaZine

[EXT] S3.Translator

Announce and Discuss the Latest Theme and Extension Releases.
pag77
 
Posts: 1530
Joined: December 26th, 2013, 10:46 pm

Post Posted April 25th, 2016, 1:03 am

version 5.22 is released
https://addons.mozilla.org/addon/s3google-translator/

changes:
added: hiiden settings for ability to select milliseconds to see the floating icons when select text: extensions.s3gt.translate_selection_timer // in milliseconds
updated: German locale (thanks Thomas.Weber)

happysurf

User avatar
 
Posts: 349
Joined: January 20th, 2011, 3:14 am

Post Posted May 3rd, 2016, 9:47 am

In the Browser Console with Firefox 47beta and e10s activated there are many "unsafe CPOW usage" JS errors related to utils.js and tooltip.js.
Surf the Internet is a dirty job but someone has to do it.

pag77
 
Posts: 1530
Joined: December 26th, 2013, 10:46 pm

Post Posted May 3rd, 2016, 10:50 am

happysurf wrote:In the Browser Console with Firefox 47beta and e10s activated there are many "unsafe CPOW usage" JS errors related to utils.js and tooltip.js.

warning errors or critical errors?
addon normally works or stops working?

happysurf

User avatar
 
Posts: 349
Joined: January 20th, 2011, 3:14 am

Post Posted May 4th, 2016, 12:23 am

pag77 wrote:
happysurf wrote:In the Browser Console with Firefox 47beta and e10s activated there are many "unsafe CPOW usage" JS errors related to utils.js and tooltip.js.

warning errors or critical errors?
addon normally works or stops working?

The addon works fine, you can see the errors screenshot here:

Image
Surf the Internet is a dirty job but someone has to do it.

pag77
 
Posts: 1530
Joined: December 26th, 2013, 10:46 pm

Post Posted May 4th, 2016, 1:05 am

> The addon works fine, you can see the errors screenshot here:
it is not critical errors

happysurf

User avatar
 
Posts: 349
Joined: January 20th, 2011, 3:14 am

Post Posted May 4th, 2016, 2:54 am

pag77 wrote:> The addon works fine, you can see the errors screenshot here:
it is not critical errors

OK, but what is the reason of these errors?
Surf the Internet is a dirty job but someone has to do it.

pag77
 
Posts: 1530
Joined: December 26th, 2013, 10:46 pm

Post Posted May 4th, 2016, 3:04 am

> OK, but what is the reason of these errors?

e10s - multiprocess Firefox :)

happysurf

User avatar
 
Posts: 349
Joined: January 20th, 2011, 3:14 am

Post Posted May 4th, 2016, 3:22 am

pag77 wrote:> OK, but what is the reason of these errors?

e10s - multiprocess Firefox :)

Yes, I found this interested article here:
https://mikeconley.ca/blog/2015/02/17/o ... s-enabled/
Surf the Internet is a dirty job but someone has to do it.

JOJ0
 
Posts: 95
Joined: November 13th, 2006, 11:33 pm

Post Posted May 5th, 2016, 9:44 am

@pag77 :) do you have ETA for fixes about those shims that are hit?

pag77
 
Posts: 1530
Joined: December 26th, 2013, 10:46 pm

Post Posted May 5th, 2016, 10:12 am

Sorry, but i do not understand you

JOJ0
 
Posts: 95
Joined: November 13th, 2006, 11:33 pm

Post Posted May 5th, 2016, 10:17 am

pag77 wrote:Sorry, but i do not understand you

https://www.arewee10syet.com/
S3.Google Translator shimmed 223923

pag77
 
Posts: 1530
Joined: December 26th, 2013, 10:46 pm

Post Posted May 5th, 2016, 10:31 am

My add-on does not work for e10s?

JOJ0
 
Posts: 95
Joined: November 13th, 2006, 11:33 pm

Post Posted May 5th, 2016, 10:10 pm

pag77 wrote:My add-on does not work for e10s?

Your add-on operates and functions with e10s enabled, unfortunately it still uses some old methodology in it's functions which leads to use shims on Firefox level. Which means it is still somewhat slower than it could be with e10s. There are optimization opportunities. In this particular case tooltip.js 492:10 and 493:3. If you insist I will enable on my profile and perform somewhat more detailed investigation to exact code lines you use in order to call those unsafe CPOWs, but you are the expert here.
You are the developer, I feel a little uncomfortable to explain this to you. Please excuse me for any inconvenience caused.

pag77
 
Posts: 1530
Joined: December 26th, 2013, 10:46 pm

Post Posted May 5th, 2016, 10:21 pm

I'll be glad to receive your help :)

Centauri39
 
Posts: 325
Joined: November 25th, 2006, 2:18 pm

Post Posted May 11th, 2016, 2:24 pm

Today, the add-on stopped working for FF 46.0 on my Linux Mint 17.3 MATE 32 Bit.
It just says "Connection error to server https://translate.google.com. Keep on trying!".

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 1 guest