MozillaZine

[Ext] Simple Locale Switcher

Announce and Discuss the Latest Theme and Extension Releases.
nohamelin
 
Posts: 75
Joined: September 3rd, 2013, 4:04 pm
Location: Chile

Post Posted September 6th, 2013, 4:02 pm

Simple Locale Switcher in: AMO | Github | BabelZilla

Compatibility: Firefox 10.0 and later, Thunderbird 10.0 and later, SeaMonkey 2.7 and later.
License: Mozilla Public License (MPL) 2.0

It exposes in a more friendly way the hidden preferences that controls the user interface language: general.useragent.locale and intl.locale.matchOS. It can be seen as an alternative to Locale Switcher and (partially) to Quick Locale Switcher.


Thread open to general discussion and user support.

nohamelin
 
Posts: 75
Joined: September 3rd, 2013, 4:04 pm
Location: Chile

Post Posted October 9th, 2015, 7:23 pm

Okay, let me try to give to this thread a bit of life...

* Release 0.8.7 was recently pushed to AMO. Getting full review should be fast. I expect I did not break anything with a recent internal change: getting rid of the recently deprecated FUEL library: If for anybody the 'Restart after switch language' switch doesn't work anymore, let me know about it.

* I have checked and it seems that the extension wasn't bitten by the recent 'let' and 'const' behaviour changes. I was a bit lucky here: though I use 'let' extensively in functions and block scopes, using it in the global context always feels a bit off to me, so I used 'var' in these cases :-" Anyway, more reports are welcomed.

nohamelin
 
Posts: 75
Joined: September 3rd, 2013, 4:04 pm
Location: Chile

Post Posted August 7th, 2017, 11:47 am

Between all the stuff being removed upstream in Firefox 57, nsLocaleService got the cut too and the add-on was broken. Hard. As the availability of a WebExtensions API for it is still an uncertain thing, I will try to keep the add-on working in Nightly/Aurora while it's possible: I will update it soon.

grahamperrin
 
Posts: 11
Joined: July 19th, 2009, 3:56 pm

Post Posted August 29th, 2017, 11:38 am

For reference:

FreeBSD bug 221916 – cease www/firefox-i18n dependency on old, incompatible xpi-quick-locale-switcher

> … Working alternatives that are multiprocess-compatible include:
>
> … Simple Locale Switcher …

Return to Extension/Theme Releases


Who is online

Users browsing this forum: YaCy [Bot] and 1 guest