MozillaZine

[Ext] DblClicker & KillSpinners & FlashStopper & Add-on Tbb

Announce and Discuss the Latest Theme and Extension Releases.
malliz
Folder@Home

User avatar
 
Posts: 43090
Joined: December 7th, 2002, 4:34 am
Location: Aus

Post Posted March 17th, 2017, 1:00 am

What sort of man would put a known criminal in charge of a major branch of government? Apart from, say, the average voter.
"Terry Pratchett"

yochaim
 
Posts: 429
Joined: September 14th, 2009, 9:23 am

Post Posted March 17th, 2017, 3:42 am

this is my original post on the subject viewtopic.php?p=14736604#p14736604
as you can see from your link it's not in motion yet (for userchrome.css) but considering the current trend with WE removing all actual browser modifications (regardless of the language that is used to hide it...) and also its dependency on xul i'm guessing it will follow the dodo in the not too far future...

sancho-82
 
Posts: 6
Joined: March 31st, 2017, 11:58 am

Post Posted March 31st, 2017, 1:26 pm

Hi,

FlashStopper is really useful but version e10s-1.4.5b5 affects size of new windows opened by JavaScript on Ubuntu 16.04.

All new windows opened by JS have size of about 200x200 px e.g. link like this:
Code: Select all
<a href="#" onclick='window.open("","","width=1000,height=1000");'>click</a>

opens tiny 200px window – it's like width and height properties was filtered out.

Stable version (1.4.5) of FlashStopper is not affected.

I reproduced this bug on two machines with FS e10s-1.4.5b5 and e10s turned on and off:
Ubuntu 16.04 64: FF 52 and FF-ESR 52
Ubuntu MATE 16.04 64: FF 50 and FF 52

I tried with all other extensions off and I think FS is to blame. When it is turned on in FF extension tab new windows opens small when it is off (no need to restart FF) new windows opens with specified dimensions.

FF 52 on Windows 10 is OK.

yochaim
 
Posts: 429
Joined: September 14th, 2009, 9:23 am

Post Posted March 31st, 2017, 2:37 pm

i can't test it on Ubuntu and (as you mentioned) it's not happening on windows...
the only thing i can think of is styles that mess up the new window
can you try on a new profile with only flashstopper using a test html page with only your code?
if that still behaves as you describe please try again after disabling FS everywhere from the toolbarbutton menu.

let me know the results

sancho-82
 
Posts: 6
Joined: March 31st, 2017, 11:58 am

Post Posted March 31st, 2017, 3:46 pm

Thanks for fast response.

I tested these already – new profile and FS disabled from toolbar – but forgot to write about it.

Now I've tested again with brand new profile and with local one-line-test-page:
Code: Select all
<a href="#" onclick='window.open("file:///home/my-home/test.html","","width=1000,height=1000");'>click</a>

and still opens tiny windows even with FS disabled from toolbar-button ("Disable everywhere" checked) but I've found also, that this is only true when parent window is maximized. When parent window is not maximized new window opens with set dimensions. Opening many windows in chain works good when first-parent-window is not maximized, but maximizing first-parent-window starts opening tiny windows, unmaximize first-parent-window and new windows open with set dimensions again.

With FS disabled in FF about:addons every window opens with set dimensions.

sancho-82
 
Posts: 6
Joined: March 31st, 2017, 11:58 am

Post Posted March 31st, 2017, 4:18 pm

This bug was introduced in version e10s-1.4.4b1.
I've just tried every past version descending and e10s-1.4.3b2 is the latest opening new windows with set dimensions.
I hope it will help.

yochaim
 
Posts: 429
Joined: September 14th, 2009, 9:23 am

Post Posted March 31st, 2017, 5:05 pm

i've compared the 2 versions and only 2 things have changed between them...
to check the first please go to about:config and change extensions.flashstopper.scripteditmenu to true
from the toolbarbutton menu click edit script... to open the editor
in the middle section titled script before the line that start with 'var dummyid = ...' add
Code: Select all
return;
and apply so the entire handler will be ignored.
i don't think this is the problem but the second issue is a bit harder to test
also open the browser console when you're testing maybe some helpful info will popup!

sancho-82
 
Posts: 6
Joined: March 31st, 2017, 11:58 am

Post Posted March 31st, 2017, 5:33 pm

I edited script and it was applied for sure because FS stopped stopping auto-play but new windows behavior is unchanged. :(
There's nothing useful in console (just a warning about missing HTML charset encoding).

yochaim
 
Posts: 429
Joined: September 14th, 2009, 9:23 am

Post Posted March 31st, 2017, 5:58 pm

do you have nightly installed?
it would be helpful to check it on nightly (and also for debugging unsigned version)
new version for testing the second issue is in www.byo.co.il/Download/newversions.zip (flashstopper-e10s.xpi ve10s145b6)
it think it can be loaded (installed) via about:debugging
but it would be better if you can test your current version on nightly first...

sancho-82
 
Posts: 6
Joined: March 31st, 2017, 11:58 am

Post Posted March 31st, 2017, 6:17 pm

It works! :D
I installed it on regular Ubuntu FF 52. It's not true what is written here https://support.mozilla.org/t5/Problems-with-add-ons-plugins-or/Add-on-signing-in-Firefox/ta-p/30262#w_what-are-my-options-if-i-want-to-use-an-unsigned-add-on-advanced-users I just set xpinstall.signatures.required to false, restarted FF and confirmed installation.

Thanks for this great add-on! And I can use it with no need to resize every pop-up window again 8-)

yochaim
 
Posts: 429
Joined: September 14th, 2009, 9:23 am

Post Posted March 31st, 2017, 6:33 pm

the problem with this version is that it is incompatible with some other add-ons (Zenmate and ublock origin but not sure about last version)
so it may not go into the release.
if you notice something like that let me know...
also i think unsigned add-ons loaded from about:debugging will only work for the uploaded session
so after restart it may disappear.
Last edited by yochaim on April 1st, 2017, 5:34 am, edited 3 times in total.

sancho-82
 
Posts: 6
Joined: March 31st, 2017, 11:58 am

Post Posted March 31st, 2017, 6:42 pm

I've restarted FF few times already and unsigned FS is still there.
I have uBlock Origin v1.11.4 installed and it seems they work together just fine but I'll keep watching.

LL25255252
 
Posts: 63
Joined: July 6th, 2009, 6:01 am

Post Posted April 6th, 2017, 2:46 pm

LL25255252 wrote:FlashStopper conflicts with Tab Tally 1.0.0 addon - https://addons.mozilla.org/en-US/firefo ... tab-tally/
I reported this issue on Tab Tally page also - https://addons.mozilla.org/en-US/firefo ... ws/840754/

Steps to reproduce :
Create a new/fresh firefox profile.
Install the 2 addons.
Restasrt
Bookmark a page > The "OK" button looks dimmed.
It happens in many of the browser's other "special" windows and setting windows of many addons.

Here's another example of a "dimmed" button window:
Image

Workaround - Install TabTally previous version (0.1.1) and Restart browser.

Is this issue only Tab Tally's "fault" ?

FlashStopper 1.4.4
Firefox 51
Win 7 x64

BTW - Do you know of any other addons which are in conflict with Flashstopper ?
Thanks in advance.

2 months have passed and I found another addon that together with flashstopper causes the same dimmed buttons issue . It is "Expire History by Days" addon - https://addons.mozilla.org/en-US/firefo ... y-by-days/

Image

Tested on a clean/fresh profile with these only 2 addons
FlashStopper 1.4.5
"Expire History by Days" addon 1.30
Firefox 52.0.2 (32-bit)
Win 7 x64
Last edited by LL25255252 on April 10th, 2017, 1:18 pm, edited 1 time in total.

yochaim
 
Posts: 429
Joined: September 14th, 2009, 9:23 am

Post Posted April 6th, 2017, 5:38 pm

hi LL25255252,

i've reproduced the issue on FF52
as far as i can tell the effect is caused by FF picking the high contrast theme instead of the default one when the 2 add-ons are enabled.
i don't know why this happens but i think it's an FF issue since it doesn't happen on nightly...

LL25255252
 
Posts: 63
Joined: July 6th, 2009, 6:01 am

Post Posted April 7th, 2017, 5:46 am

yochaim wrote:hi LL25255252,
i've reproduced the issue on FF52
as far as i can tell the effect is caused by FF picking the high contrast theme instead of the default one when the 2 add-ons are enabled.
i don't know why this happens but i think it's an FF issue since it doesn't happen on nightly...

You are probably right...The author of "expire History by days" found a bug page at bugzilla (it may be a dupe of an existing and already fixed bug) :
https://bugzilla.mozilla.org/show_bug.cgi?id=1337913

Return to Extension/Theme Releases


Who is online

Users browsing this forum: No registered users and 1 guest