MozillaZine

[SOLVED] Lightning with iCloud - repeated login requests

For discussing the Mozilla Calendar, Sunbird and Lightning projects.
Ed1
 
Posts: 937
Joined: January 30th, 2005, 2:33 pm

Post Posted November 4th, 2018, 8:40 am

I decided to try to get Lightning calendar to work with iCloud calendar. After hours of research and trial/error, I succeeded yesterday in getting 2-way syncing going between Lightning calendar and my iCloud calendar. The process included going to the Apple ID website and generating an app-specific password that is entered in Thunderbird when a new calendar is set up in TB to be synced with iCloud's calendar. For 2-way syncing, the CalDav calendar format was used. Everything finally was working yesterday, with new Events created in either TB or iCloud showing up on both, and deletions on either also showing up on both.

This morning, upon opening TB, the login window for the iCloud calendar immediately opens. This requires obtaining again a new Apple app-specific password and entering it again in TB. On closing and reopening TB, the same thing happens. TB does not seem to save the Apple app-specific password from session to session.

Needless to say, this is frustrating and if this is the normal behavior, would preclude use of the TB/Lightning calendar for me.

Why doesn't TB retain the calendar login password? It should not be necessary to manually login to subscribed calendars each time TB is opened, and certainly not for iCloud calendars for which a new generated password seems to be required each time.

Help please!

EDIT: I am using Thunderbird 64.0 Beta 1, 32-bit on Windows 10 x64. This version uses Lightning 6.6. I may try reinstalling Thunderbird using TB 60.3, 32-bit, which I believe uses an earlier version of Lightning, perhaps 6.2.

EDIT: Maybe I am just misinterpreting how the Lightning calendar works. Is the user supposed to manually re-enter, each time TB opens, the password needed by the remote calendar to allow access?

Ed1
 
Posts: 937
Joined: January 30th, 2005, 2:33 pm

Post Posted November 14th, 2018, 9:55 am

I seem to have resolved this issue. I was using TB 64 beta 1 and then TB 64 Beta 2. The issue persisted.

I just set up the Lightning Calendar on another computer running TB 60.3. I noticed when setting up the subscription to my iCloud calendar, that the dialog box that opens that states that iCloud is requesting username and password had a check box for saving the password to the TB Password Manager. I checked that box and finished the setup. TB on that computer does not display this dialog each time it is opened and the Lightning Calendar opens with the subscription to my iCloud calendar active.

In TB 64 Beta x64, and I believe on TB 63 Beta x64, the checkbox for saving the subscribed calendar password to the TB Password Manager is missing. So the password had to be re-entered each time TB was opened. This was the cause of my problem.

Hopefully, this will be fixed in TB 64. Where should I report this issue to Mozilla?

WaltS48

User avatar
 
Posts: 3816
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted November 15th, 2018, 7:04 am

Ed1 wrote:I seem to have resolved this issue. I was using TB 64 beta 1 and then TB 64 Beta 2. The issue persisted.

I just set up the Lightning Calendar on another computer running TB 60.3. I noticed when setting up the subscription to my iCloud calendar, that the dialog box that opens that states that iCloud is requesting username and password had a check box for saving the password to the TB Password Manager. I checked that box and finished the setup. TB on that computer does not display this dialog each time it is opened and the Lightning Calendar opens with the subscription to my iCloud calendar active.

In TB 64 Beta x64, and I believe on TB 63 Beta x64, the checkbox for saving the subscribed calendar password to the TB Password Manager is missing. So the password had to be re-entered each time TB was opened. This was the cause of my problem.

Hopefully, this will be fixed in TB 64. Where should I report this issue to Mozilla?


You can submit a bug report here. https://bugzilla.mozilla.org/

I would use Calendar for the Product and Dialogs for the Component.
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

Eckard

User avatar
 
Posts: 1316
Joined: September 5th, 2011, 8:17 am
Location: Paris (not TX)

Post Posted November 17th, 2018, 5:35 am

Ed1 wrote:
In TB 64 Beta x64, and I believe on TB 63 Beta x64, the checkbox for saving the subscribed calendar password to the TB Password Manager is missing. So the password had to be re-entered each time TB was opened. This was the cause of my problem.

Hopefully, this will be fixed in TB 64. Where should I report this issue to Mozilla?

There are already two bug reports for this issue :
https://bugzilla.mozilla.org/show_bug.cgi?id=1505950
https://bugzilla.mozilla.org/show_bug.cgi?id=1506484

Ed1
 
Posts: 937
Joined: January 30th, 2005, 2:33 pm

Post Posted November 17th, 2018, 6:06 am

You're right, Eckard! Thanks for pointing out the bug reports.

Hopefully, this issue will be fixed soon.

Return to Calendar


Who is online

Users browsing this forum: No registered users and 2 guests