Problems running sunbird on Debian

For discussing the Mozilla Calendar, Sunbird and Lightning projects.
Posts: 4
Joined: September 11th, 2003, 3:13 pm
Location: Vancouver, BC

Post Posted November 11th, 2004, 3:32 pm

This may have bene asked before, but if so I haven't found any info about it on the forum:

I can get the calendar extension for Thunderbird to work on my Debian Sid system, but not the actual standalone Sunbird application. I've tried both of the available Sunbird packages. When I run either of them from X, or from the command line, nothing happens. Not even an error message.

Any suggestions? I'd really like to get this working.

Posts: 9
Joined: December 5th, 2004, 2:46 am
Location: Calgary, Canada

Post Posted December 5th, 2004, 3:05 am

Well, I had the same symptoms.

Are you running it directly out of the directory where you untar'd it? If you run sunbird-bin instead of sunbird you'll see the problem is a missing Same if you run ldd on sunbird-bin. It's not missing, it just isn't in your LD path. Do this (I made a wrapper script):

$ LD_LIBRARY_PATH=/the/path/to/sunbird:$LD_LIBRARY_PATH /the/path/to/sunbird/sunbird-bin &

I haven't noticed any difference running "sunbird" or "sunbird-bin".

Problem is, the stand-alone sunbird can't sent email yet, and "ftp" doesn't work for getting/putting remote calendar files.


Return to Calendar

Who is online

Users browsing this forum: No registered users and 1 guest