MozillaZine

Light Firefox & XP Pro_SP3

Discussion of third-party/unofficial Firefox/Thunderbird/SeaMonkey builds.
painted-cow
 
Posts: 8
Joined: December 22nd, 2016, 8:59 pm

Post Posted December 30th, 2016, 8:22 pm

I've got a multi-boot desktop in my home office, and I still use XP Pro_SP3 a lot.

I downloaded Light Firefox_v48.0 (win32) from SourceForge:

https://sourceforge.net/projects/lightf ... 827_win32/

I didn't realize you had to install an earlier version with XP, before installing the latest version. This KB
document says you can install the latest version, but an earlier version like 43.0 must be installed first:

https://support.mozilla.org/en-US/kb/ge ... s-xp-vista

Here is the list of all Light Firefox versions:

https://sourceforge.net/projects/lightfirefox/files/

If I download and install Light Firefox_v43.0, will I have any problems installing 48.0 which is the latest version?

James
Moderator

User avatar
 
Posts: 27000
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted December 30th, 2016, 8:44 pm

painted-cow wrote:I've got a multi-boot desktop in my home office, and I still use XP Pro_SP3 a lot.

I downloaded Light Firefox_v48.0 (win32) from SourceForge:

https://sourceforge.net/projects/lightf ... 827_win32/

I didn't realize you had to install an earlier version with XP, before installing the latest version. This KB
document says you can install the latest version, but an earlier version like 43.0 must be installed first:

https://support.mozilla.org/en-US/kb/ge ... s-xp-vista

Here is the list of all Light Firefox versions:

https://sourceforge.net/projects/lightfirefox/files/

If I download and install Light Firefox_v43.0, will I have any problems installing 48.0 which is the latest version?

That sumo article is archived as it is outdated now. The issue was for during Firefox 43.0.2 till 48.0.2 the .exe's were signed (due to a Microsoft requirement) in a way that WinXP users with SP2 and not SP3 could not run the setups. Since it is not possible to tell by useragent if a WinXP user has SP2 or SP3 installed the 43.0.1 was served so they could then update to current Release at time. Vista had same issue if they did not keep Vista updated with at least a needed update.

The article was archived when Firefox 49.0 was Released as WinXP users still using SP2 could now install the setups fine since including the current 50.1.0 Release.

Note the future Firefox 53.0 and later will be dropping support for WinXP and Vista so the latest WinXP users can use will be the then Firefox 52.0 ESR Releases. Also Firefox 49.0 and later has dropped support of old CPU's that only supported SSE and not SSE2 flag.

painted-cow
 
Posts: 8
Joined: December 22nd, 2016, 8:59 pm

Post Posted December 31st, 2016, 7:42 pm

I made a foolish mistake! Please accept my apologies.

I downloaded the 64 bit version of Light Firefox. My system is 32 bit. When I ran the 64 bit installer a dialog box
appeared stating that this version needed Windows 7 and above.

I can't completely blame myself for this mistake. Look at the top of this page where all Light Firefox versions are
listed:

https://sourceforge.net/projects/lightfirefox/files/

Here is the exact quote:

Looking for the latest version? Download light-47.0.en-US.win64.installer.exe (23.9 MB)


The question is, why do they show a link for the latest 64 bit version only?

I completely ignored the "win64.installer" as part of the filename. My brain must be turning to mush!

System requirements:

32 bit: Winows XP SP2 and above
64 bit: Windows 7 and above


I'll download the latest 32 bit version of Light Firefox. If the system requirements are correct, there should be no
problems with my XP Pro_SP3 system.

Return to Third Party/Unofficial Builds


Who is online

Users browsing this forum: No registered users and 2 guests