MozillaZine

SeaMonkey launch hoses previous session despite prefs

User Help for Seamonkey and Mozilla Suite
QonoS
 
Posts: 228
Joined: February 11th, 2003, 8:09 pm

Post Posted July 6th, 2018, 6:26 pm

Greetings:

Platform: OS X El Cap 10.11.6, iMac 27" mid-2010. SeaMonkey 2.49.3

SeaMonkey is set as the default browser. Prefs are set to restore previous session on launch, and "Only restore tabs when I need them".

Under certain circumstances, SeaMonkey auto-launches -- meaning it receives a signal to launch from another application, not from me, the user, clicking its Dock icon, or doubleclicking the SeaMonkey Finder icon, etc. One such example occurs if I check for Flash Player (I know, I know) updates in System Prefs with SeaMonkey closed, and if notified that an update is available, I click "Download". That launches SeaMonkey and points it to the relevant Adobe website.

In those cases, SeaMonkey does not restore the previous session in addition to loading the newly-requested webpage. All other tabs and windows are gone.

This has now happened several times, and is infuriating. I had forgotten about sessionstore files but in researching this issue I was reminded of them. Both sessionstore.json (of course) and sessionstore.bak (less of course) contain new rather than old data.

Perhaps if this were to happen again I might be quick enough to save my sessionstore.bak file. Maybe. I don't know how soon sessionstore.bak would update.

I've also downloaded and installed Session Manager, which I used to use with the old Firefox before FF borked a wide swath of existing extensions. I don't know which back end SeaMonkey is using so I don't know yet if it will work.

In any case, this is a destructive behavior and clearly not intended by a user who has set prefs for different behavior. Is this "expected behavior"??

ETA: If SeaMonkey is open at the time I perform an action that would result in the above scenario, expected behavior ensues. System switches to SeaMonkey, already open, and a new tab is opened in the frontmost window.

therube

User avatar
 
Posts: 18784
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted July 9th, 2018, 4:06 am

Check Profile Manager & see if it shows more then one Profile?
As in you may be opening a Profile different from what you're expecting?

(Don't know Mac, so...) check your desktop shortcuts, &/or OS settings, & see what switches they may be setting in opening SeaMonkey.

Check your Profile folder & see if it contains multiple numbered sessionrestore files or -corrupt ones or other oddities?


(Make backups of your Profile, or at least session files ;-).)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Return to SeaMonkey Support


Who is online

Users browsing this forum: Google [Bot] and 2 guests