MozillaZine

What Can I Do?

User Help for Seamonkey and Mozilla Suite
speedo1952

User avatar
 
Posts: 68
Joined: January 29th, 2007, 8:06 am
Location: USA - East Coast

Post Posted June 28th, 2018, 6:52 am

I have Seamonkey 64 bit ver 2.46 which hasn't been updated in about a year because the developer's website (can't remember his name) has been closed. I am getting messages from ebay and others saying that my browser is outdated and won't work for transactions.

I like Seamonkey. Is there a way to update it or do i have to switch to a 32 bit version which is still supported. If i have to install another version, can I transfer the profile folder to the new version?

frg
 
Posts: 628
Joined: December 15th, 2015, 1:20 pm

Post Posted June 28th, 2018, 8:31 am

Pick Bills 2.49.4 x64:

http://www.wg9s.com/comm-esr/

speedo1952

User avatar
 
Posts: 68
Joined: January 29th, 2007, 8:06 am
Location: USA - East Coast

Post Posted June 28th, 2018, 8:45 am

Thank you.

Do you know if Bill's is updated periodically? Can you tell me if Bill's will install over mine, or do I have to uninstall mine first? What about my profile/settings/bookmarks/mail, etc?

frg
 
Posts: 628
Joined: December 15th, 2015, 1:20 pm

Post Posted June 28th, 2018, 9:08 am

> Do you know if Bill's is updated periodically?

Yes if the tree updates so does the build. He has a script running which checks this. If I have patches I think which are stable I send them to him too but this is mostly for 2.53 now.

> Can you tell me if Bill's will install over mine, or do I have to uninstall mine first? What about my profile/settings/bookmarks/mail, etc?
Should all be retained. As usual do a full backup before. The release notes for 2.49.3 apply.

speedo1952

User avatar
 
Posts: 68
Joined: January 29th, 2007, 8:06 am
Location: USA - East Coast

Post Posted June 29th, 2018, 12:08 pm

Great! Installed 2.49.4 and incorporated all my settings from 2.46.
2.53 and 2.57 also show on that link. Are these later/"better" than 2.49?

frg
 
Posts: 628
Joined: December 15th, 2015, 1:20 pm

Post Posted June 29th, 2018, 2:26 pm

> 2.53 and 2.57 also show on that link. Are these later/"better" than 2.49?

Depends. 2.57 currently is unusable. This will become the next major version based on ESR60 if we manage. Browser works but because of Mozilla changes almost all add-ons, mailnews, sidebar and a ton of other things broken. Only there to test if new fixes work and it still builds.

2.53 is based on latest Fx 56 code with a ton of fixes. Maintained mostly by me to use as a testing bed for new patches which are scheduled for 2.57. I grabbed a lot of security fixes and some enhancements since 56 but the sec fixes are not up to date. If you want to help testing use it but keep this in mind. Biggest problem still in it is that it chokes with restoring many tabs during session restore. Some will just not load. If you are not a tab junkie you probably won't notice but this needs to be fixed. There are still some problmes in the download manager and some other parts but I think nothing big. Composer needs testing including uploading and I also need to check if uploads to ftp sites still work.

speedo1952

User avatar
 
Posts: 68
Joined: January 29th, 2007, 8:06 am
Location: USA - East Coast

Post Posted June 30th, 2018, 6:47 am

frg wrote:> 2.53 and 2.57 also show on that link. Are these later/"better" than 2.49?

Depends. 2.57 currently is unusable. This will become the next major version based on ESR60 if we manage. Browser works but because of Mozilla changes almost all add-ons, mailnews, sidebar and a ton of other things broken. Only there to test if new fixes work and it still builds.

2.53 is based on latest Fx 56 code with a ton of fixes. Maintained mostly by me to use as a testing bed for new patches which are scheduled for 2.57. I grabbed a lot of security fixes and some enhancements since 56 but the sec fixes are not up to date. If you want to help testing use it but keep this in mind. Biggest problem still in it is that it chokes with restoring many tabs during session restore. Some will just not load. If you are not a tab junkie you probably won't notice but this needs to be fixed. There are still some problmes in the download manager and some other parts but I think nothing big. Composer needs testing including uploading and I also need to check if uploads to ftp sites still work.


I usually end every session with at least 5 tabs open.

Thank you very much. Last question: How will I know when updates are available for 2.49 and when 2.57 will be ready for use? I assume that auto updates are not functional (they weren't in 2.46......I always would get popups saying that update failed).

frg
 
Posts: 628
Joined: December 15th, 2015, 1:20 pm

Post Posted June 30th, 2018, 7:30 am

> I usually end every session with at least 5 tabs open.

5 isn't "lots". Ask therube :)

We are moving to our own infrastructure. I don't expect for updates to work in the next releases until this one is done and stable. Just watch here or on the website for any announcements. I expect 2.49.4 in 2-3 weeks. It is already late. Still depends on 2 missing reviews and the old builders not crapping out. 2.57 not this year I am afraid.

FRG

speedo1952

User avatar
 
Posts: 68
Joined: January 29th, 2007, 8:06 am
Location: USA - East Coast

Post Posted June 30th, 2018, 2:13 pm

OK
I guess I should check this link?
http://www.wg9s.com/comm-esr/
Is there any way that I can see if ebay likes the later version of SeaMonkey (2.49.4)?

therube

User avatar
 
Posts: 19116
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted July 2nd, 2018, 10:02 am

If ebay doesn't like the current 2.49.4, it's not going to like a later 2.49.4.
That said, there should be no reason (security-wise) that ebay (or any other site) should not like SeaMonkey.
And if they don't, most likely it will be easy to skirt their misplaced dislike.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

speedo1952

User avatar
 
Posts: 68
Joined: January 29th, 2007, 8:06 am
Location: USA - East Coast

Post Posted July 5th, 2018, 11:21 am

eBay must like 2.49.4 'cause I just purchased something while on 2.49.4 with eBay

Return to SeaMonkey Support


Who is online

Users browsing this forum: No registered users and 3 guests