MozillaZine

Google Flights no longer likes Seamonkey

User Help for Seamonkey and Mozilla Suite
leishirsute
 
Posts: 97
Joined: September 16th, 2006, 7:50 pm

Post Posted June 18th, 2018, 5:30 am

As of version 2.49.3, Google Flights states Seamonkey is an unsupported browser. If I select the continue option, the Google Flights webpage is painted but in a corrupted display.

Prior version did not have a problem with Google Flights, but maybe Google Flights has changed their browser check as well.

Any suggestions to get Google Flights to properly work with Seamonkey?

therube

User avatar
 
Posts: 20119
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 18th, 2018, 5:50 am

Google Flights

URL?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

leishirsute
 
Posts: 97
Joined: September 16th, 2006, 7:50 pm

Post Posted June 18th, 2018, 6:12 am


ElTxolo

User avatar
 
Posts: 2506
Joined: July 30th, 2007, 9:35 am
Location: Localhost

Post Posted June 18th, 2018, 6:16 am

leishirsute wrote:As of version 2.49.3, Google Flights states Seamonkey is an unsupported browser. If I select the continue option, the Google Flights webpage is painted but in a corrupted display.

    :-k Typical bad browser sniffing ...

  • Type about:config in the Address Bar and press Enter to display the list of preferences.
  • Ignore the warning message.
  • Right click >> New >> String >> general.useragent.override.google.com/flights
    >>> Mozilla/5.0 (Windows NT 10.0; WOW64; rv:61.0) Gecko/20100101 Firefox/61.0
  • Restart SeaMonkey.
  • Done!









    Cheers! Image
How to Ask Questions The Smart Way - How to Report Bugs Effectively ;)
Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20190804 SeaMonkey/2.49.5
Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20200126 SeaMonkey/2.53.2

therube

User avatar
 
Posts: 20119
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 18th, 2018, 6:29 am

(Strange that Google does not complain about Pale Moon 27.
PM comes "pre-overridden" with:
general.useragent.override.google.com;Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.9) Gecko/20100101 Goanna/3.4 Firefox/52.9 PaleMoon/27.9.3
& Google has no problem with that.)

Google may also be storing cookies, or whatnot, that might affect things even after overriding?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

leishirsute
 
Posts: 97
Joined: September 16th, 2006, 7:50 pm

Post Posted June 18th, 2018, 8:43 am

"
[*]Type about:config in the Address Bar and press Enter to display the list of preferences.
[*]Ignore the warning message.
[*]Right click >> New >> String >> general.useragent.override.google.com/flights
>>> Mozilla/5.0 (Windows NT 10.0; WOW64; rv:61.0) Gecko/20100101 Firefox/61.0
[*]Restart SeaMonkey.
[*]Done!
"

That did not change any behavior.
I don't know how to import a screenshot here to show you the entry in the config.

Anonymosity
 
Posts: 8573
Joined: May 7th, 2007, 12:07 pm

Post Posted June 18th, 2018, 8:46 am

Google Maps did not work very well with Pale Moon until I added the Firefox compatibility info to its user-agent.

leishirsute
 
Posts: 97
Joined: September 16th, 2006, 7:50 pm

Post Posted June 18th, 2018, 8:58 am

I tried "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.9) Gecko/20100101 Goanna/3.4 Firefox/52.9 PaleMoon/27.9.3" and it didn't change anything either. Still get the unsupported browser warning from Google.

Frank Lion

User avatar
 
Posts: 20575
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted June 18th, 2018, 9:36 am

leishirsute wrote:I tried "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.9) Gecko/20100101 Goanna/3.4 Firefox/52.9 PaleMoon/27.9.3" and it didn't change anything either. Still get the unsupported browser warning from Google.

Use this - general.useragent.override.google.com

I used an Edge UA, but you should be able to use any of the usual ones. No warning message at my end now.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

leishirsute
 
Posts: 97
Joined: September 16th, 2006, 7:50 pm

Post Posted June 18th, 2018, 9:56 am

Frank Lion wrote:
leishirsute wrote:I tried "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.9) Gecko/20100101 Goanna/3.4 Firefox/52.9 PaleMoon/27.9.3" and it didn't change anything either. Still get the unsupported browser warning from Google.

Use this - general.useragent.override.google.com

I used an Edge UA, but you should be able to use any of the usual ones. No warning message at my end now.



That worked with "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.9) Gecko/20100101 Goanna/3.4 Firefox/52.9 PaleMoon/27.9.3"

Thank you!

ElTxolo

User avatar
 
Posts: 2506
Joined: July 30th, 2007, 9:35 am
Location: Localhost

Post Posted June 18th, 2018, 10:51 am

leishirsute wrote:
  • Type about:config in the Address Bar and press Enter to display the list of preferences.
  • Ignore the warning message.
  • Right click >> New >> String >> general.useragent.override.google.com/flights
    >>> Mozilla/5.0 (Windows NT 10.0; WOW64; rv:61.0) Gecko/20100101 Firefox/61.0
  • Restart SeaMonkey.
  • Done!


That did not change any behavior.
...

    :-k Well, it works fine for me, making those changes:
    (Using Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20180403 SeaMonkey/2.49.3 in VoidLinux)

    Image




    And I don't have a problem with PaleMoon either:
    (general.useragent.override.google.com - Mozilla/5.0 (X11; Linux x86_64; rv:52.9) Gecko/20100101 Goanna/3.4 Firefox/52.9 PaleMoon/27.9.3)

    Image







    Cheers! Image
How to Ask Questions The Smart Way - How to Report Bugs Effectively ;)
Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20190804 SeaMonkey/2.49.5
Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20200126 SeaMonkey/2.53.2

therube

User avatar
 
Posts: 20119
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 18th, 2018, 11:08 am

New >> String >> general.useragent.override.google.com/flights

That should be: general.useragent.override.google.com, no trailing /, no flights.


(And it wasn't my intention, necessarily, for you to use a PM useragent, only pointing out that it is accepted by Google, where oddly, ours is not - at least for some.
And I wonder why it does work for some of us?
Still does not work for me using ElTxolo's UA?)


Suppose it's something in here?
Code: Select all
a:{var Ra=_.l.navigator;if(Ra){var Sa=Ra.userAgent;if(Sa){_.Qa=Sa;break a}}_.Qa=""}_.x=function(a){return-1!=_.Qa.indexOf(a)};var Ta;Ta="constructor hasOwnProperty isPrototypeOf propertyIsEnumerable toLocaleString toString valueOf".split(" ");_.Ua=function(a,c){for(var d,e,f=1;f<arguments.length;f++){e=arguments[f];for(d in e)a[d]=e[d];for(var g=0;g<Ta.length;g++)d=Ta[g],Object.prototype.hasOwnProperty.call(e,d)&&(a[d]=e[d])}};
var Va;_.Wa=function(){return _.x("Safari")&&!(Va()||_.x("Coast")||_.x("Opera")||_.x("Edge")||_.x("Silk")||_.x("Android"))};Va=function(){return(_.x("Chrome")||_.x("CriOS"))&&!_.x("Edge")};_.Xa=function(){return _.x("Android")&&!(Va()||_.x("Firefox")||_.x("Opera")||_.x("Silk"))};
_.Ya=function(){return _.x("iPhone")&&!_.x("iPod")&&!_.x("iPad")};_.Za=function(){return _.Ya()||_.x("iPad")||_.x("iPod")};_.$a=function(a){_.$a[" "](a);return a};_.$a[" "]=_.ua;var bb=function(a,c){var d=ab;return Object.prototype.hasOwnProperty.call(d,a)?d[a]:d[a]=c(a)};var qb,rb,ab,zb;_.cb=_.x("Opera");_.y=_.x("Trident")||_.x("MSIE");_.db=_.x("Edge");_.eb=_.db||_.y;_.fb=_.x("Gecko")&&!(-1!=_.Qa.toLowerCase().indexOf("webkit")&&!_.x("Edge"))&&!(_.x("Trident")||_.x("MSIE"))&&!_.x("Edge");_.gb=-1!=_.Qa.toLowerCase().indexOf("webkit")&&!_.x("Edge");_.ib=_.x("Macintosh");_.jb=_.x("Windows");_.kb=_.x("Linux")||_.x("CrOS");_.lb=_.x("Android");_.mb=_.Ya();_.nb=_.x("iPad");_.ob=_.x("iPod");_.pb=_.Za();qb=function(){var a=_.l.document;return a?a.documentMode:void 0};
a:{var sb="",tb=function(){var a=_.Qa;if(_.fb)return/rv:([^\);]+)(\)|;)/.exec(a);if(_.db)return/Edge\/([\d\.]+)/.exec(a);if(_.y)return/\b(?:MSIE|rv)[: ]([^\);]+)(\)|;)/.exec(a);if(_.gb)return/WebKit\/(\S+)/.exec(a);if(_.cb)return/(?:Version)[ \/]?(\S+)/.exec(a)}();tb&&(sb=tb?tb[1]:"");if(_.y){var ub=qb();if(null!=ub&&ub>(0,window.parseFloat)(sb)){rb=String(ub);break a}}rb=sb}_.vb=rb;ab={};_.wb=function(a){return bb(a,function(){return 0<=_.Pa(_.vb,a)})};_.yb=function(a){return Number(xb)>=a}; var Ab=_.l.document;zb=Ab&&_.y?qb()||("CSS1Compat"==Ab.compatMode?(0,window.parseInt)(_.vb,10):5):void 0;var xb=zb;



@ElTxolo, did you check to see if you might not already have had a google.com override set in SeaMonkey?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

ElTxolo

User avatar
 
Posts: 2506
Joined: July 30th, 2007, 9:35 am
Location: Localhost

Post Posted June 19th, 2018, 10:38 am

therube wrote:... @ElTxolo, did you check to see if you might not already have had a google.com override set in SeaMonkey?

    :-k I only have this change:

    Code: Select all
    general.useragent.override.mail.google.com;Mozilla/5.0 (X11; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0


    Anyway, I think I made a big mistake. Image

    Yesterday morning, I was doing some administrative work on a government website.
    As this type of web, only works with Firefox or Chrome crap, I changed the SeaMonkey user agent to Firefox 61 via PrefBar.
    And when I saw leishirsute's message I made the changes in about:config that I commented on in my first message,
    but without having changed the Firefox 61 user agent to SeaMonkey (the PrefBar toolbar was hidden, and I didn't notice it).
    So the Google Flights web site works correctly. But it worked correctly, because it was using the PrefBar user agent (Firefox 61) not the one
    that had changed in about:config

    I'm sincerely sorry for this stupid mistake. #-o






    Cheers!! Image
How to Ask Questions The Smart Way - How to Report Bugs Effectively ;)
Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20190804 SeaMonkey/2.49.5
Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20200126 SeaMonkey/2.53.2

leishirsute
 
Posts: 97
Joined: September 16th, 2006, 7:50 pm

Post Posted June 19th, 2018, 11:37 am

NO problem. Lot's of help here. Thanks.

Return to SeaMonkey Support


Who is online

Users browsing this forum: No registered users and 4 guests