MozillaZine

Compliment & Question about XP

User Help for Seamonkey and Mozilla Suite
Peter Creasey

User avatar
 
Posts: 483
Joined: October 26th, 2007, 2:32 pm
Location: Texas

Post Posted May 23rd, 2018, 1:17 pm

Hearty compliments and appreciation to the developers for their continued fine work...in this case with SM 2.49.3.

Question -- does this version 2.49.3 work okay with Windows XP?

Thanks!
. . . . . . . . . . Pete

DanRaisch
Moderator

User avatar
 
Posts: 119601
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted May 23rd, 2018, 4:19 pm

That version of SeaMonkey requires at least XP Service Pack 2. https://www.seamonkey-project.org/doc/s ... quirements

frg
 
Posts: 540
Joined: December 15th, 2015, 1:20 pm

Post Posted May 24th, 2018, 12:05 am

I usually test on XP SP3 so yes. The VS2015 runtime is not certified to run with SP2. We are picking up the requirements from Firefox here but if it breaks on SP2 we will just update the requirements to only be compatible with SP3 :)

Peter Creasey

User avatar
 
Posts: 483
Joined: October 26th, 2007, 2:32 pm
Location: Texas

Post Posted May 24th, 2018, 6:48 am

frg, I don't know how to interpret what you said as it affects whether Windows XP runs okay with SM 2.49.3.

Dan, thank you. I'm pretty sure I have SP2. I don't recall there being a SP3 but if there was, I would imagine I have it.
. . . . . . . . . . Pete

DanRaisch
Moderator

User avatar
 
Posts: 119601
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted May 24th, 2018, 7:11 am

You should check to see which version you have because most updates of other software are likely to work only with SP3. https://support.microsoft.com/en-us/hel ... sion-or-64

therube

User avatar
 
Posts: 18679
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted May 24th, 2018, 10:15 am

From a command prompt, WINVER.

XP is almost always going to be x86.
XP is almost always going to be SP3.
(If it were not to be SP3, you would have been the one to decide that - for some specific reason.)


You could always install SeaMonkey onto your XP box & see what happens.


See also, SeaMonkey 2.46 requires CPU with SSE2 support.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

frg
 
Posts: 540
Joined: December 15th, 2015, 1:20 pm

Post Posted May 25th, 2018, 12:25 am

> If it were not to be SP3, you would have been the one to decide that - for some specific reason.)

+1
Unless you are running some particularly quirky program which requires this and it is a matter of life and death to run it no need for SP2 anymore. And you wouldn have needed to disabled automatic updates too. If you use the WPOS hack you are even covered till 2019 with SP3 :)

Peter Creasey

User avatar
 
Posts: 483
Joined: October 26th, 2007, 2:32 pm
Location: Texas

Post Posted May 25th, 2018, 6:55 am

therube wrote:(If it were not to be SP3, you would have been the one to decide that - for some specific reason.)


frg wrote:> If it were not to be SP3, you would have been the one to decide that - for some specific reason.)
+1
Unless you are running some particularly quirky program which requires this and it is a matter of life and death to run it no need for SP2 anymore. And you wouldn have needed to disabled automatic updates too. If you use the WPOS hack you are even covered till 2019 with SP3


Thanks, guys...good to know. I'll be firing up the XP machine at the beach soon.
. . . . . . . . . . Pete

Peter Creasey

User avatar
 
Posts: 483
Joined: October 26th, 2007, 2:32 pm
Location: Texas

Post Posted May 25th, 2018, 3:02 pm

Reporting in, SeaMonkey 2.49.3 appears to be working fine on my XP machine (and, yes, it has Windows SP3).

Thanks again!
. . . . . . . . . . Pete

James
Moderator

User avatar
 
Posts: 27312
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted May 25th, 2018, 3:33 pm

Peter Creasey wrote:Dan, thank you. I'm pretty sure I have SP2. I don't recall there being a SP3 but if there was, I would imagine I have it.

WinXP SP3 was first available to the public for download and in windows update since May 6, 2008. https://en.wikipedia.org/wiki/Windows_XP#Service_Pack_3

Firefox 53.0 or rather Gecko 53.0 and later does not run on Windows XP and Vista.

For Firefox 52 ESR the last major update will be 52.9.0 ESR apart from any minor 52.9.X esr updates for security and or allowed stability fixes. This mean any SeaMonkey versions that is using Gecko 53.0 and later will not run on WinXP. An option would be to say dual boot with a light Linux distro.

Peter Creasey

User avatar
 
Posts: 483
Joined: October 26th, 2007, 2:32 pm
Location: Texas

Post Posted May 26th, 2018, 6:12 am

James wrote: any SeaMonkey versions that is using Gecko 53.0 and later will not run on WinXP.


James, so this means that SM will no longer work with WinXP SP3 starting with which SM version?
. . . . . . . . . . Pete

frg
 
Posts: 540
Joined: December 15th, 2015, 1:20 pm

Post Posted May 26th, 2018, 7:32 am

> James, so this means that SM will no longer work with WinXP SP3 starting with which SM version?

2.50 and up. Next planned official major version is 2.57. Probably 2.49.5 will be the last one before but this is all not set in stone because 2.57 is unusable right now.

Return to SeaMonkey Support


Who is online

Users browsing this forum: No registered users and 2 guests