MozillaZine

Seamonkey quietly closes on CTRL-Q, doesn't warn

User Help for Seamonkey and Mozilla Suite
kmike
 
Posts: 118
Joined: November 4th, 2002, 10:54 pm

Post Posted February 9th, 2019, 11:12 pm

Hello,
I usually press CTRL-Q to exit Seamonkey 2.49.1, and I may have inadvertently removed checkbox from the warning dialog that usually appeared. Browser now closes silently, and that's not what I want since CTRL-Q is right near CTRL-W.

I can't find a relevant setting in preferences. Nearest what I could find is "Warn me when closing a window with multiple tabs" and it's on. I also scoured about:config and found "browser.warnOnQuit" which is enabled (for default). Anyone has any idea what setting it is?

TPR75
 
Posts: 708
Joined: July 25th, 2011, 8:11 am
Location: Poland

Post Posted February 10th, 2019, 2:26 am

kmike wrote:Hello,
I usually press CTRL-Q to exit Seamonkey 2.49.1, and I may have inadvertently removed checkbox from the warning dialog that usually appeared. Browser now closes silently, and that's not what I want since CTRL-Q is right near CTRL-W.

I can't find a relevant setting in preferences. Nearest what I could find is "Warn me when closing a window with multiple tabs" and it's on. I also scoured about:config and found "browser.warnOnQuit" which is enabled (for default). Anyone has any idea what setting it is?


It will be:
Code: Select all
browser.tabs.warnOnClose


It's "Warn me when closing a window with multiple tabs" and should be unmarked when you choose "Do not ask next time" after Ctrl+Q.

Is there any particular reason why are you using outdated version 2.49.1 instead of latest 2.49.4?

kmike
 
Posts: 118
Joined: November 4th, 2002, 10:54 pm

Post Posted February 17th, 2019, 5:48 am

Thank you for the suggestion. But browser.tabs.warnOnClose is already set to "true" for me. So it must be a different "about:config" setting.

About version I'm using, each browser upgrade is a hassle for me as there's always a chance that the new version will stop working with my custom Sync 1.1 server, and I'll have to tinker with settings again.

therube

User avatar
 
Posts: 19374
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted February 17th, 2019, 7:39 am

If you have SeaMonkey set to Restore Previous Session on browser startup, then Ctrl+Q does not prompt.

Edit | Preferences | Browser -> Display on ... Browser Startup
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

kmike
 
Posts: 118
Joined: November 4th, 2002, 10:54 pm

Post Posted February 17th, 2019, 12:44 pm

Well, it's pretty weird then - I always had Restore Previous Session enabled, and Seamonkey always asked me for confirmation on Ctrl-Q for like years. That changed about a month ago, and I did nothing wrt browser upgrade, etc. That dialog had a "ask next time" checkbox and I must have clicked on it accidentally.

therube

User avatar
 
Posts: 19374
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted February 18th, 2019, 6:14 pm

Do note that having the browser set to 'Restore Previous Session' on browser startup
& quitting & reopening from Session Restore are different.

My "startup" is set to a Blank Page.

But when I Quit (Ctrl+Q), I choose to save my session.
So when I restart, my session is (seen &) restored (automatically) from Session Restore (sessionstore.json).
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Return to SeaMonkey Support


Who is online

Users browsing this forum: Google [Bot] and 1 guest