MozillaZine


Default cursor location in TB 91.2

User Help for Mozilla Thunderbird
apuder
 
Posts: 3
Joined: October 18th, 2021, 1:16 pm

Post Posted October 18th, 2021, 1:24 pm

Hi,

starting with TB 91.2, the default cursor location for the reply compose window has changed. In previous versions, when I hit reply, the cursor would be in the message compose pane. Now with 91.2, the default input focus is with the list of recipients. I have gotten used to immediately typing a response. But now I first have to click into the message composition pane first. Since I'm not used to that, I start my responses in the "To:" field. I know it seems like a minor thing but I have gotten so used to immediately type my response after hitting "reply" that I now routinely start typing the response in the address field. Very, very annoying. Since it is not very common to change the list of recipients for a reply, I wonder why the default input focus is now with the "To:" field and not like before with the compose pane.

Can this default behavior be changed?

TIA,
AP

tanstaafl
Moderator

User avatar
 
Posts: 48175
Joined: July 30th, 2003, 5:06 pm

Post Posted October 18th, 2021, 2:47 pm

I can't duplicate your problem using version 91.2.0 under Windows 10. It always defaults to the message compose pane regardless of how I select a reply (Ctrl+R, button on toolbar, menu command etc.).

Perhaps you're running into a side effect of an add-on that doesn't work correctly with version 91 due to API changes. Many of the add-ons that worked with 78 either don't work or have weird side effects. See if the problem goes way if you use help -> troubleshooting mode.

apuder
 
Posts: 3
Joined: October 18th, 2021, 1:16 pm

Post Posted October 18th, 2021, 5:09 pm

Thanks for your response. I appreciate it. I followed your suggestion and voila, the input focus is back to where it belongs. I guess I have to disable the add-ons one by one to identify the culprit.

AP

apuder
 
Posts: 3
Joined: October 18th, 2021, 1:16 pm

Post Posted October 19th, 2021, 9:21 am

The source of the issue seems to be an add-on called "Thunderbird Conversations": https://github.com/thunderbird-conversa ... tions/wiki

I filed a bug report: https://github.com/thunderbird-conversa ... ssues/1725

However, the author of the add-on believes this is a bug within TB: https://bugzilla.mozilla.org/show_bug.cgi?id=1732558

AP

solidusit
 
Posts: 1
Joined: October 28th, 2021, 1:57 am

Post Posted October 28th, 2021, 2:02 am

I had the exact same problem, very annoying
in my case it was the "FOLDER ACCOUNT" plugin https://addons.thunderbird.net/it/thunderbird/addon/folder-account/?src=ss
after deactivating the plugin thusderbird is working fine

Solidus

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 6 guests