MozillaZine


Attachment Preference Handling Not Being Remembered

User Help for Mozilla Thunderbird
D.Dancer

User avatar
 
Posts: 74
Joined: February 5th, 2006, 1:09 pm

Post Posted October 17th, 2021, 11:36 am

This is not pinking me off but it is an annoying behavior.

I have it set on one machine that MP3 files be opened by Audition.

The checkbox is clicked for "Always do this."

The dialog still comes up.

Image
https://sta.sh/0mn1t57cphg

tanstaafl
Moderator

User avatar
 
Posts: 48193
Joined: July 30th, 2003, 5:06 pm

Post Posted October 17th, 2021, 12:49 pm

Known bug . See https://bugzilla.mozilla.org/show_bug.cgi?id=453455 , https://bugzilla.mozilla.org/show_bug.cgi?id=1727175 and https://bugzilla.mozilla.org/show_bug.cgi?id=1690395 . Its confusing why they treat it as 13 year old bug while the problem didn't occur for most people until version 91.

This seems to be a political problem because it effects both Firefox and Thunderbird and the Thunderbird project doesn't seem willing to do a short term fix that will work for most people. They appear to be waiting for a long term fix from Firefox.

https://www.betterbird.eu is a modified fork of Thunderbird lead by a former Thunderbird developer. Somebody in one of the bug reports claims betterbird fixed it and the betterbird release notes also claim that.

D.Dancer

User avatar
 
Posts: 74
Joined: February 5th, 2006, 1:09 pm

Post Posted October 19th, 2021, 12:32 pm

Probably some old work-around hid the problem but now they needed to unpatch the patch and bang it resurfaces.

Seen that happen before.

swbrains
 
Posts: 33
Joined: July 7th, 2004, 12:05 pm

Post Posted October 21st, 2021, 3:00 pm

I installed Betterbird and can confirm that it handles opening attachments properly in the associated app without asking. In TB 91.2.1 (just downloaded today), the issue persists.

For me, it only seems to be certain file types (JPG and PNG most notibly) which just happen to be the most common attachment types I receive, unfortunately. I have PDFs set to open in Foxit Reader in TB and they seem to open properly without asking me to choose an app.

jonhar
 
Posts: 1
Joined: October 24th, 2021, 1:31 pm

Post Posted October 24th, 2021, 2:10 pm

I also have this issue. iMac TB 91.2.1. I'm on the release channe. The prior version, and all prior versions for last several years have worked fine. I have no add-ons or extensions. Made no changes since the update.
My problem is with JPG, it uses Preview to open. With this new release it always asks in spite of "always do this". I suppose I will also run into this w/ mp4's. No problem so far w/ .pdf's.

I joined this forum while looking to see if this bug was reported. I did not follow the links tanstasfl posted as it seems like it will be ineffective.

tanstaafl
Moderator

User avatar
 
Posts: 48193
Joined: July 30th, 2003, 5:06 pm

Post Posted October 24th, 2021, 11:25 pm

jonhar:

The bug has been reported. I can duplicate the bug (in fact I submitted a bug report about it that was closed as a duplicate). You basically have four choices:

1) Live with the problem and hope that it will either get fixed in a later release or you get lucky and the problem disappears again in a later release for some unknown reason. AFAIK there isn't any setting you can tweak using the config editor to workaround this problem.

2) Go back to an older release. See http://kb.mozillazine.org/Go_back_to_an ... hunderbird for links to old setup programs if you want to go back to an older version. The projects official position is that its critical to always use the latest version to get the latest security fixes and stress that most of them are rated critical or high severity. However they're almost always potential risks that require javascript to be enabled, and javascript is disabled for mail accounts in Thunderbird. i.e. mainly effects Firefox or news/chat accounts. Even the official Mozilla security advisory for Thunderbird 91.2 states:

"In general, these flaws cannot be exploited through email in the Thunderbird product because scripting is disabled when reading mail, but are potentially risks in browser or browser-like contexts."

3) Use Betterbird. You could do a custom install in a different directory and keep Thunderbird installed. The main downside is if you want to use your existing profile is the hash string for Lock= in the profiles.ini file is going to point to Thunderbird's installations directory, not BetterBirds. So it will complain that version of the program is not compatible with that profile (even though it is). You can usually workaround that type of problem by clicking on the about:profiles link in help -> more troubleshooting information for BetterBird and press the associated "set as default profile" button for the profile.

It would be easier to just install BetterBird over the existing Thunderbird installation but that's risky unless you've spent enough time using BetterBird to know whether it does a better job of meeting your needs. Sort of a catch-22.

4) You could try using freeware like AutoIt or AutoHotkey to automatically recognize the popup window and press the button for you but I assume you'd have to use a shortcut to launch that script every time you launch Thunderbird. So it probably wouldn't be worth the effort to create the script unless you frequently need to open attachments.

https://www.autoitscript.com/site/
https://www.autohotkey.com
https://www.reddit.com/r/AutoHotkey/com ... tton_on_a/

WaltS48

User avatar
 
Posts: 4996
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted October 25th, 2021, 6:36 am

The fifth workaround is to save the file and open it from the saved location in the file manager.
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 4 guests