There is no email program associated error with Tbird 91.1.1

User Help for Mozilla Thunderbird
Nick Payne
Posts: 21
Joined: December 13th, 2004, 6:20 pm

Post Posted September 22nd, 2021, 3:19 am

I installed Thunderbird 91.1.1 x64 as an update over Thunderbird 78.14 x64 (OS is Win10 Pro x64 21H1, build 19043.1237). When starting TB after 91.1.1 installed, I get the error dialog: "There is no email program associated to perform the requested action. Please install an email program or, if one is already installed, create an association in the Default Programs control panel."

When I OK the dialog, Thunderbird starts up fine and appears to run completely normally. When I check default apps, email is set to Thunderbird, and when I check the registry, both Computer\HKEY_CURRENT_USER\SOFTWARE\Clients\Mail and Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail default value is set to "Mozilla Thunderbird". I can also right-click a file in Windows Explorer and select Send to / Mail Recipient, and that works correctly as well.

Uninstalled 91.1.1 and installed 78.14, then ran "thunderbird.exe -p --allow-downgrade". With 78.14 I don't get the error msg - I'm using the same profile with both versions. If I upgrade again to 91.1.1, the error returns, and if I downgrade to 78.14, it disappears. I also tried the latest beta version, 93.0b3, and get the error msg on startup with it as well.


User avatar
Posts: 48164
Joined: July 30th, 2003, 5:06 pm

Post Posted September 22nd, 2021, 6:34 pm

I suspect it defaults to 78.14.0, not 91.1.1. As far as Windows is concerned they are two unrelated programs even though you had installed both in the same location. Try pressing the check now button in the system integration section of the preferences using 91.1.1.

Nick Payne
Posts: 21
Joined: December 13th, 2004, 6:20 pm

Post Posted September 29th, 2021, 8:23 pm

I don't think defaulting to 78.14 is the problem. I closed Thunderbird, uninstalled 78.14, rebooted, installed 91.1.2. The "no email program associated" dialog again reappears each time I start 91.1.2. I checked the "Make Thunderbird the default email client" checkbox during the installation, and if I run the System Integration check within Thunderbird, and then restart it, I get the same error dialog again.


User avatar
Posts: 48164
Joined: July 30th, 2003, 5:06 pm

Post Posted September 29th, 2021, 9:27 pm

It might not be defaulting to 78.14 but I wouldn't expect what you described doing to effect it.

I have four different versions of Thunderbird installed. I looked at the default apps section in the windows "settings" program and it said Thunderbird. However, there isn't any obvious way to tell which of the four installations its referring to. It only listed one Thunderbird in "chose an app" and didn't let me browse to an executable. Setting a default app in the control panel now calls the settings program unfortunately. Ditto for the associate a file type or protocol with a program link in the control panel.

If making a email client other than Thunderbird the default email client and then making Thunderbird 91 the default again doesn't help you probably need to edit the registry.

Using the registry editor I searched for thunderbird.exe and found that HKEY_CLASSES_ROOT\mailto\shell\open\command is set to "C:\Program Files\Thunderbird 91\thunderbird.exe" -osint -compose "%1" and HKEY_CLASSES_ROOT\ThunderbirdEML\shell\open\command is set to "C:\Program Files\Thunderbird 91\thunderbird.exe" "%1"

I could edit them if needed to one of the other executables. There are other Thunderbird handlers like that in the registry for news etc.

I found HKEY_CLASSES_ROOT\WOW6432Node\CLSID\{29F458BE-8866-11D5-A3DD-00B0D0F3BAA7}\LocalServer32 is set to "C:\Program Files\Thunderbird 78\thunderbird.exe" /MAPIStartup . I didn't find a similar one that used Thunderbird 91 which makes me wonder if MAPI is not enabled for version 91 on my machine. Fortunately I don't use SimpleMAPI for anything as I don't run word, excel etc.

Posts: 796
Joined: February 12th, 2005, 8:33 pm

Post Posted September 30th, 2021, 2:43 pm

In your first message, you say that, after you installed Thunderbird 91, you got the following error message: "There is no email program associated to perform the requested action..."

You didn't say, however, when you got the message: is it when you click on a link in your browser, or in another application such as Word, FileMaker, a PDF reader? That could make a difference in finding the culprit and therefore the solution.

Meanwhile, a few ideas.

1. Have you got many versions of Thunderbird installed. One problem is that typically, when you upgrade from 32-bit to 64-bit, the 32-bit application stays in place.
Here is what you could do. Bear in mind that my system is in French, so the names I used are my own translation.
– Open Control Panel (the old one), then "Programs and functionalities"
– Search for versions of "Mozilla Thunderbird" you have.
Normally, the only one you should see is "Mozilla Thunderbird 91.1.2 (x64).
– If you have more than one version, particularly some NOT identified with x64, it means you have one or more 32-bit versions installed.
– Definitely remove all 32-bit versions and, to be safe, ALL versions of Thunderbird. (copy your profile beforehand to be safe – see below).
– Restart your computer.
– At that time, set your email program to one of the other choices (like Mail or Edge). That way, when you reinstall and reassign Thunderbird, it should do the job correctly.
– Install ONE version of Thunderbird (most likely TB 91.1.2 (x64).
– See if it works. If you have to reassign applications, you won't have more than one Thunderbird to chose from, so that would be easier.

– Normally, either when you click on "Make Thunderbird my default program" (of afterwards), you should be referred to "Settings".
– Select "Applications –> Default applications" and make Thunderbird your default mail application.
– The go to "Default values by application". Select Thunderbird, manage, and make sure the three choices refer to Thunderbird (.eml ; .wdseml and MAILTO).


To backup your profile:
It should normally be in

Copy it in a safe place like your desktop so you could recreate it if necessary.
Michel Gagnon
Montréal (Québec, Canada)

Posts: 1
Joined: September 29th, 2021, 12:49 pm

Post Posted October 1st, 2021, 9:37 am

I'm having the same problem, but I got 18 popups.
I created a backup and removed all THunderbird versions and leftover registries.
Reinstalled version 91.1.2 again and started it. It gave no popups but of course no mailboxes where there.
Then I restored my mailboxes and the popups where back again.
But I can't find a relation between my mailboxes or other settings and the 18 popups.


User avatar
Posts: 48164
Joined: July 30th, 2003, 5:06 pm

Post Posted October 1st, 2021, 3:16 pm

"Then I restored my mailboxes and the popups where back again."

Please provide more detail on the steps you took. It sounds like Thunderbird, not Windows, is displaying the popups. That's confusing as its not clear what the requested action that triggered the popup was since it appears you didn't open a message or an attachment, double click on a .eml file using windows explorer , run a message filter or send a message before getting the popup.

Did you delete the profiles before re-installing Thunderbird? I'm not sure what you're referring to by "leftover registries" as few people go to all of the trouble of using the registry editor to remove all remaining traces when trying to start fresh.

When you "restored your mailboxes" did you copy a older prefs.js file over a new one or did you create a new profile using the new account wizard? I'm assuming you did more than just copy mbox files as you need an existing account to create a place to store them. Nowadays the "local folders" special account isn't created until after you add your first account.

What was the last thing you did in restoring your mailboxes?

Posts: 2
Joined: October 17th, 2021, 4:09 am

Post Posted October 17th, 2021, 4:14 am

hey, I have the same error. I am getting 9 iterations of the error message after update to 91.2.0 (Win 10). Also, after the update my exquilla acount is gone. What might be the solution here - roll back to a previous version?

Posts: 2
Joined: October 17th, 2021, 4:09 am

Post Posted October 18th, 2021, 3:00 am

Without me doing anything, the exquilla acount re-appeared. I'm still getting those error-messages at startup though...

Posts: 3
Joined: October 28th, 2021, 11:58 pm

Post Posted October 29th, 2021, 12:13 am

I have the same problem with Thunderbird automatically updates to 91.2.1. But if I install this version from the beggining in one clean computer , the problem don't appear. Curious!!
I've tried everything I found, fixing mail preferences, Thunderbird preferences, changing some Registry entries, but nothing works. Even I tried to unistall this version and install another older, like 78, but the message continuous appearing.
The numbers of error windows that appear before open Thunderbird is random, sometimes 8, 10, 12, ...

New Member
Posts: 1
Joined: November 8th, 2021, 4:44 am

Post Posted November 8th, 2021, 4:50 am

Searching on the web, it seems related to "EDS - Evolution Data Server" (
For me, removing the lines which contains "ldap_2.servers.eds" from 'prefs.js' file in the profile folder seems to have fixed the problem.
Make a backup copy of 'prefs.js' and do some tests.
that i found thanks to Cris486\
For me
the first send did not work closed open tested all fine
also it seamed to be connected to synced email addresses re great improvement to TB
the details were in prefs.js'
but the account was missing in thunderbords
the customer said he never did nothing and i'd asume it was setting up a sync contacts account without knowing how to after the update

so hopefully another bug crushed Win

Return to Thunderbird Support

Who is online

Users browsing this forum: Cbhihe and 4 guests