MozillaZine


Transfer TB profile to fresh Win 10 install- Emails missing

User Help for Mozilla Thunderbird
BlaserSkeet
 
Posts: 1
Joined: November 22nd, 2020, 12:16 pm

Post Posted November 22nd, 2020, 12:33 pm

I've been having issues with BSOD for a few months now, so I decided to do a full wipe and reinstall (which as it turns out didn't help anyways, probably finally time to replace my 10 year old PC).

I saved my profile to a flash drive, same as I've done a half dozen times before for system wipes, new hard drives, switching from 32 bit to 64 bit, ect. When I attempt to transfer it to TB on the new install, I've lost three sub-folders from Inbox completely (including hundreds of relatively important saved emails that don't exist anywhere else), and the past 3 years of "sent", although 2005-2017 come through fine strangely. Address book also appears to be intact.

The strange thing is the "missing" emails aren't gone. If I do a search using a specific word, the emails that should be there show up in the preview pane, presumably fully intact, however when you click on the preview to open the email it's blank.

I suppose it would be less frustrating if I messed something up (or even if it wasn't my fault) and I KNEW the data was simply gone forever, but the fact that it appears to be there, just VERY inconveniently accessible is infuriating. I'm 99% sure I did the transfer as intended, and that this is some sort of (hopefully fixable) glitch. I can theoretically fish through the past 30 days of "trash" in Gmail and recompile some stuff, so at least that's something.

This was POP through Gmail, with delete on read, so all of the received messages are gone from Googles servers. I do still have a complete archive of "sent" since that sits on google, although Gmails search function has always been particularly horrible for me. So right now I'm left theoretically intact, but apparently extremely scattered to the winds.

I am curious if the file size is/did cause this issue, the saved profile was just over 2GB. It's almost as if the first 2GB was backed up, and the rest lost or forgotten, dunno.

Moral of the story may be that I need to start using IMAP instead of POP3 so this doesn't happen again.

Spent about 16 hours on this so far with ZERO progress using every hint and tutorial I could find, about ready to throw in the towel and live with the result. Any ideas?

tanstaafl
Moderator

User avatar
 
Posts: 47301
Joined: July 30th, 2003, 5:06 pm

Post Posted November 22nd, 2020, 1:43 pm

It sounds like the global search index is finding messages that were essentially removed behind its back (due to your losing several folders). So you can see whatever partial copy of the message is kept in the search index, but when it tries to open the mail folder where the message is stored it can't find it.

Try importing the mbox files (a file named after the folder with no file extension which contains the mail for the folder such as "inbox." or "sent items.") using the ImportExportTools NG add-on. Or just copy them to a child directory in "Local Folders" (look at the local directory setting in the server settings for where it stores files for the account).

http://kb.mozillazine.org/Importing_folders hasn't been updated for the new version of the ImportExportTools add-on but the basics haven't changed.

I'm skeptical size is the problem. Individual folders can be over 4GB and there is no limit on the size of a profile. You might also have a corrupt "sent" folder.

Its possible to have both a POP and a IMAP account for the same mailbox/email address at the same time. If your old PC was still running I'd suggest you think about using the new account wizard to create IMAP accounts, and copy all of the messages from the POP accounts to the IMAP accounts. That essentially uploads the messages "as is" (no extra headers like there would be if you forwarded them). If that succeeds you can add the IMAP accounts to the profile on your new PC and it will automatically find/use those messages.

If your only copy of the old profile is on the flash disk and the new PC's hard disk that's unfortunate. Use a utility such as the MboxViewer at http://sourceforge.net/projects/mbox-viewer/ to look at the mbox files for the missing folders. If it can't display any messages then you probably had a problem backing up part of the profile. http://kb.mozillazine.org/Mail_Utilities

Unfortunately there is always the possibility you actually lost many of the missing messages on your old PC beforehand and didn't realize it because they they were still listed by a corrupt folder listing and you didn't try to open the messages.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 5 guests