MozillaZine

Not display remote image in compose window

User Help for Mozilla Thunderbird
aricoba
 
Posts: 20
Joined: March 27th, 2016, 9:18 am

Post Posted October 8th, 2020, 1:35 pm

Hi,
Since my update from Thunderbird 68 to 78.3.1 (64-bit, debian sid), I've lost a feature I had set up years ago in the Config editor.
Could you please tell me how to not display in the compose window remote images?

Thanks in advance for your kind help :-)

tanstaafl
Moderator

User avatar
 
Posts: 47159
Joined: July 30th, 2003, 5:06 pm

Post Posted October 8th, 2020, 2:44 pm

I don't understand the context. Are you creating a new HTML message or replying to one that has remote images?

aricoba
 
Posts: 20
Joined: March 27th, 2016, 9:18 am

Post Posted October 8th, 2020, 4:34 pm

I'm indeed creating a new html message.

morat
 
Posts: 4098
Joined: February 3rd, 2009, 6:29 pm

Post Posted October 8th, 2020, 5:06 pm

How did you set up the feature in Thunderbird 68? With an addon?

aricoba
 
Posts: 20
Joined: March 27th, 2016, 9:18 am

Post Posted October 8th, 2020, 5:09 pm

Not with an addon, as far as I remember I used the Config editor to set it up.

tanstaafl
Moderator

User avatar
 
Posts: 47159
Joined: July 30th, 2003, 5:06 pm

Post Posted October 8th, 2020, 5:27 pm

All of the remote image settings in the config editor I'm aware of deal with viewing existing messages, not composing ones.

Any chance you're talking about using the moz-do-not-send attribute? It's used internally by Thunderbird to tell it not to include the full image file contents, but instead to simply link to the external image.

http://kb.mozillazine.org/Creating_comp ... ote_images

aricoba
 
Posts: 20
Joined: March 27th, 2016, 9:18 am

Post Posted October 9th, 2020, 6:05 am

My html code already uses the moz-do-not-send attribute (moz-do-not-send="true").
I modified my Thunderbird profile (I thought it was in config editor, but it was years ago so I'm not sure) to avoid to display this image when I'm composing emails.
In case it may help, I still have a copy of a Thunderbird before the update, when this feature was still working.

morat
 
Posts: 4098
Joined: February 3rd, 2009, 6:29 pm

Post Posted October 9th, 2020, 6:29 am

Are you using the AutoConfig file in Thunderbird 68?

The AutoConfig file would be specified in the general.config.filename pref.

Deploying Firefox in an enterprise environment
http://developer.mozilla.org/Firefox/Enterprise_deployment_before_60
Last edited by morat on October 9th, 2020, 6:31 am, edited 2 times in total.

aricoba
 
Posts: 20
Joined: March 27th, 2016, 9:18 am

Post Posted October 9th, 2020, 6:30 am

morat wrote:Are you using the AutoConfig file in Thunderbird 68?
I am not.

tanstaafl
Moderator

User avatar
 
Posts: 47159
Joined: July 30th, 2003, 5:06 pm

Post Posted October 9th, 2020, 7:31 am

https://support.mozilla.org/bm/questions/1261691 talks about getting a error message where Thunderbird blocked loading a file when using a signature with a image, and the image is specified in the exceptions list in the privacy settings.

So it looks like the exception list applies to messages you are composing too. That used to be set using the address book at one time. Did you use to see a empty outline for the images (in your older configuration) and the image placement effect formatting of text etc. or was nothing displayed at all?

aricoba
 
Posts: 20
Joined: March 27th, 2016, 9:18 am

Post Posted October 25th, 2020, 1:22 pm

tanstaafl wrote:https://support.mozilla.org/bm/questions/1261691 talks about getting a error message where Thunderbird blocked loading a file when using a signature with a image, and the image is specified in the exceptions list in the privacy settings.

Hi,
Yes I had read this thead, but I don't think it's the solution since I didn't have this notification:
Image

tanstaafl wrote:So it looks like the exception list applies to messages you are composing too. That used to be set using the address book at one time. Did you use to see a empty outline for the images (in your older configuration) and the image placement effect formatting of text etc. or was nothing displayed at all?

Yes here is how it looked like before upgrading to Thunderbird v.78, an empty place:
https://i.imgur.com/uqR8LsE.png
Last edited by DanRaisch on October 25th, 2020, 2:02 pm, edited 1 time in total.
Reason: Image tags removed to restore page formatting.

tanstaafl
Moderator

User avatar
 
Posts: 47159
Joined: July 30th, 2003, 5:06 pm

Post Posted October 25th, 2020, 2:55 pm

In 78.4 I added https://g.foolcdn.com/ to the block list, restarted Thunderbird and then composed a HTML message with
https://g.foolcdn.com/misc-assets/logo- ... agenta.svg that I sent to myself. To my surprise
I not only saw the image while composing but saw it when reading the new message.

What I think happened is that the exception to allow images from my email address (its my main account) overruled the
exception that blocked a specific web site (g.foolcdn.com) . I suspect that means exceptions for email address override
exceptions for specific web sites.

I then tried again sending between two different email account that were not listed in the exceptions. This time I saw
the remote image while composing the message but saw the yellow banner with a warning message, a outline of the
remote image and just its alternate text when reading the new message.

I then tried again with 68.12.1 (using the same 2 accounts as last time). It did not display the remote image or a outline
while composing. The received mail has no image or outline either. I looked at the raw message source of the received
message to verify it has the remote image. I then looked at the same message using 78.4 (in a different profile). It
displayed a outline of the remote image with alternative text, but no yellow banner with an error. I then looked at the
preceding image which used to have a yellow banner and that banner is gone too.

It looks like with both 68 and 74 once you see the yellow warning banner for a specific exception you won't see it again
for that exception. I forwarded inline the last message (which just has the outline + alternative text) to another account
and it displayed it the same way, with no yellow banner. Yet another undocumented behavior.

I'm not too surprised that undocumented behavior changed. All that I can suggest is that you check in the list of exceptions
that your email address is not listed. That won't provide the same behavior as before, but its probably the best you can do.

Sorry I can't suggest a workaround. All I've really done is confirm that you did nothing special (no add-ons
or config editor settings) in 68 to get the behavior you want to keep using in 74.

aricoba
 
Posts: 20
Joined: March 27th, 2016, 9:18 am

Post Posted October 30th, 2020, 4:08 pm

Hi tanstaafl,
I'm still confused.
I still have access to a Thunderbird v.68.8.1 install.
In the compose window, the remote image is not displayed, as expected:
Image
But it's not because of the Privacy settings… because they are empty, exactly as my v.78, where the remote image is displayed yet
Image

Any idea?
Is there no way to figure out the solution from my dear old v.68 profile, which is working exactly as I want?

Thanks again for your kind help.

morat
 
Posts: 4098
Joined: February 3rd, 2009, 6:29 pm

Post Posted October 31st, 2020, 3:48 am

To undo "Show remote content in this message"

* select message
* tools > developer tools > error console
* copy and paste code into error console
* press enter to run

Code: Select all
(function () {
  var kNoRemoteContentPolicy = 0;
  var kBlockRemoteContent = 1;
  var kAllowRemoteContent = 2;
  var msgHdr = gMessageDisplay.displayedMessage;
  if (msgHdr) {
    var remoteContentPolicy = msgHdr.getUint32Property("remoteContentPolicy");
    if (remoteContentPolicy == kBlockRemoteContent) {
      setMsgHdrPropertyAndReload("remoteContentPolicy", kAllowRemoteContent);
    } else if (remoteContentPolicy == kAllowRemoteContent) {
      setMsgHdrPropertyAndReload("remoteContentPolicy", kNoRemoteContentPolicy);
    }
    window.content.focus();
  }
})();

To undo "Allow remote content from"

* tools > options > privacy > mail content > exceptions

Remote Content in Messages
http://support.mozilla.org/kb/remote-content-in-messages

Error Console command line
http://developer.mozilla.org/docs/Tools/Browser_Console#Browser_Console_command_line

aricoba
 
Posts: 20
Joined: March 27th, 2016, 9:18 am

Post Posted November 1st, 2020, 9:40 am

morat wrote:To undo "Show remote content in this message"

* select message
* tools > developer tools > error console

Hi morat,
This menu doesn't exist in compose window.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 5 guests