MozillaZine

Your message was sent but a copy was not placed in your sent

User Help for Mozilla Thunderbird
Skyzoomer
 
Posts: 97
Joined: September 12th, 2007, 12:56 pm

Post Posted June 8th, 2019, 12:44 pm

When sending an email with multiple attachments, I'm getting the error:

"Your message was sent but a copy was not placed in your sent folder (Sent Mail) due to network or file access errors.
You can retry or save the message locally to Local Folders/Sent Mail-xxxxxxx@gmail.com."


(not sure why the "Mail-xxxxxxx@gmail.com" is blue instead of red. I did not do that.)

Here's the results of my testing:

Email with Attachment-1 and one large attachment does NOT get the error:
- Attachment-1.zip ..... (4236 KB)
- Attachment-2.pdf .... (2915 KB)

Email with Attachment-1 and two large attachments gets the error:
- Attachment-1.zip ..... (4236 KB)
- Attachment-2.pdf .... (2915 KB)
- Attachment-3.pdf .... (1894 KB)

But email with Attachment-1 and two small attachments does NOT get the error:
- Attachment-1.zip ..... (4236 KB)
- Attachment-5.pdf .... (731 KB)
- Attachment-6.pdf .... (232 KB)

I can send the email with these 5 attachments (omitting attachment-1) and the error does NOT occur:
- Attachment-2.pdf .... (2915 KB)
- Attachment-3.pdf .... (1894 KB)
- Attachment-4.pdf .... (1817 KB)
- Attachment-5.pdf .... (731 KB)
- Attachment-6.pdf .... (232 KB)

So it appears that attachment-1 (4236 KB) is one of the key factors in causing the error.

Complex problem. Any ideas?
(Tbird 9.0.1 running on Win7 (x64) on Intel i5 system.) (Tbird 9.0.1 running on Vista on Dell Core 2 Duo T6400 laptop.)

tanstaafl
Moderator

User avatar
 
Posts: 45872
Joined: July 30th, 2003, 5:06 pm

Post Posted June 8th, 2019, 7:47 pm

http://kb.mozillazine.org/Can_not_send_ ... ttachments

Sending a message (via SMTP) is done independently of uploading a saved copy (via IMAP), at the same time. Its possible to save a copy of the sent message before its sent, or even if the sending fails.

attachment 1 might actually be 1/3 larger due to the base64 encoding used by binary attachments. I suspect its not an attachment specific problem, it's caused by your total message size when its being uploaded over a poor tcp-ip connection. I also wouldn't expect the threshold (how large before it fails) to stay the same, it will vary a little.

Most of my accounts don't have this problem , but one (fastmail) does. The workaround I used was there is an optional setting available in the webmail settings page to configure the SMTP server to save a copy of the sent message for you, so that you can disable Thunderbird uploading a copy to your sent folder. That solved the problem. See if your email provider offers a feature like that.

Skyzoomer
 
Posts: 97
Joined: September 12th, 2007, 12:56 pm

Post Posted June 9th, 2019, 1:12 pm

tanstaafl wrote:http://kb.mozillazine.org/Can_not_send_large_attachments

Sending a message (via SMTP) is done independently of uploading a saved copy (via IMAP), at the same time. Its possible to save a copy of the sent message before its sent, or even if the sending fails.

attachment 1 might actually be 1/3 larger due to the base64 encoding used by binary attachments. I suspect its not an attachment specific problem, it's caused by your total message size when its being uploaded over a poor tcp-ip connection. I also wouldn't expect the threshold (how large before it fails) to stay the same, it will vary a little.

Most of my accounts don't have this problem , but one (fastmail) does. The workaround I used was there is an optional setting available in the webmail settings page to configure the SMTP server to save a copy of the sent message for you, so that you can disable Thunderbird uploading a copy to your sent folder. That solved the problem. See if your email provider offers a feature like that.

Thanks much for your reply! I'll look into what you posted and report results. May take a little while due to "Honey dos" backlog :wink: .
(Tbird 9.0.1 running on Win7 (x64) on Intel i5 system.) (Tbird 9.0.1 running on Vista on Dell Core 2 Duo T6400 laptop.)

Skyzoomer
 
Posts: 97
Joined: September 12th, 2007, 12:56 pm

Post Posted June 13th, 2019, 4:31 am

Skyzoomer wrote:
tanstaafl wrote:http://kb.mozillazine.org/Can_not_send_large_attachments

Sending a message (via SMTP) is done independently of uploading a saved copy (via IMAP), at the same time. Its possible to save a copy of the sent message before its sent, or even if the sending fails.

attachment 1 might actually be 1/3 larger due to the base64 encoding used by binary attachments. I suspect its not an attachment specific problem, it's caused by your total message size when its being uploaded over a poor tcp-ip connection. I also wouldn't expect the threshold (how large before it fails) to stay the same, it will vary a little.

Most of my accounts don't have this problem , but one (fastmail) does. The workaround I used was there is an optional setting available in the webmail settings page to configure the SMTP server to save a copy of the sent message for you, so that you can disable Thunderbird uploading a copy to your sent folder. That solved the problem. See if your email provider offers a feature like that.

Thanks much for your reply! I'll look into what you posted and report results. May take a little while due to "Honey dos" backlog :wink: .


Have not been able to figure out how to configure the SMTP server to save a copy of the snet msg for me.

But I did find out some things:
I have 4 gmail accounts. Using Tbird, 2 accounts can send all of the attachments without any error. Two accounts get the error.

What happens using the accounts that work:
... 1. Delivering mail
... 2. Sending login information
... 3. Sending windows close and all is good.

What happens using the accounts that have the error:
... 1. Delivering mail
... 2. Sending login information
... 3. Sending login information
... 4. A window pops up saying "Connection to server imap.gmail.com timed out"

I made all of the settings in Tbird for one error account the same as for one good account. But the error on the bad account persists.
I made all of the settings in gmail for the two accounts the same but the error on the bad account persists.

Mind boggling so far,
Skyzoomer
(Tbird 9.0.1 running on Win7 (x64) on Intel i5 system.) (Tbird 9.0.1 running on Vista on Dell Core 2 Duo T6400 laptop.)

Skyzoomer
 
Posts: 97
Joined: September 12th, 2007, 12:56 pm

Post Posted June 14th, 2019, 1:20 pm

I fixed my problem. Fix was to delete the gmail account that had the problem and add it again to Tbird. Now no errors even with all attachments sent.
Skyzoomer

EDIT: The fix was short lived. Same problem as before again. Copies are being placed in the sent mail folder (before and now) so no loss but the problem does cause long delays until the time out happens. Guess I'll just have to live with it, or split attachments into two emails to avoid the problem.
(Tbird 9.0.1 running on Win7 (x64) on Intel i5 system.) (Tbird 9.0.1 running on Vista on Dell Core 2 Duo T6400 laptop.)

JYLD
 
Posts: 148
Joined: July 18th, 2019, 9:59 am

Post Posted July 19th, 2019, 9:48 pm

You have 4 gmail accounts. You might be hitting limits on simultaneous TB connections to the GMAIL Server. Try making these changes and see if they help.

Thunderbird:
network.http.max-persistent-connections-per-server in about:config.
Default is 6. I changed this to 12. Google IMAP accepts up to 15

Also under Tools Options Account Settings Server Advanced.
I changed the default max connections to cache from default of
5 to 12.

The above changes have been working well for me to speed up TB. If these changes cause you problems, go back to the default values.

Next Change:
I use a GMAIL (actually GSuite GMail) that is the back end for my own domain email. When I send an email using TB or Web Interface. GMAIL will automatically put a copy of the sent mail in the [Gmail] "Sent Mail" folder. TB in its default suggested configuration under Tools, Account Settings, Copies & Folders will be configured to also put a copy of your sent email messages in the Sent folder. The Sent folder is just another IMAP folder in default configuration. That requires TB to open another connection to GMail servers to access the Sent folder (note Sent folder and Sent Mail folder are two different folders). I would sometimes get a time out error when TB was trying to connect to Gmail to place a copy of the email in one of the two sent email folders.

Anyway, besides making the changes regarding persistent server connections and cached connections mentioned above I made the following change which makes the copying of a sent email to the "Sent" folder virtually instantaneous.

I created a local folder named Sent. Then under Tools, Account Settings, Copies & Folders I pointed TB to save that extra sent email copy to the LOCAL "SENT" FOLDER. TB no longer needs to open another gmail server connection to handle this and with windows file caching, etc. the saving of the message in the "Sent" folder is now virtually instantaneous.

See if these suggestions above help. Based solely on my personal experience with the above changes, I would recommend these changes to everyone. Especially, anyone using TB with a GMail account. If you have LOTS of emails in MANY different/separate email folders and you are using IMAP, then these changes make a big difference in how responsive and fast TB feels.

tanstaafl
Moderator

User avatar
 
Posts: 45872
Joined: July 30th, 2003, 5:06 pm

Post Posted July 19th, 2019, 11:12 pm

network.http.max-persistent-connections-per-server is for http connections. I don't think Thunderbird uses that limit for pop/imap/smtp. Each account has a mail.server.serverX.max_cached_connections (where X is the same id as the account id). The latter can be set by pressing the advanced button in the server settings and editing "maximum number of server connection to cache". As an experiment I set it to 29 for a Gmail IMAP account, exited and restarted and the value was still kept.

Usually if you run into a limit you get an error message such as "Unable to connect to your IMAP server. You may have exceeded the maximum number of connections to this server. If so, use the Advanced IMAP Server Settings dialog to reduce the number of cached connections"

You might want to first try modifying each Gmail account to use the same Gmail SMTP server and see what effect that has, before you worry about the number of simultaneous connections being an issue. I'm not suggesting you do this permanently, just for troubleshooting.

The Gmail SMTP server will ignore whatever From: address you supply unless you add it in the Gmail web page at Setting -> Accounts -> "Add another email address". So you would need to register all of your Gmail addresses with each Gmail webmail.

https://support.google.com/mail/answer/22839?hl=en is the Gmail help on "Limits for sending and getting mail"

"I created a local folder named Sent. Then under Tools, Account Settings, Copies & Folders I pointed TB to save that extra sent email copy to the LOCAL "SENT" FOLDER. TB no longer needs to open another gmail server connection to handle this and with windows file caching, etc. the saving of the message in the "Sent" folder is now virtually instantaneous."

AFAIK you can't disable the Gmail SMTP server from saving a copy of a message you send in the Gmail sent mail folder. Normally the reason saving a copy of your sent message in a folder in the Local Folders account is quick is because it doesn't go out over the network, its mainly limited by the speed of your storage. Unless you are storing your profile on a flash drive or have a really large attachment you typically wouldn't notice that.

JYLD
 
Posts: 148
Joined: July 18th, 2019, 9:59 am

Post Posted July 20th, 2019, 10:22 am

Tanstaafl, does your gmail account that you used have many thousands of messages spread out over more than 100 IMAP folders? Have you on that account ever experienced the problem the OP described of copying a message to a sent folder timing out? I have. If not then you are trying to compare apples to oranges. My Gmail account has over 30,000 messages (maybe as much as 50,000 I'm not positive on the maximum number) and I have over 150 IMAP folders in which those 30,000+ messages are spread about.

All I know is my personal experience. The changes I described and recommended make a huge difference in how TB feels and responds when using TB with my gmail account. I stand by the recommended changes. Especially as I stated for anyone using TB with gmail IMAP accounts when they have MANY messages spread out over LOTS of IMAP folders.

tanstaafl wrote:network.http.max-persistent-connections-per-server is for http connections. I don't think Thunderbird uses that limit for pop/imap/smtp.


All I know is that change along with the others I recommended make a big difference in my personal experience. I stand by my recommendation as I wrote it.

tanstaafl wrote:Each account has a mail.server.serverX.max_cached_connections (where X is the same id as the account id). The latter can be set by pressing the advanced button in the server settings and editing "maximum number of server connection to cache". As an experiment I set it to 29 for a Gmail IMAP account, exited and restarted and the value was still kept.


29 was still kept or the default of 5 was still kept? I wouldn't recommend 29 based on things I've read. From what I've read GMail doesn't handle more than 15 as I stated in my original post. I wouldn't recommend more than the 12 I recommended in my original post, and that might possibly be too high when one has 4 different gmail accounts open at the same time in TB as does the OP.

tanstaafl wrote:AFAIK you can't disable the Gmail SMTP server from saving a copy of a message you send in the Gmail sent mail folder.


That's what I wrote in my original post.

tanstaafl wrote:Normally the reason saving a copy of your sent message in a folder in the Local Folders account is quick is because it doesn't go out over the network


Again that is what I wrote in my original post.

tanstaafl
Moderator

User avatar
 
Posts: 45872
Joined: July 30th, 2003, 5:06 pm

Post Posted July 20th, 2019, 11:25 am

I don't want to get into an argument about what you did or didn't write. It serves no purpose (doesn't help the author of this thread).

The total number of messages and folders doesn't matter. Its mainly a question of what folders have been opened that session, and how many messages are in them. It can take a very long time to update the folder listing if you have a really large number of messages. AFAIK that isn't effected by the size of the messages. Thunderbird loads a folder's *.msf file into memory whenever it opens the folder. By default it keeps up to 30 *.msf files open for 5 minutes (and their contents in memory), unless they are "special" folders (such as the inbox), which it never closes. It loads the inbox.msf file for every account on startup.

One of the simplest ways to improve performance is to move most of the messages from the inbox to other folders/child folders (and then compact the folder, to physically remove the original copy of the messages, which were marked deleted). Periodically archiving old messages in the sent mail folder would also help.

JYLD
 
Posts: 148
Joined: July 18th, 2019, 9:59 am

Post Posted July 20th, 2019, 12:09 pm

Tanstafl, I'll reply in reverse order of your post.

I do move my messages from the inbox to an appropriate folder. My inbox has less than 100 out of my 30,000 messages on average.

I do compact folders regularly.

You can't archive messages for a gmail IMAP account. GMAIL and TB won't do anything but put archives in the all mail GMAIL folder. That's assuming you can get TB to even create an archive folder and put emails in it with a Gmail account, which I have never seen happen. You can if you are careful, manually create some archive folders under local folders and then copy messages from a Gmail folder to a local folder and then delete the gmail messages so copied from the Gmail account AND from the Gmail All Mail folder, which is the only way to really get rid of a Gmail message. If you try doing this manual archive with too many messages at one time, you can crash TB and possibly corrupt your entire TB profile.

You don't use gmail on a regular basis with lots of emails and many folders that is apparent.

What TB put's into local memory etc. and how it does so is irrelevant to what we are discussing and the problem reported by the OP.

You are WRONG about many folders not making a difference when TB is dealing with a Gmail IMAP account. TB has to open a separate server connection for each folder it is attempting to download or upload messages (i.e. synchronize), TB needs a separate server connection for each folder one moves an email from their inbox into. TB needs a separate server connection to connect to your google calendar if you having lighting set up for that. TB needs a separate server connection to connect to your google contacts if you have the address book set up to synchronize with google contacts.

All these separate server connections for IMAP folders, calendar, indox, contacts, add up very quickly. It means that TB is always closing connections and opening connections to the Gmail server. It means that TB does NOT keep a connection to the "Sent" folder (not to be confused with the [Gmail] Sent Mail folder) always open. When you send a message TB will usually need to close some connection to the Gmail server and then open a connection to the server for the "sent" folder (which by default is just another IMAP folder on gmail). If there are no available connections at that time the copying to the "sent" folder has to wait. Sometimes the waiting can cause a time out. That's why making the "sent" folder a local folder is by comparison virtually instantaneous as I stated. Its because AS I STATED, TB doesn't have to open a connection to the gmail server (i.e. it doesn't have to because the email will be saved to the local folder on the hard disk and NOT on an IMAP folder on the Gmail server. Reading comprehension is a good thing).

All the opening and closing of server connections takes some amount of time. When the max number of connections is tied up, there is a delay experienced by the user trying to go in and out of an IMAP folder that is not already open. The delay is caused by TB having to close one folder connection with the Gmail server to open the new Gmail server connection for the folder you want to enter.

So to sum up. The number of folders and messages makes a HUGE difference with TB and Gmail when you have MANY messages spread out over LOTS of folders. Increasing the max number of Gmail server connections makes a BIG difference.

That is my personal experience. I stand by my recommendations. If I was the OP I would try the changes I suggested before he wastes his time trying anything else.

Skyzoomer
 
Posts: 97
Joined: September 12th, 2007, 12:56 pm

Post Posted July 20th, 2019, 1:10 pm

JYLD and tanstaafl,

Thanks for both your inputs. I'll have to read your posts several times to try to understand what you both are saying. It might take a while for me to do research to try to understand your posts.

Thanks again for both your help,
Skyzoomer
(Tbird 9.0.1 running on Win7 (x64) on Intel i5 system.) (Tbird 9.0.1 running on Vista on Dell Core 2 Duo T6400 laptop.)

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 5 guests