MozillaZine

Cannot send & receive mails via TB after upgrading to 60.3.3

User Help for Mozilla Thunderbird
Baby0506
 
Posts: 3
Joined: December 16th, 2018, 4:13 am

Post Posted December 16th, 2018, 4:27 am

Hi,
I am using thunderbird as mail and calendar-client a couple of years and it used to work fine. My Mail is a web.de-account, my calendar is a google-calendar.
Today TB upgrades from TB 52.9.1 to 60.3.3. After this upgrade I neither send nor receive mails while the calendar is still working fine.
When I de-install TB 60.3.3 and reinstall TB 52.9.1 + adding the Lightning-stuff, mail and calendar is working fine again. After upgrading again to TB 60.3.3 it stopps, syncing the mails. I already disabled my viruschecker (GDATA) for a test, but this did not help.
I am using Windows 10 build 1803 as operating system and GDATAs newest version 25.5.1.21 as antivirus-software.
Here is also theTB-report for my system:


Allgemeine Informationen

Name: Thunderbird
Version: 60.3.3
Build-ID: 20181204174145

Update-Kanal: release
User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:60.0) Gecko/20100101 Thunderbird/60.3.3
Betriebssystem: Windows_NT 10.0

Fenster mit mehreren Prozessen: 0/0 (deaktiviert)
Web-Inhaltsprozesse:
Stylo: content = true (aktiviert (Standard)), chrome = true (aktiviert (Standard))
Unternehmensrichtlinien:
Google-Schlüssel: Fehlt
Mozilla-Location-Service-Schlüssel: Fehlt
Abgesicherter Modus: false

E-Mail- und Newsgruppen-Konten
account1:
INCOMING: account1, , (imap) imap.web.de:993, SSL, passwordCleartext
OUTGOING: , smtp.web.de:587, alwaysSTARTTLS, passwordCleartext, true

account2:
INCOMING: account2, , (none) Local Folders, plain, passwordCleartext

Absturzberichte der letzten 3 Tage

Alle Absturzberichte

Erweiterungen

Name
Version
Aktiviert
ID

Lightning
6.2.3.3
true
{e2fda1a4-762b-4020-b5ad-a41df1933103}

Provider für Google Kalender
4.4.2
true
{a62ef8ec-5fdc-40c2-873c-223b8a6925cc}

Sicherheitssoftware

Typ: Name

Antivirus:
Antispyware:
Firewall: Windows-Firewall

Grafik

Allgemeine Merkmale
Compositing: Basic
Asynchrones Wischen und Zoomen: nichts
WebGL-1-Treiber: WSI Info: EGL_VENDOR: Google Inc. (adapter LUID: 0000000000006467)
EGL_VERSION: 1.4 (ANGLE 2.1.0.7edc21933ef1)
EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_ANGLE_direct_composition EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_stream_producer_d3d_texture EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_CHROMIUM_sync_control EGL_EXT_pixel_format_float EGL_KHR_surfaceless_context EGL_ANGLE_display_texture_share_group EGL_ANGLE_create_context_client_arrays EGL_ANGLE_program_cache_control EGL_ANGLE_robust_resource_initialization
EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
WebGL-1-Treiber: Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 1070 Ti Direct3D11 vs_5_0 ps_5_0)
WebGL-1-Treiber: Version: OpenGL ES 2.0 (ANGLE 2.1.0.7edc21933ef1)
WebGL-1-Treiber: Erweiterungen: GL_ANGLE_client_arrays GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_pack_reverse_row_order GL_ANGLE_program_cache_control GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_color_buffer_float_rgb GL_CHROMIUM_color_buffer_float_rgba GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc_srgb GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_surfaceless_context GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
WebGL-1-Erweiterungen: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
WebGL-2-Treiber: WSI Info: EGL_VENDOR: Google Inc. (adapter LUID: 0000000000006467)
EGL_VERSION: 1.4 (ANGLE 2.1.0.7edc21933ef1)
EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_ANGLE_direct_composition EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_stream_producer_d3d_texture EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_CHROMIUM_sync_control EGL_EXT_pixel_format_float EGL_KHR_surfaceless_context EGL_ANGLE_display_texture_share_group EGL_ANGLE_create_context_client_arrays EGL_ANGLE_program_cache_control EGL_ANGLE_robust_resource_initialization
EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
WebGL-2-Treiber: Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 1070 Ti Direct3D11 vs_5_0 ps_5_0)
WebGL-2-Treiber: Version: OpenGL ES 3.0 (ANGLE 2.1.0.7edc21933ef1)
WebGL-2-Treiber: Erweiterungen: GL_ANGLE_client_arrays GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_multiview GL_ANGLE_pack_reverse_row_order GL_ANGLE_program_cache_control GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_color_buffer_float_rgb GL_CHROMIUM_color_buffer_float_rgba GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_float GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc_srgb GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_norm16 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_EGL_image_external_essl3 GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_surfaceless_context GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
WebGL-2-Erweiterungen: EXT_color_buffer_float EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context
Zeichnen auf Nebenthread aktiviert: true
DirectWrite: true (10.0.17134.376)
Last edited by LIMPET235 on December 18th, 2018, 8:14 am, edited 2 times in total.
Reason: Extraneous config data removed from post

DanRaisch
Moderator

User avatar
 
Posts: 121325
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted December 16th, 2018, 6:38 am

Moving to Thunderbird Support as no confirmed bug has yet been identified here.

tanstaafl
Moderator

User avatar
 
Posts: 45240
Joined: July 30th, 2003, 5:06 pm

Post Posted December 16th, 2018, 2:55 pm

"Today TB upgrades from TB 52.9.1 to 60.3.3. After this upgrade I neither send nor receive mails while the calendar is still working fine."

Can you still read old mail?
Can you refresh your list of potential folders to subscribe?

http://smtpimap.email/web.de-smtp-imap- ... tings.html seems to describe the settings you need. Your posts stated your are using the following for your web.de IMAP account:

INCOMING: account1, , (imap) imap.web.de:993, SSL, passwordCleartext
OUTGOING: , smtp.web.de:587, alwaysSTARTTLS, passwordCleartext, true"


I am surprised by "passwordClearText". I'm used to seeing either "Normal password" or "OAuth2" (gmail, yahoo etc.). I've never seen alwaysSTARTTLS. I'm used to seeing STARTTLS or SSL/TLS. Please explain.

I created a IMAP account in Thunderbird 60.3.3 for web.de using a bogus email address and password. I used manual config and then advanced config to bypass the login check. It successfully fetched settings for that email provider from the Mozilla ISP database. I'd expect the account number to be different . Why don't the rest of your settings match the other settings I used?

incoming: account16 (imap) imap.web.de:993 SSL/TLS Normal password
outgoing: smtp.web.de:587 STARTTLS Normal password true

tanstaafl
Moderator

User avatar
 
Posts: 45240
Joined: July 30th, 2003, 5:06 pm

Post Posted December 16th, 2018, 3:02 pm

My Local Folders account in the troubleshooting information has:
account2 (none) Local Folders None Normal password

Yours has:
account2, , (none) Local Folders, plain, passwordCleartext

What causes the connection security to be "plain"? It should be "none" as Local Folders doesn't know how to talk over the network to a mail server.

tanstaafl
Moderator

User avatar
 
Posts: 45240
Joined: July 30th, 2003, 5:06 pm

Post Posted December 16th, 2018, 3:10 pm

I installed a German version of Thunderbird 60.3.3 in a different directory to see if localization was causing the differences in terminology. I saw:

account2 (none) Local Folders Keine Passwort, normal
account16 (imap) imap.web.de:993 SSL/TLS Passwort, normal smtp.web.de:587 STARTTLS Passwort, normal true

"Keine" appears to mean None. "Passwort,normal" appears to mean Normal password. That seems to rule out it being a localization problem (i.e. not due to using a German version).

Baby0506
 
Posts: 3
Joined: December 16th, 2018, 4:13 am

Post Posted December 17th, 2018, 6:56 am

Hi tanstaafl,
thank you for the reply. As a result of you mail I looked closer to my tb installation and found, that I have now 2 TBs in parallel
1. Systemwide - the TB Version 52.9.1, 32 Bit. This is the one, which I installed intentionally. Updatesettings: Look for updates, but do not automatically install them
2. under my useraccount - TB 60.3.3, 32 Bit. Result of an automated update.

In both cases I did not intentionally do the settings with "passwordCleartext", this must be a result of some defaultsettings. I changed this accoding to your suggestion above.
I currently have the 2 TB versions 52.9.1 and 60.3.3 im parallel and can play mail-pingpong with some interesting results:
1.If I send an email to myself from TB 52.9.1 everything works fine: I can send it, a copy is stored in folder "sent" and the inbox updates and show me that message
2. If I now switch to TB 60.3.3 I see the new messahe in the inbox
I I sent a mail from TB 60, I get the message: WMail has been sent, but was not copied to the sent-folder, because there were problems accessing the network or files. Regardless if I select "Do not save" or "store locally" I do not receive the mail, I just sent in TB 60 within TB 60. To see this message, I have to close TB 60 and start TB 52. If I then stop TB 52 and start TB 60, I can see the new message also here.

Your second post from today seem to point to a problem with the local stage, which may cause the rest of the problems I have. As I did not intentionally do any settings here - I just used the defaultvalues from the installation - where are this values stored?
If I look at the settings for the local folders, both installations seem to be identically even if they behave differently:
If I go to "local folders"/"Lokale Ordner" I see in both TB-installations: "Account name"/"Konten-Bezeichnung" = "Lokale Ordner". Both installation use the same local folder.
Where can I find the values you metioned in your post?
Thank you
Bernd

tanstaafl
Moderator

User avatar
 
Posts: 45240
Joined: July 30th, 2003, 5:06 pm

Post Posted December 17th, 2018, 7:34 am

Your account settings are stored in the prefs.js file in the profile. You could edit that with a text editor or the config editor at tools -> options -> advanced -> general (think of it as about:config, but run from a menu)

When version 60 was initially released it was not available as a update to 52.9.1. You had to download the setup program for it. Once you installed it you could update it normally.

I suggest you use help -> troubleshooting information -> open folder in each version of Thundebrird, and see if they both open file explorer (windows explorer) at the same directory. I'd normally expect them to use the same profile.

The main issue with 52.9.1. and 60.3.3 sharing a profile is that if you modified extensions.strictCompatibility to false (to allow you to install add-ons that don't formally support version 60) it gets reset whenever you switch versions because the default value is different in the two versions. You can prevent that problem by setting it in the optional user.js file, which overrides whatever is set in prefs.js. If you never modified that setting, you don't have to do anything.

http://kb.mozillazine.org/User.js_file (user.js file)
http://kb.mozillazine.org/Profile_folder_-_Thunderbird (where is a profile)
http://kb.mozillazine.org/Files_and_fol ... hunderbird (whats in a profile)

Baby0506
 
Posts: 3
Joined: December 16th, 2018, 4:13 am

Post Posted December 18th, 2018, 7:41 am

Hi Tanstaafl,
finally I got it.
1. I did an uninstall/reinstall of both TB-installations and got the same result (TB 52 working, TB 60 not/ in the way I descibed above).
2. I deinstalled both versions again and manually deleted the directory under %profile%\appdata\roaming\Thunderbird
3. I installed TB 60 again. This time, I got a warning by myvirusscanner, guessing some suspect code in the tb-istallation, which I did not get before - caused by the deletion of the Thunderbird-dir.
4. I then got a message from TB 60, that he would not trust the certificate of web.de, which ist caused by the GDATA-AVK
5. I then (see GDATA-Supportpage) had to export the GDATA-certificate and import this into the TB-certificates
Everything is working now and we learned, that the installation has been influenced by my virus-scanner, something which you could not reproduce.
Thank you for the support. Maybe the guys, programming TB can take care to be more virus-scanner-compatile in the furture.
Best regards Bernd

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Google Adsense [Bot] and 10 guests