MozillaZine

Message filters "body" option missing from individual accoun

User Help for Mozilla Thunderbird
paulkruger
 
Posts: 19
Joined: June 3rd, 2006, 1:57 pm

Post Posted October 5th, 2018, 6:36 am

I have been trying to set up a filter due to recent flood of generic blackmail scams. They always have one of two passwords they seem to have gotten from hacked sites. ( long since changed anyway ) so I want to make a filter that removes those mails if the body contains those passwords.

I can find in Local Folders the option to filter on body but that does me no good. I have two other emails that get these but when I try to create same filter on either of those the option to filter on "BODY" is missing?

Any ideas why it would appear under "Local Folders" but not under email account folders and how can I fix that?

Thanks much. :D

DanRaisch
Moderator

User avatar
 
Posts: 120275
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted October 5th, 2018, 6:59 am

How are those accounts set up in Thunderbird, as POP or IMAP? Find out using menu path Tools->Account Settings->Server Settings->Server Type at the top right of the dialogue.

tanstaafl
Moderator

User avatar
 
Posts: 44326
Joined: July 30th, 2003, 5:06 pm

Post Posted October 7th, 2018, 10:28 am

POP accounts have Body as a choice in the list box. IMAP accounts don't. You need to add a custom header for Body if you want to filter that with a IMAP account. You can add custom headers by editing prefs.js (not recommended), using the Config Editor or by using the "customize..." option at the bottom of the leftmost list box in searches and message filters to add a custom header (it updates mailnews.customHeaders). Don't add a trailing ':' when adding the header. i.e. add Body not Body: .

http://kb.mozillazine.org/Message_Filters
http://kb.mozillazine.org/Custom_headers

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 4 guests