MozillaZine

How do I open TB messages indexed in recoll

User Help for Mozilla Thunderbird
robbyx
 
Posts: 902
Joined: September 1st, 2003, 10:08 am

Post Posted September 30th, 2018, 1:23 pm

I am using Ubuntugnome 18.04. I have my TB messages indexed by Recoll. My messages are stored locally as a result of using TB via pop3

When I find a message via Recoll that I wish to look at in TB, it is currently not opening there. Instead it opens in LibreOffice Writer and so all the underlying codes can be seen.
Here is an example a search by Recoll:

Preview Open 3 KB Re: [#880778] Setting up the free
message/rfc822 2013-10-13 18:56:01 +0100 file:///home/robins/.thunderbird/x8thazak.robin/Mail/Local Folders/001-Bel Man.sbd/internet connection 10
I think …


In the system default settings Thunderbird is shown as the default mail client. Mailbox files have individual global properties and they are set to open with TB mail.

What should I change to ensure that TB opens them nstead so that messages and attachments can be easily read?
Robin

tanstaafl
Moderator

User avatar
 
Posts: 44326
Joined: July 30th, 2003, 5:06 pm

Post Posted September 30th, 2018, 2:28 pm

Recoll has configuration files to specify what application should be used to view various file types. Perhaps that file has a setting that specifies LibreOffice Writer. i.e. its not paying attention to the system default settings because its using its own. I suggest you look at the mimeview file. It specifies which programs are started when you click on an Open link in a result list.

The manual states: "If Use desktop preferences to choose document editor is checked in the Recoll GUI preferences, all mimeview entries will be ignored except the one labelled application/x-all (which is set to use xdg-open by default)." Is "use desktop preferences" checked? That sounds like using the systems default settings.

http://www.lesbonscomptes.com/recoll/us ... EVIEW.html
http://www.lesbonscomptes.com/recoll/us ... INDEX.html

tanstaafl
Moderator

User avatar
 
Posts: 44326
Joined: July 30th, 2003, 5:06 pm

Post Posted October 5th, 2018, 12:41 am

Did that work?

robbyx
 
Posts: 902
Joined: September 1st, 2003, 10:08 am

Post Posted October 5th, 2018, 6:37 am

I could not find the reference to defaulting to desktop preferences in the recoll gui preferences. It does not seem to be there.

Mimeview had no active content, but I tried adding the following active lines, from the example file. My changes did not work:

# The system-wide configuration files for recoll are located in:
# /usr/share/recoll/examples
# The default configuration files are commented, you should take a look
# at them for an explanation of what can be set (you could also take a look
# at the manual instead).
# Values set in this file will override the system-wide values for the file
# with the same name in the central directory. The syntax for setting
# values is identical.
application/x-all = xdg-open %u
# Opening mail messages not always works.
# - Thunderbird will only open a single-message file if it has an .eml
# extension
# - "sylpheed %f" seems to work ok as of version 3.3
# - claws-mail: no can do apparently
# - "kmail --view %u" works
message/rfc822 = thunderbird -file %f
text/x-mail = thunderbird -file %f
application/x-mimehtml = thunderbird -file %f
Robin

tanstaafl
Moderator

User avatar
 
Posts: 44326
Joined: July 30th, 2003, 5:06 pm

Post Posted October 6th, 2018, 1:16 am

See section 3.1.2 in http://www.lesbonscomptes.com/recoll/us ... EARCH.TIPS

"Clicking the Open link will start an external viewer for the document. By default, Recoll lets the desktop choose the appropriate application for most document types (there is a short list of exceptions, see further). If you prefer to completely customize the choice of applications, you can uncheck the Use desktop preferences option in the GUI preferences dialog, and click the Choose editor applications button to adjust the predefined Recoll choices. The tool accepts multiple selections of MIME types (e.g. to set up the editor for the dozens of office file types).

Even when Use desktop preferences is checked, there is a small list of exceptions, for MIME types where the Recoll choice should override the desktop one. These are applications which are well integrated with Recoll, especially evince for viewing PDF and Postscript files because of its support for opening the document at a specific page and passing a search string as an argument. Of course, you can edit the list (in the GUI preferences) if you would prefer to lose the functionality and use the standard desktop tool.

You may also change the choice of applications by editing the mimeview configuration file if you find this more convenient.

Each result entry also has a right-click menu with an Open With entry. This lets you choose an application from the list of those which registered with the desktop for the document MIME type.
"

I found screen shots of Recoll showing File | Tools | Preferences | Help as the toolbar in the main window, but none showing the actual Preferences dialog. Preferences doesn't lead you to a child menu to check "Use desktop preferences"?

robbyx
 
Posts: 902
Joined: September 1st, 2003, 10:08 am

Post Posted October 6th, 2018, 4:59 am

Thank for the detailed advice. The nearest I canifind to "use desktop prefs" is in the local parameters of the preferences.

"The parameters that follow are set either at the top level, if nothing or an emty line is selected in the listbox above, or for the selected subdirectory."

There are boxes "only mime types" and "exclude mime types" also one for skipped names.

The manual at 5.4.8.1 explains an approach similar to what you quoted.

"If you just wanted to change the application used by Recoll to display a MIME type which it already knows, you would just need to edit mimeview. The entries you add in your personal file override those in the central configuration, which you do not need to alter. mimeview can also be modified from the Gui."

Can you suggest what I need to put into the mimeview to ensure that TB opens the link.

I had put this into the mimeview but it makes no difference and libreOffice opens the link instead of TB

[view]
message/rfc822 = thunderbird -file %f
text/x-mail = thunderbird -file %f
application/x-mimehtml = thunderbird -file %f

Do you know how to get around this

# - Thunderbird will only open a single-message file if it has an .eml
# extension

I think my mail files do not have an extension
Robin

tanstaafl
Moderator

User avatar
 
Posts: 44326
Joined: July 30th, 2003, 5:06 pm

Post Posted October 6th, 2018, 1:22 pm

I've never used Recoll. I haven't used Linux for over a decade and the port of Recoll to Windows is not free, so its not practical for me to experiment with it under Windows 10.

Your mail files do not have an extension. Thunderbird normally stores the messages for each folder in a "mbox" file (that is the name of the format used). That is named after the folder, and has no file extension. So the mbox file for the inbox folder would be "inbox.". The "inbox.msf" file (a so called index file) has no messages, its basically just a cache of the folder listing. "inbox.sbd" is a renamed child directory used to help organize the mail folders into a hierarchy.

Recent versions of Thunderbird support using a variation of the maildir format for storage. That would store each message in a separate file, rather than storing all of the messages for a folder in a file. It uses the .eml file format, but the files have numeric names with no file extension.

You can use Thunderbird to view a message with a .eml file extension. File > save as -> file would save a message as a .eml file. File -> open -> saved message will view a .eml message, but used to not let you copy it to a folder. I can copy it to a folder using version 60.2.1. I don't know when they added that feature, its been requested for many years.

robbyx
 
Posts: 902
Joined: September 1st, 2003, 10:08 am

Post Posted October 6th, 2018, 2:57 pm

Thank you again for your help. Can you tell if I have misunderstood how to change the mimeview file?

I had put this into the mimeview but it makes no difference and libreOffice opens the link instead of TB

[view]
message/rfc822 = thunderbird -file %f
text/x-mail = thunderbird -file %f
application/x-mimehtml = thunderbird -
Robin

tanstaafl
Moderator

User avatar
 
Posts: 44326
Joined: July 30th, 2003, 5:06 pm

Post Posted October 7th, 2018, 1:32 am

I don't know. Looking at "6.4.6. The mimeview file":

* it uses %f. not %f
* I didn't see anything that says a -file is necessary. However I don't know whats in the default mimetype. file.
* message/rfc822 looks right. However, I can't find any documentation about text/x-mail and application/x-mimehtml MIME types. I even searched https://www.iana.org/assignments/media- ... ypes.xhtml .
* I don't understand why you added the trailing dash in the last entry.

robbyx
 
Posts: 902
Joined: September 1st, 2003, 10:08 am

Post Posted October 8th, 2018, 12:07 pm

Let me know if you find a solution. I made the changes to %f but it made no difference. So I am living with the defect and having to just use the preview mode. Thank you for trying. For the moment I have given up.
Robin

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 10 guests