MozillaZine

[RESOLVED] How do i suppress subject line graphics?

User Help for Mozilla Thunderbird
mbott
 
Posts: 16
Joined: February 11th, 2007, 12:25 pm
Location: Central OH

Post Posted June 29th, 2018, 5:24 pm

This has become an issue within the last 10 days or so. Seems that I'm getting at least one e-mail a day with graphics in the subject line. It there a way to suppress or eliminate these?

--
Mike
Last edited by mbott on June 29th, 2018, 5:45 pm, edited 1 time in total.

mbott
 
Posts: 16
Joined: February 11th, 2007, 12:25 pm
Location: Central OH

Post Posted June 29th, 2018, 5:44 pm

Ah, finally found the issue. I disabled the Noto Color Emoji font and that seems to have done the trick. Evidently it is a but in Ubuntu 18.04.

tanstaafl
Moderator

User avatar
 
Posts: 44486
Joined: July 30th, 2003, 5:06 pm

Post Posted June 29th, 2018, 10:16 pm

Thanks for sharing that information. If the problem re-occurs see viewtopic.php?f=39&t=3033601 . It discusses a more generic problem with icons in the Subject.

KFlash
 
Posts: 14
Joined: November 5th, 2004, 6:56 am
Location: Germany

Post Posted August 18th, 2018, 1:27 pm

mbott wrote:Ah, finally found the issue. I disabled the Noto Color Emoji font and that seems to have done the trick. Evidently it is a but in Ubuntu 18.04.


How do you do this? I did not find any setting in TB regarding the application font.

tanstaafl
Moderator

User avatar
 
Posts: 44486
Joined: July 30th, 2003, 5:06 pm

Post Posted August 18th, 2018, 2:15 pm

https://www.fosslinux.com/3952/how-to-e ... 04-lts.htm

In a terminal window: sudo apt remove fonts-noto-color-emoji

https://bugs.launchpad.net/ubuntu/+sour ... ug/1761844 talks about installing several other font packages as a workaround.

mbott
 
Posts: 16
Joined: February 11th, 2007, 12:25 pm
Location: Central OH

Post Posted August 18th, 2018, 2:26 pm

KFlash wrote:
How do you do this? I did not find any setting in TB regarding the application font.


Disabling via Settings > Font Manager also works in Ubuntu 18.04.

--
Mike

KFlash
 
Posts: 14
Joined: November 5th, 2004, 6:56 am
Location: Germany

Post Posted August 19th, 2018, 11:03 pm

tanstaafl wrote:https://www.fosslinux.com/3952/how-to-enable-disable-color-emoji-in-ubuntu-18-04-lts.htm

In a terminal window: sudo apt remove fonts-noto-color-emoji

https://bugs.launchpad.net/ubuntu/+sour ... ug/1761844 talks about installing several other font packages as a workaround.


That "solved" the problem.
But to be honest, it would be much better if somebody from Mozilla checks back with the guys from Ubuntu regarding those characters.
Why is this bug/misrendering only visible in Thunderbird and not in i.e. KDEs Kate? At least the subject lines I copied to Kate are displayed correctly.

A nice summary of the problem is here:
http://www.answers.candoerz.com/questio ... o-big.aspx

It looks like the fault is with Mozilla, and not with the OS.

tanstaafl
Moderator

User avatar
 
Posts: 44486
Joined: July 30th, 2003, 5:06 pm

Post Posted August 19th, 2018, 11:24 pm

The first post in https://bugzilla.mozilla.org/show_bug.cgi?id=1416018 states:
"The following bug as been reported in ubuntu: https://bugs.launchpad.net/ubuntu/+sour ... ug/1694329 . Apparently ubuntu is not shipping the EmojiOneMozilla.ttf font in their package and this is causing emoji to be oversized. I've been personally able to reproduce the same issue with thunderbird in debian. The thunderbird package is not shipping the EmojiOneMozilla.ttf font."

See viewtopic.php?p=14796077#p14796077 for more information

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 2 guests