MozillaZine

How to block remote images in messages after turned on?

User Help for Mozilla Thunderbird
SMCorp
 
Posts: 105
Joined: September 6th, 2007, 9:26 pm
Location: USA

Post Posted May 17th, 2018, 3:41 am

For computer OS reasons, I'm using Mozilla Thunderbird version 2.0.0.23 (20090812) and won't upgrade it.

When I see an e-mail in the inbox, there is a light yellow area at the top of the message that says, "To protect your privacy, Thunderbird has blocked remote images in this message.", on the right side is a gray button that says, "Load Images", and on the left side is a link that says, "Click here to always load remote images from (email address)", to approve that sender forever more.

Though this was very, very helpful ten years ago in blocking spam engines from using remote images to confirm my e-mail was valid, I ended up clicking the "Click here to always load remote images from (email address)" for most of my mailing list e-mails that I needed to look at quickly, so I wouldn't have to click that same "Load Images" button again and again.

My problem now is I don't see a way to UN-DO that setting.

Years ago, I'd clicked it for e-mails that used to be just honest e-mails and all I was letting through were graphics to see what it was and to make it more readable, but in later years they started to have massive adware working on them, so just clicking that mail (without even opening it) makes my browser blow up with error boxes like, "Alert - Thunderbird can't connect securely to (whatever domain) because the site uses a security protocol that isn't enabled."

This is an unuseful message, because it doesn't involve anything needing security, just part of the dumb trend that EVERY PAGE ON THE INTERNET is now an SSL site that loads 50x slower for no potential benefit to the visitor ("Oh my god, better secure this connection with 128-bit SSL encryption so no one but me can read this CNN fake news article!").

Some mails, like eBay daily search mails, used to be honest mails, they couldn't tell if I was getting or reading them or not, but now EACH ONE (of 30-50/day) blows up with 11 error boxes one after the other. I would not have clicked that link years ago if I'd known this would happen.

How can I (easily, without hacking the system registry, etc.) un-do this setting for some of my senders? This way, the "Load Images" button and other link would reappear, and I wouldn't click it again.

Thank you.

morat
 
Posts: 2865
Joined: February 3rd, 2009, 6:29 pm

Post Posted May 17th, 2018, 4:59 am

I don't know if the solution works with Thunderbird 2.0. I can't check the Gecko 1.8.1 source since it isn't online anymore.

Changing your mind about "show remote content"
viewtopic.php?f=39&t=2744597

Undoing "Show remote content in this message"
viewtopic.php?f=39&t=2864297

LIMPET235
Moderator

User avatar
 
Posts: 38420
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted May 17th, 2018, 5:03 am

Hi,
I am not a Thunderbird guru but after a bit of a search of the "Prefs/about:config" page,
I found this reference to Loading images.
> permissions.default.image
Open Thunderbird & go to, Tools > Options > Advanced > General.
There should be a button for the Config Editor.
The above pref's default is one. (1) This is what mine is set to.
(I use version 2.0.0 24.)
&, I can see all the "Options" for loading images at the top.

Please ref; the options...
1 (default): Allow all images to load, regardless of origin. This also enables the "Show Remote Content" button.
2: Block all images from loading.
3: Prevent third-party images from loading.

Reset it to two. (2)

Close & reopen Thunderbird & see what happens next time an image is emailed to you.
Again, I am not a Thunderbird expert, so there may be another setting.
Wait for someone more knowledgeable perhaps?

Moving this to Thunderbird Support...
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-57.0-61.0-62.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.11.0.
RadioYachting. (Always choose the "Custom" Install.)

SMCorp
 
Posts: 105
Joined: September 6th, 2007, 9:26 pm
Location: USA

Post Posted May 17th, 2018, 5:24 am

Thank you very much for your replies, morat and LIMPET235.

I saw them both at the same time, and the first link in the first one solved it.

morat, I'm sorry you had to do my searching for me! I looked a few weeks ago and couldn't find a solution, then today before my post. Maybe my subject title is better and people can find it in the future.

For anyone else who has this problem and finds my subject title first, here's what fixed it for me:

Find the contact for that address in your address book, select properties, and uncheck "allow remote content".

In my case, it was ebay@ebay.com, and was fixed by clicking on that entry in my address book, then it opens the box titled "Edit Card for eBay.", then I fixed it by unchecking "Allow remote images in HTML mail."

This is a lot of work in the background I didn't know about. I never made a card for ebay@ebay.com, and I never checked that box, Thunderbird itself added that card and checked that box when I hit the "Load Images" button years ago.

Now I can quickly click through dozens of e-mails, no errors.

Thanks everyone.

LIMPET235
Moderator

User avatar
 
Posts: 38420
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted May 17th, 2018, 6:01 am

&, a big, Thank You for the feedback.
It may just help others that strike the same problem.
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-57.0-61.0-62.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.11.0.
RadioYachting. (Always choose the "Custom" Install.)

Return to Thunderbird Support


Who is online

Users browsing this forum: Belles, Bing [Bot] and 4 guests