MozillaZine

toolbar keeps disappearing

User Help for Mozilla Thunderbird
slickrcbd
 
Posts: 351
Joined: September 1st, 2010, 1:57 am

Post Posted January 11th, 2018, 8:23 am

I have a second custom toolbar I use for all the common operations I do.
It keeps disappearing and I have to recreate it every couple of days.

Is this a bug in the latest version, or is it a corrupt profile? Something similar happened once with Firefox a few years ago that required me to create a new profile.

However, if I went that route and needed a new profile, how would I get the messages I downloaded from a now-defunct e-mail account transferred to the new account? My work place changed e-mail systems with a warning that all e-mails would be lost, so I only have the saved local copies.

If it is a bug in the current version, I'll just revert to an earlier version until they update. There is nothing new added in the last few years that I use.

tanstaafl
Moderator

User avatar
 
Posts: 43868
Joined: July 30th, 2003, 5:06 pm

Post Posted January 11th, 2018, 10:21 am

By second custom toolbar do you mean one of the built-in toolbars that you have customize what buttons it uses, or do you mean a toolbar added by an add-on? More details would help.

slickrcbd
 
Posts: 351
Joined: September 1st, 2010, 1:57 am

Post Posted January 11th, 2018, 5:20 pm

I have had T-bird configured to look like this for years
ImageTB31from by slickrcbd, on Flickr

However, the line that says "reply, reply all, reply to list, archive, forward, delete, next, previous..." keeps going away when I turn off my computer and I have to re-create it from scratch.

P.S. I recycled an old photo rather than making and uploading a new screenshot.

tanstaafl
Moderator

User avatar
 
Posts: 43868
Joined: July 30th, 2003, 5:06 pm

Post Posted January 11th, 2018, 5:56 pm

That is the mail toolbar, enabled via view -> toolbars -> mail. Try re-enabling it, right clicking on the toolbar, selecting "customize", and then press "restore default set" and "OK".

If that doesn't help see http://kb.mozillazine.org/Toolbar_or_wi ... ot_working . You might need to just delete the xulstore.json file and restart.

slickrcbd
 
Posts: 351
Joined: September 1st, 2010, 1:57 am

Post Posted January 11th, 2018, 11:59 pm

The second line that says "reply, reply all, reply to list, archive, forward, delete, next, previous..." disappears, leaving only the line that says "get messages, write, chat, address book..."
When I try to re-enable it, all available options are checked, and I have to create a new toolbar from scratch.
Doing it every couple of days wastes time and is VERY annoying.

I will try deleting xulstore.json, however, as the problem is annoyingly intermittent, I might not know for a week.

tanstaafl
Moderator

User avatar
 
Posts: 43868
Joined: July 30th, 2003, 5:06 pm

Post Posted January 12th, 2018, 12:26 am

Just to be clear, when the problem occurs the actual toolbar doesn't disappear, you just lose your customizations for that toolbar and it uses the default buttons?

If this is a relatively new problem its possible this is a side effect of an add-on that doesn't work correctly anymore due to recent changes in the Mozilla toolkit. Some APIs meant for legacy add-ons have been deleted (due to Firefox's move to the web extension API). The Thunderbird developers are trying to support both legacy add-ons and ones using web extension based APIs, but that can require some updates to the add-on. If you are using a add-on that is no longer actively maintained you can run into problems. The developers appear to be trying to update some of the most popular abandoned add-ons so that they will continue working. This is mainly meant as a effort in preparation for the next major version of Thunderbird, when there will be more significant changes to the Mozilla toolkit.

slickrcbd
 
Posts: 351
Joined: September 1st, 2010, 1:57 am

Post Posted January 12th, 2018, 10:40 am

When I customize, there is an option to "add new toolbar". It is the new toolbar I add that disappears. Annoying because it has the most used buttons. The changes made to the built-in one stick.
It happens 1-4 times a week since Christmas. At first I thought it was an update glitch that reset my UI layout, but the day after I fixed it the second toolbar disappeared again. It is intermittent, there was almost a week at one point between glitches.

tanstaafl
Moderator

User avatar
 
Posts: 43868
Joined: July 30th, 2003, 5:06 pm

Post Posted January 12th, 2018, 10:57 am

I had never noticed the add new toolbar button and have never used it. However, have you considered just adding and removing buttons as desired in the mail toolbar instead? That will give you more usable real estate.

Looking at your screen image again you even added a File.. list box button despite having File.. on the menu bar. Perhaps you should remove the menu bar.

slickrcbd
 
Posts: 351
Joined: September 1st, 2010, 1:57 am

Post Posted January 15th, 2018, 10:54 am

You are missing the point, I've had a feature that I've used for a decade, ever since the Mozilla suite was discontinued, and suddenly due to a bug I have to cut the number of buttons I use in half. Old habits now.
I should boot up my Windows 98SE machine and post a screenshot, I've got it configured the same way with Thunderbird 2.0.

tanstaafl
Moderator

User avatar
 
Posts: 43868
Joined: July 30th, 2003, 5:06 pm

Post Posted January 15th, 2018, 11:02 am

I understand why you want to maintain the status quo. But I don't know of a fix for your problem. AFAIK all of the toolbars and their buttons are stored together.

The best I can suggest is to browse http://kb.mozillazine.org/Toolbar_or_wi ... ot_working

https://bugzilla.mozilla.org/show_bug.cgi?id=363981 is the original bug report requesting the ability to add toolbars. I searched the bugs database and couldn't find any bug reports about your problem.

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 4 guests