MozillaZine

Trouble sending email with 52.4.0

User Help for Mozilla Thunderbird
sankeny
 
Posts: 36
Joined: January 7th, 2003, 8:04 am

Post Posted November 7th, 2017, 3:43 am

I'm having a similar problem.

Linux Mint 18.2
Thunderbird 52.4.0
openssl 1.02g-1ubuntu4.9 (updated 11-6-17)

I had a running instance of Thunderbird with several working accounts: cinergymetro.net, gmail.com, safe-mail.com

I shutdown the laptop, and when I brought it back several hours later, Thunderbird would not connect to any mail servers. I can neither receive nor send from Thunderbird. I installed claws-mail, and it connects properly to my mail servers with the same settings as Thunderbird. The only "change" I see is the recent upgrade of openssl from 4.8 to 4.9 which occurred prior to my shutdown.

When receiving, it never completes its connection to the mail server. When sending, it returns the error:

    Sending of the message failed.
    An error occurred while sending mail: Could not get password for smtp.cinergymetro.net. The message was not sent.

Any thoughts or suggestions? I have considered downgrading openssl or uninstalling Thunderbird and reinstalling. Thx

bread_baby
 
Posts: 1
Joined: November 7th, 2017, 4:06 am

Post Posted November 7th, 2017, 4:17 am

I have the same problem. I resolved it by changing authentication method to 'no authentication'. However this doesn't seem right..

windows 10.
Thunderbird 52.4 32-bit
Shared server webhosting mail.

Incoming messages require authentication STARTTLS, normal password.
outgoing smtp messages only work STARTTLS, no authentication.

--------------------------------

My Yahoo mail works. It uses 0auth.

DanRaisch
Moderator

User avatar
 
Posts: 117741
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted November 7th, 2017, 5:04 am

sankeny, I split your post from it's original location as your issue is not the same as that being dealt with there. You're not accessing an Outlook/Hotmail account or running Windows as is the case in that topic.

Are you running a version of Thunderbird directly from Mozilla or one from the Linux distro?

sankeny
 
Posts: 36
Joined: January 7th, 2003, 8:04 am

Post Posted November 7th, 2017, 12:49 pm

I'm using the Thunderbird instance that comes from the Linux Mint (Ubuntu) repository.

Also, I've tried "No authentication," and I've tried various other authentication settings, none of which worked.

As I stated in the original, I installed a different mail client, and it works. I compared the authentication there with that in Thunderbird, and I've also tried setting up a "new" account with the mail server (no success) to compare the settings Thunderbird finds. Still no success.

Is there a way to "reset" the SSL/TLS settings? It seems as though Thunderbird needs to create new certificates or handshakes.

sankeny
 
Posts: 36
Joined: January 7th, 2003, 8:04 am

Post Posted November 10th, 2017, 6:52 am

I restarted in "Safe Mode" and read the "Error Console"

    Could not read chrome manifest 'file:///usr/lib/thunderbird/chrome.manifest'.
    : Component returned failure code: 0x805a1f9b [nsIPK11Token.initPassword] crypto-SDR.js:66
    Error: Initialization failed storage-json.js:90:13
    NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "Initialization failed" {file: "resource://gre/components/storage-json.js" line: 90}]'[JavaScript Error: "Initialization failed" {file: "resource://gre/components/storage-json.js" line: 90}]' when calling method: [nsILoginManagerStorage::initialize] nsLoginManager.js:134
    : Component returned failure code: 0x805a1f9b [nsIPK11Token.initPassword] crypto-SDR.js:66
    Error: Initialization failed storage-json.js:90:13
    NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "Initialization failed" {file: "resource://gre/components/storage-json.js" line: 90}]'[JavaScript Error: "Initialization failed" {file: "resource://gre/components/storage-json.js" line: 90}]' when calling method: [nsILoginManagerStorage::initialize] nsLoginManager.js:134
    NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService] msgOAuth2Module.js:99
    Error in parsing value for ‘box-sizing’. Declaration dropped. start-style.css:96:14
    Error in parsing value for ‘box-sizing’. Declaration dropped. start-style.css:152:14
    Error in parsing value for ‘box-sizing’. Declaration dropped. start-style.css:212:14
    Expected media feature name but found ‘-webkit-min-device-pixel-ratio’. start-style.css:339:8
    An error occurred executing the cmd_getNewMessages command: [Exception... "Component returned failure code: 0x8055000a [nsIMsgIncomingServer.getNewMessages]" nsresult: "0x8055000a (<unknown>)" location: "JS frame :: chrome://messenger/content/mailWindowOverlay.js :: GetNewMsgs :: line 2753" data: no] globalOverlay.js:103
    A promise chain failed to handle a rejection. Did you forget to '.catch', or did you forget to 'return'?
    See https://developer.mozilla.org/Mozilla/J ... sm/Promise

    Date: Thu Nov 09 2017 07:35:35 GMT-0500 (EST)
    Full Message: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
    Full Stack: JS frame :: resource://gre/modules/XPCOMUtils.jsm :: XPCU_serviceLambda :: line 230
    JS frame :: resource://gre/modules/XPCOMUtils.jsm :: XPCU_defineLazyGetter/<.get :: line 198
    JS frame :: resource://gre/components/msgAsyncPrompter.js :: runnablePrompter.prototype.run< :: line 23
    JS frame :: resource://gre/modules/Task.jsm :: TaskImpl_run :: line 319
    JS frame :: resource://gre/modules/Task.jsm :: TaskImpl :: line 277
    JS frame :: resource://gre/modules/Task.jsm :: createAsyncFunction/asyncFunction :: line 252 XPCOMUtils.jsm:230
    : Component returned failure code: 0x805a1f9b [nsIPK11Token.initPassword] crypto-SDR.js:66
    Error: Initialization failed storage-json.js:90:13
    NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "Initialization failed" {file: "resource://gre/components/storage-json.js" line: 90}]'[JavaScript Error: "Initialization failed" {file: "resource://gre/components/storage-json.js" line: 90}]' when calling method: [nsILoginManagerStorage::initialize] nsLoginManager.js:134
    : Component returned failure code: 0x805a1f9b [nsIPK11Token.initPassword] crypto-SDR.js:66
    Error: Initialization failed storage-json.js:90:13
    NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "Initialization failed" {file: "resource://gre/components/storage-json.js" line: 90}]'[JavaScript Error: "Initialization failed" {file: "resource://gre/components/storage-json.js" line: 90}]' when calling method: [nsILoginManagerStorage::initialize] nsLoginManager.js:134
    : Component returned failure code: 0x805a1f9b [nsIPK11Token.initPassword] crypto-SDR.js:66
    Error: Initialization failed storage-json.js:90:13
    NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "Initialization failed" {file: "resource://gre/components/storage-json.js" line: 90}]'[JavaScript Error: "Initialization failed" {file: "resource://gre/components/storage-json.js" line: 90}]' when calling method: [nsILoginManagerStorage::initialize] nsLoginManager.js:134

I have changed "javascript.enabled;true" to "javascript.enabled;false" in Thunderbird "about:config"

Looking at the first line in the "Error Console"

    Could not read chrome manifest 'file:///usr/lib/thunderbird/chrome.manifest'.

That file DOES NOT exist at "/usr/lib/thunderbird" but at "/usr/lib/firefox/browser' instead. Should it be created?

Alternatively, what's going on with Javascript in Thunderbird? This is getting frustrating.

Edit: Should I post my questions on SuperUser or some other site?

sankeny
 
Posts: 36
Joined: January 7th, 2003, 8:04 am

Post Posted November 12th, 2017, 5:34 pm

After no response, I finally decided to "purge" every instance of Thunderbird from my machine and start from scratch.

It worked successfully, as two of my accounts are back and running. I have no idea WHY they suddenly stopped connecting to the mail servers.

I am not going to mark this [SOLVED] as no one solved anything. Thanks for reading.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 4 guests