MozillaZine

Empty From broken header TB won't download from server

User Help for Mozilla Thunderbird
kcbenson
 
Posts: 2
Joined: April 17th, 2017, 6:19 am

Post Posted April 17th, 2017, 7:43 am

I'm not sure if TB really should bear the responsibility of being able to download broken-header emails, but I don't see how this could be definitively fixed at any other point in the process. The problem is that my email server is receiving emails with malformed headers. Thunderbird sees them but won't download them. The broken header causes the From address to be cut off the header and exposed as text. TB sees the email on the server, but won't download it. The result is that the New Mail notification shows up in the system tray, but there is no new mail in my Inbox. I can log into webmail and delete the offending emails, but I'm getting two or three of these every day. I can reject the address at the server level, but the addresses keep changing.

TB 45.8.0 on Windows 10 64-bit, IMAP mail server

Broken header looks like this (example.com substituted for my domain):

Return-Path: <4018-11-1851794-164-kbenson=example.com@mail.derrar.us>
Delivered-To: kcbenson-example:com-kbenson@example.com
X-Envelope-To: kbenson@example.com
Received: (qmail 11371 invoked from network); 17 Apr 2017 12:07:32 -0000
Received: from mailwash38.pair.com (66.39.2.38)
by issara.pair.com with ESMTPS (DHE-RSA-AES256-GCM-SHA384 encrypted); 17 Apr 2017 12:07:32 -0000
Received: from localhost (localhost [127.0.0.1])
by mailwash38.pair.com (Postfix) with SMTP id 0E8B67368D
for <kbenson@example.com>; Mon, 17 Apr 2017 08:07:32 -0400 (EDT)
X-Virus-Check-By: mailwash38.pair.com
X-Spam-Check-By: mailwash38.pair.com
X-Spam-Status: Yes, hits=15.9 required=5.0 tests=DCC_CHECK,DKIM_SIGNED,MISSING_DATE,MISSING_FROM,MISSING_HEADERS,MISSING_MID,MISSING_SUBJECT,PP_
MIME_FAKE_ASCII_TEXT,RDNS_NONE,T_DKIM_INVALID,URIBL_ABUSE_SURBL,URIBL_DBL_SPAM,URIBL_INV autolearn=disabled version=3.004001
X-Spam-Flag: YES
X-Spam-Level: ***************
X-Spam-Filtered: 588005fbbae6c4834a150da29fd9aa07
Received: from localhost (localhost [127.0.0.1])
by mailwash38.pair.com (Postfix) with SMTP id 2F5817367D
for <kbenson@example.com>; Mon, 17 Apr 2017 08:07:31 -0400 (EDT)
Received: from oxnard.derrar.us (unknown [104.140.246.140])
by mailwash38.pair.com (Postfix) with ESMTP
for <kbenson@example.com>; Mon, 17 Apr 2017 08:07:31 -0400 (EDT)
DKIM-Signature: v=1; a=rsa-sha1; c=relaxed/relaxed; s=k1; d=derrar.us;
h=Content-Type:Date:From:Reply-To:Subject:To:Message-ID; i=Diabetes_Protection@derrar.us;
bh=TSP5Xc84Gf6QQ0HV4HAHdTJYUWA=;
b=UFUcbR1lihx579wft7yBdw2gJ3e4UD0gf+nW3wS3fSR4s0peLKOA9dAan1YhBfRhrMSTF9YyHBD/
zDdudX31PQ7wCuQU2Smdd/GLHuG88ZqZwLFASGvUR4fOt5cyEa4S0EHfOgPIt6fK+/hCRhWLqaxS
EtLMpv2CDZy4xJ5J5a4=
DomainKey-Signature: a=rsa-sha1; c=nofws; q=dns; s=k1; d=derrar.us;
b=jHp7PjTWF27nFCyL8gd3886xBgfhgZeM++y1gndksccdCAZRaCSZKErAlzXL7+Y8VXwQSLapxNxC
6lwKAoKQWXE26Cwuk7U9irXVMePUF/rziZ7H9A8Jxy7lK20v17sd9uXU/SB0YPl0ylTHwNvn6UE8
MkiZHCuKazdXCJE/M9A=;

Mime-Version: 1.0
Content-Type: multipart/alternative; boundary="1ce6a5af2f2396824bc65a36cca83213"
Date: Mon, 17 Apr 2017 07:59:22 -0400
From: "Blood-Sugar-Guardian" <Diabetes_Protection@derrar.us>
Reply-To: "Blood-Sugar-Guardian" <Diabetes_Protection@derrar.us>
Subject: 45 Doctor SECRETS For Fighting Pre-Diabetes Before It’s Too Late
To: <kbenson@example.com>
Message-ID: <0.0.1851794.axzjlw1c4192ywptrc647017.0@derrar.us>

--1ce6a5af2f2396824bc65a36cca83213
Content-Type: text/plain;

Everything from "Mime-Version: 1.0" and lower shows up in the email body.

Thanks for any help you can give me,
Ken Benson
Last edited by LIMPET235 on April 17th, 2017, 7:47 am, edited 1 time in total.
Reason: Post edited to wrap any long lines in it.

tanstaafl
Moderator

User avatar
 
Posts: 42552
Joined: July 30th, 2003, 5:06 pm

Post Posted April 17th, 2017, 2:56 pm

Moved from Thunderbird Bugs to Thunderbird Support as you are not discussing a workaround for a confirmed bug reported at https://bugzilla.mozilla.org/ . The closest match I found was https://bugzilla.mozilla.org/show_bug.cgi?id=667288 which was due to Thunderbird not removing a Unix Mbox mail separator line in a local mail folder file upon IMAP upload, if some variants of the Unix Mbox separator were used in the local mail folder file, causing the upload to fail due to broken headers. Basically a compatibility problem due to there being so many different standards for mbox files.

The example you gave appears to have a valid From: header. The h= argument in the DKIM-Signature: header looks weird but I compared it to several other messages and I suspect its okay. Its weird to see a Reply-To: header set to the same value as the From: header but I suspect thats legal.

Mime-Version: 1.0 is invalid. I'm used to seeing both the MIME version and the first Content-Type header after the To/cc headers though I don't know if the rfc requires that. That might be why you are seeing those headers in the message body text.

Its unrealistic to expect Thunderbird to fix such a broken message. From your description webmail doesn't either. If this occurs with all of your messages you need to complain to your email provider. If it occurs only with messages from certain people you need to contact them and see if you are the only one running into this problem.

Who is your email provider? A web host provider such as Dreamhost or Gator?

kcbenson
 
Posts: 2
Joined: April 17th, 2017, 6:19 am

Post Posted April 17th, 2017, 7:26 pm

I guess I wasn't clear. These are spam messages. I don't want them fixed. I just want them off the server so they don't trigger the New Mail notification.

Webmail *does* display these, so webmail is doing better than Thunderbird, although I wouldn't expect either to fix them. I just would like Thunderbird to download them along with all my other mail so I can delete them or, ideally, let them go to my Spam folder. I get only two or three of these a day; the rest of my mail is fine. It's not my provider's fault; this is just spam (malformed, probably intentionally) getting past the filter. My provider is Pair Networks (yes, also my web host provider).

I agree that I'm seeing part of the header in the body because "Mime-Version: 1.0" is invalid. While my example may appear to have a valid From: header, the From: header is displaying as part of the email body, so there really is no From: header.

I don't expect there is any kind of workaround to this other than what I'm already doing (deleting them through webmail, adding the domain to a reject list). I was more looking for a someone to agree or disagree with me that this is a bug so I can report it or not report it. Is leaving malformed emails on the server while showing the New Mail notification really intended behavior?

tanstaafl
Moderator

User avatar
 
Posts: 42552
Joined: July 30th, 2003, 5:06 pm

Post Posted April 17th, 2017, 10:48 pm

No. However I suspect the code to check for new mail does not examine the contents, so it doesn't know its not displayable. Given that the tb-planning list has lots of traffic recently about exactly how should they develop a replacement for the existing Thunderbird in order to deal with not being able to rely upon Gecko (HTML rendering engine developed for Firefox) and XUL much longer I suspect their attitude will be its not worth fixing if it mainly occurs with spam.

If you decide to submit a bug report at https://bugzilla.mozilla.org/ please post a link to it afterwards.

Return to Thunderbird Support


Who is online

Users browsing this forum: Google [Bot] and 7 guests