MozillaZine


autocompletion of address

User Help for Mozilla Thunderbird
grzz76
 
Posts: 99
Joined: October 2nd, 2004, 7:09 am

Post Posted January 13th, 2021, 8:27 am

I am having trouble with typing in an address:

I want to send an email to xyz@domain.com but my address book has an entry with email xyzabc@domain.com so the address fills with xyzabc@domain.com.

How do I prevent this autocompletion for this one instance?

Thanks,

DanRaisch
Moderator

User avatar
 
Posts: 124067
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted January 13th, 2021, 8:57 am

What version of Thunderbird?
Have you tried opening the Contact Sidebar (press F9) in the composition window and selecting the preferred address from that list?

grzz76
 
Posts: 99
Joined: October 2nd, 2004, 7:09 am

Post Posted January 13th, 2021, 10:28 am

Version 78.6.1

xyz@domain.com is an email that is not in my contact list. So I am typing that address in the address section of an email, but autocomplete is putting in xyzabc@domain.com, which is in the contact list.

In other words, autocomplete is entering an email from my contact list for an address that I'm trying to enter manually (because it is not in my contact list).

tanstaafl
Moderator

User avatar
 
Posts: 47301
Joined: July 30th, 2003, 5:06 pm

Post Posted January 13th, 2021, 2:28 pm

Just ignore the autocomplete entry and continue typing. The text should turn red once it no longer matches anything in the address books. At that point it should automatically remove the remainder of the auto-complete address.

You could also add xyz@domain.com to one of your other address books such as the history address book. No need to full out other contact details if you just want to be able to choose it from the auto-complete popup window.

WaltS48

User avatar
 
Posts: 4583
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted January 13th, 2021, 5:32 pm

You right click in the address and edit it.
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

mgagnonlv
 
Posts: 764
Joined: February 12th, 2005, 8:33 pm

Post Posted January 13th, 2021, 6:56 pm

Either that or type "xyz@". That is, assuming that the address "xyz@domain.com" is part of your previous contacts.

Depending on how your preferences are set, it will prefill addresses from all the contacts you have PLUS all addresses collected in the "Collected Addresses" address book. You can change your preferences under Tools –> Options –> Composition –> Addressing.

Likewise, if you use the Cardbook extension, there is a preference telling it what address book(s) to use for autocompletion.

If you have no idea where the "xyzabc@domain.com" comes from, often, the culprit is found in the "collected addresses" address book. Search for that address and delete it from there.
Michel Gagnon
Montréal (Québec, Canada)

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 8 guests