MozillaZine

Start Page Preference Ignored

User Help for Mozilla Thunderbird
greybeard2012
 
Posts: 73
Joined: October 21st, 2012, 8:27 pm

Post Posted November 8th, 2019, 6:18 am

From when I updated to the newer GUI v68.2.1 last week and the latest update v68.2.2 the menu Options > Options > General > Thunderbird Start Page setting appears it is being totally ignored.

Whether I have the box ticked or not the "When Thunderbird launches show Start Page in the message area" my start page is now my Inbox rather than the main general Thunderbird start page as it had been before.

In theory if the box is pre-ticked, which with v68.2.1 and v68.2.2 it is, it should use the page specified in the Location address box ie. by default:-

https://live.thunderbird.net/thunderbir ... 1105113228

That's the Welcome to Thunderbird web page, but it is not even using that.

I want the start page to be the program's main general Thunderbird Mail - .......primary account page not my Inbox contents. I have to sign in of course but those, possibly private, email headers, senders; names, dates etc are still visible to all and sundry behind the sign in box.

I've changed nothing yet but as other here have reported too I've also noticed since the update my font preference had been changed to use Calibri 17pt. Where that came from I can't even guess because whilst Calibri is an MS default for some stuff I've never used it at 17pt, ever. My previous setting was for Tahoma 16pt. I've changed that back and it is now being used.

I suspect some about:config settings have been changed in these latest Thunderbird updates and they're overriding user preferences. Is there a setting entry there I can alter to get the start page back to what it was previously?

tanstaafl
Moderator

User avatar
 
Posts: 45896
Joined: July 30th, 2003, 5:06 pm

Post Posted November 8th, 2019, 7:48 am

You should be able to check the checkbox to use the Thunderbird start page, and then press the restore default button at the right end of the Location" field. The Location field and the restore default button are disabled/greyed out when using the start page is disabled.

morat
 
Posts: 3492
Joined: February 3rd, 2009, 6:29 pm

Post Posted November 8th, 2019, 8:48 am

I can't use an "about:" or "file:" url for the start page anymore?

Succeeds
http://www.mozillazine.org/

Fails
about:about

Fails
file:///C:/bookmarks.html

Start Page for mail
http://kb.mozillazine.org/Start_Page_for_mail

Thunderbird 68.2.2
Windows 7 SP1 32-bit
Last edited by morat on November 11th, 2019, 9:25 am, edited 1 time in total.

tanstaafl
Moderator

User avatar
 
Posts: 45896
Joined: July 30th, 2003, 5:06 pm

Post Posted November 8th, 2019, 9:10 am

viewtopic.php?f=39&t=3048711&hilit=+start+page is a old related thread about how to make the start page always show up using userContent.css. One reason why I mention that is that on my system with 68.2.2 when I specify a local .bmp file as the start page it is briefly displayed on startup and then a blank message pane shown. However the default start page is always shown correctly (doesn't go away).

greybeard2012
 
Posts: 73
Joined: October 21st, 2012, 8:27 pm

Post Posted November 8th, 2019, 10:06 am

tanstaafl wrote:You should be able to check the checkbox to use the Thunderbird start page, and then press the restore default button at the right end of the Location" field. The Location field and the restore default button are disabled/greyed out when using the start page is disabled.


Something has been changed in the new versions. The user settings have definitely been changed. My other PC with Thunderbird was updated at a different time and that too now shows the default font change to Calibri 17pt (previously Tahoma 16pt too).

I've now discovered the default start page link to the Thunderbird web site is being used it is just because I have it minimised at the bottom of the screen I did not notice it. But I'm not interested in that. I want it to display the program's main Thunderbird Mail....... start menu page and not have my inbox screen visible in the background or, with the box unchecked, effectively as the start screen.

Is there some Thunderbird configuration setting that will do that? If so what and how?
Last edited by greybeard2012 on November 8th, 2019, 10:25 am, edited 1 time in total.

morat
 
Posts: 3492
Joined: February 3rd, 2009, 6:29 pm

Post Posted November 8th, 2019, 10:19 am

The "about:" and "file:" urls work correctly if I close all tabs except the main tab in the 3pane window, then restart.

I think having the Options tab open when restarting causes a problem.

greybeard2012
 
Posts: 73
Joined: October 21st, 2012, 8:27 pm

Post Posted November 9th, 2019, 7:23 am

I think I've found the cause for me and a solution of sorts. It is because I use CCleaner at the end of the day and it is set to delete the session information, a .json file, by default.

If I go to the Thunderbird Mail home page for my email address ie. the Thunderbird program's main menu page and exit the session that page is remembered if I do not delete the session history using CCleaner. You just untick the "Session" box in its Thunderbird options menu. When you relaunch Thunderbird it starts on that 'home page' because it was the page you were on at the end of the last session.

There must have been a change because I've had CCleaner on default settings for years and if I've exited on that home page, used CCleaner and then restarted Thunderbird I'm pretty sure it has restarted on the the home screen I want, not my inbox.

I know full well from past dealings with the Mozilla community in regard to Firefox that many people have an unreasoned hate for CCleaner despite the fact it does clean up better than Firefox itself and rarely causes problems. So I'm expecting some more of that in regard to this Thunderbird matter.

However the fact is the default Thunderbird home page appears to be the primary email account's inbox content and not the Thunderbird main menu page. I'm assuming this is new behaviour and even if it is not what is that page there for?

I want to have Thunderbird always start on that page at login by default and instead of using my inbox page as a background as it does now. Surely there is a configuration setting for altering this to what I'd prefer.
Last edited by greybeard2012 on November 10th, 2019, 6:21 am, edited 1 time in total.

DanRaisch
Moderator

User avatar
 
Posts: 122243
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted November 9th, 2019, 7:38 am

many people have an unreasoned hate for CCleaner despite the fact it does clean up better than Firefox itself and rarely causes problems.

It's not unreasoned and it's not hate. It's based on numerous reports of problems which were eventually traced back to Ccleaner's overaggressive removal of files that Firefox (and sometimes Thunderbird) need to operate properly. Ccleaner may have fixed some of those past issues but some still appear to remain. Thus the advise from long time forum members is to set Ccleaner (if one must use it) to leave Firefox and Thunderbird to do their own clean up, both of which do an adequate job by themselves.

greybeard2012
 
Posts: 73
Joined: October 21st, 2012, 8:27 pm

Post Posted November 10th, 2019, 9:55 am

Thanks but my experience with CCleaner, or at least the version I use, is that it does not cause any problems with either program and you only get issues like this when they're updated and have changed their behaviour.

The latest Thunderbird update clearly messed with some user settings, like the font preference and possibly other things too. Hence my post.

I've just spent an hour updating FF to v70, contrary to natural inclination to leave things alone when they are not broken, and trying to get it to work like v57. That itself I moved to reluctantly from v56 and had to spend many hours researching alternatives for my favourite extensions the use of which FF v57 Quantum had disabled permanently.

These time consuming problems are almost always caused by such changes, some inexplicable, some deliberate, like unhelpfully disabling the userChrome.css by default or simply accidental, as I suspect was the Thunderbird font change.

EDIT
I was thinking about the original problem. It now seems to be not so much a matter of start page preferences being ignored but not being able to set it to the Thunderbird screen you actually want as default. The question is why is the email account inbox the default and can that be changed?

As said if the 'Session' history is not deleted either by using the Thunderbird: Clear Recent History options or CCleaner it will start on the last page you visited during that session. Sensible and what you'd hope it would do.

But if the 'Session' history is cleared it should be wrong for it to start by displaying the inbox contents. The very reason you delete the history is for personal security reasons. Surely others here can understand how stupid that it is logging in after you've deleted the history but with the inbox contents list displayed in the background.

It should start on the Thunderbird program's own home page for the account being used.

frg
 
Posts: 805
Joined: December 15th, 2015, 1:20 pm

Post Posted November 11th, 2019, 9:16 am

Using ccleaner with SeaMonkey, Thunderbird or Firefox is asking for trouble. I like it for Windows cleanup but the first thing I do is disable some application cleanups. The internal structure of the mozilla databases changes frequently and if they don't pick up the change your profile will become corrupted.

Still on 4.19 for older Windows and 5.35 for laters ones too. The latest releases did nothing but add questionable phone home features and ad displays.

Frank Lion

User avatar
 
Posts: 20499
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted November 11th, 2019, 9:41 am

greybeard2012 wrote:Thanks but my experience with CCleaner, or at least the version I use, is that it does not cause any problems with either program and you only get issues like this when they're updated and have changed their behaviour..

greybeard2012 wrote:I think I've found the cause for me and a solution of sorts. It is because I use CCleaner at the end of the day and it is set to delete the session information, a .json file, by default.

Hard enough as it is to read these posts without all this twisting and turning stuff.

Was CCleaner causing your problem or not? No 'I stand by my point' stuff, just a simple Yes/No will do.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

greybeard2012
 
Posts: 73
Joined: October 21st, 2012, 8:27 pm

Post Posted November 11th, 2019, 5:45 pm

No, CCleaner was/is doing almost the same as Thunderbird's own Clear Recent History does.

It is not the cause of any problem.

The only difference between what they do is that Thunderbird's Clear Recent History does not clear the session files. It keeps them and that seems to mean it restarts on the page you were on when exiting the program. If I uncheck the CCleaner Thunderbird "Session" clean option it behaves exactly the same way.

The 'problem' for me are these two JSON files :-

C:\Users\User Name\AppData\Roaming\Thunderbird\Profiles\nbhbadk3.default\sessionCheckpoints.json
C:\Users\User Name\AppData\Roaming\Thunderbird\Profiles\nbhbadk3.default\session.json

In fact it might just be one of them. In the sessionCheckpoints.json there's an entry: ","final-ui-startup":true" which I'm guessing means Thunderbird restarts on the page you're on at exit.

So if I want to get Thunderbird to start on its own Thunderbird Mail home page (not the Thunderbird web site Welcome page) for my email account all I have to do is remember to go to that page before exiting and keep CCleaner Thunderbird > "Session" clean option unticked. Same applies if I use Thunderbird's Clear Recent History, because that does not clean the session history ie. those two JSON files either.

But whenever those two files are deleted Thunderbird always starts on the inbox by default. That's the problem: Thunderbird's default behaviour.

Surely it would be more logical and undoubtedly better for privacy reasons for it to default always to the Thunderbird Mail home page for your account instead or at least be a user menu preference option.
Last edited by greybeard2012 on November 12th, 2019, 8:06 am, edited 1 time in total.

Frank Lion

User avatar
 
Posts: 20499
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted November 12th, 2019, 12:38 am

greybeard2012 - Thanks for the much clearer explanation.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

greybeard2012
 
Posts: 73
Joined: October 21st, 2012, 8:27 pm

Post Posted November 12th, 2019, 8:30 am

Yes, sorry when I have a matter this I tend to include all the information I think is relevant so that sometimes makes it a chore to read through and understanding the precise problem. I'll try to be more concise in the future. :)

I do not know whether this is new Thunderbird behaviour or just something I've not noticed or been bothered about before the recent update. It could even be that I accidentally ticked the CCleaner clean Thunderbird "Session" at some point recently. I'm not sure if it is a default setting. That may be why I started noticing the start up/login background page being used more

But the 'problem' remains: to find a better way of dealing with it rather than having to remember to exit on the Thunderbird Mail home screen and not delete the session.

Return to Thunderbird Support


Who is online

Users browsing this forum: Google [Bot] and 4 guests