MozillaZine

Time format (Linux)

User Help for Mozilla Thunderbird
aik_au
 
Posts: 23
Joined: November 13th, 2016, 10:13 pm

Post Posted August 8th, 2018, 4:53 pm

TB shows time with am/pm instead of 24h format and there is no button in the gui to change that.

Fedora 27. "date" prints as "Thu Aug 9 09:46:47 AEST 2018" (ie 24h), same in gnome3, LANG=en_US.utf8, LC_TIME=en_AU.UTF-8 so it should be 24h in TB as well but it is not.

However changing LC_TIME to en_GB does the trick.

Some predictability/configursbility would not hurt here :)
Last edited by DanRaisch on August 9th, 2018, 5:11 am, edited 1 time in total.
Reason: (Linux) added to subject line.

WaltS48

User avatar
 
Posts: 3706
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted August 9th, 2018, 7:05 am

If I change the time format in my Ubuntu 18.04 settings to 24-hour, I immediately see the change under the Date column of the Thread Pane in Thunderbird 60.0.

I also see the change in the Message Header if I select that message and in the Print Preview.

A restart of Thunderbird was required for the time format to change in the Today Pane and Calendar tab.
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

aik_au
 
Posts: 23
Joined: November 13th, 2016, 10:13 pm

Post Posted August 9th, 2018, 5:10 pm

It does not work like this in Fedora27+gnome3, it affects the gnome but not TB.

Return to Thunderbird Support


Who is online

Users browsing this forum: Google [Bot] and 6 guests