MozillaZine

Strange characters in e-mail

User Help for Mozilla Thunderbird
MomAries

User avatar
 
Posts: 170
Joined: January 4th, 2007, 6:20 pm
Location: Ohio

Post Posted December 7th, 2017, 7:05 pm

Hi everyone ,
Does anyone have this problem?? I got strange foreign looking characters in my e-mail. Funny thing is I don't get it with every one on my list, only a couple people.
I had Norton working on my computer for about an hour looking for viruses. Found no viruses or infections.

I wish I could attach an image I did .. Here I copied to show how it looks:
If I still have this issue I will close this sub-account and open a new one. � Its gonna be a huge hassle but if I have to� I have to...
PLEASE� reply to this� mail so I see if the issue is solved.
Funny thing is -� I sent a few� mails to my gmail account,� and believe it or not there were no characters at all in any of those mails! .�


Norton said it could be my server issue ..
Any idea how to rid of these messages? They are annoying!
Thanks.
Many thanks to all the folks who help me with my problems. :)

tanstaafl
Moderator

User avatar
 
Posts: 43372
Joined: July 30th, 2003, 5:06 pm

Post Posted December 7th, 2017, 7:29 pm

Its not due to a virus or malware, its probably a problem with the character encoding. The message probably has a mixture of 7 and 8 bit characters and some 8 bit characters are not getting mapped to something sensible.

Try setting view -> text encoding -> Unicode. If that doesn't help use Control-U or view -> message source and copy and paste the content of the first Content-Type: header you find (it should be near the Date: header) so that we can see what text encoding was used. Example: Content-Type: text/plain; charset=UTF-8

viewtopic.php?f=39&t=736705&hilit=½

MomAries

User avatar
 
Posts: 170
Joined: January 4th, 2007, 6:20 pm
Location: Ohio

Post Posted December 7th, 2017, 8:24 pm

tanstaafl wrote:Its not due to a virus or malware, its probably a problem with the character encoding. The message probably has a mixture of 7 and 8 bit characters and some 8 bit characters are not getting mapped to something sensible.

Try setting view -> text encoding -> Unicode. If that doesn't help use Control-U or view -> message source and copy and paste the content of the first Content-Type: header you find (it should be near the Date: header) so that we can see what text encoding was used. Example: Content-Type: text/plain; charset=UTF-8

viewtopic.php?f=39&t=736705&hilit=½


Since I did not know the nature of this problem I had Norton to check my computer anyway. It sure doesn't help. WHY did it happen all of the sudden is beyond me. I have not change encoding for ages! I now changed encoding to Unicode to experiment even before reading your message. :). Hope it will help.
If not I will follow your advice with View / CTRL-U.
But I wonder why I only see these characters with two people out of my mailing list?? Only two people. Does it depend which Window is used, or what?? I use Window 7. The person whose e-mail also gives characters uses W10. I forgot what the other guy is using...
Thanks a bunch.
Many thanks to all the folks who help me with my problems. :)

tanstaafl
Moderator

User avatar
 
Posts: 43372
Joined: July 30th, 2003, 5:06 pm

Post Posted December 7th, 2017, 10:36 pm

It doesn't matter what version of Windows you or the sender are using. You might have had encoding set to ISO-8859-1 which would work fine until you got a message from somebody who for some reason needed to use some characters that it couldn't represent. For example the euro sign € . Or used a email client that had different defaults due to that is what everybody as that company used etc.

MomAries

User avatar
 
Posts: 170
Joined: January 4th, 2007, 6:20 pm
Location: Ohio

Post Posted December 8th, 2017, 11:56 am

tanstaafl wrote:It doesn't matter what version of Windows you or the sender are using. You might have had encoding set to ISO-8859-1 which would work fine until you got a message from somebody who for some reason needed to use some characters that it couldn't represent. For example the euro sign € . Or used a email client that had different defaults due to that is what everybody as that company used etc.

Or thats sucks . I had NEVER had this situation before... :( Not good....
I don't have high hopes after changing to Unicode... First it doesn't hold. It changes to Western eventually. Second it gave me some different in the text: a questionmark boxed. Now I still have on Unicode... We will see... If it doesn't help I'll copy/paste here ...
Last edited by MomAries on December 8th, 2017, 12:54 pm, edited 1 time in total.
Many thanks to all the folks who help me with my problems. :)

tanstaafl
Moderator

User avatar
 
Posts: 43372
Joined: July 30th, 2003, 5:06 pm

Post Posted December 8th, 2017, 12:27 pm

Did setting to unicode help?
If not, what is the contents of the first Content-Type: header?

MomAries

User avatar
 
Posts: 170
Joined: January 4th, 2007, 6:20 pm
Location: Ohio

Post Posted December 8th, 2017, 12:56 pm

tanstaafl wrote:Did setting to unicode help?
If not, what is the contents of the first Content-Type: header?

I changed to Unicode a few days ago ..... It did not help. But I changed again yesterday... Don't know yet. Hope people will reply to my mail. Then I find out.
Many thanks to all the folks who help me with my problems. :)

MomAries

User avatar
 
Posts: 170
Joined: January 4th, 2007, 6:20 pm
Location: Ohio

Post Posted December 8th, 2017, 1:08 pm

MomAries wrote:
tanstaafl wrote:Did setting to unicode help?
If not, what is the contents of the first Content-Type: header?

I changed to Unicode a few days ago ..... It did not help. But I changed again yesterday... Don't know yet. Hope people will reply to my mail. Then I find out.

I sent a message to myself, there were no characters. I hope to hear from people .... :D
Many thanks to all the folks who help me with my problems. :)

MomAries

User avatar
 
Posts: 170
Joined: January 4th, 2007, 6:20 pm
Location: Ohio

Post Posted December 8th, 2017, 8:39 pm

tanstaafl wrote:Did setting to unicode help?
If not, what is the contents of the first Content-Type: header?


I I went to "display, and Advanced and changed to Unicode in both Incoming and Outcoming mail. I asked a couple people to let me know if they still see the characters.
I might be able to stop them. Keeping fingers crossed.
Thank you tanstaafl.
Many thanks to all the folks who help me with my problems. :)

MomAries

User avatar
 
Posts: 170
Joined: January 4th, 2007, 6:20 pm
Location: Ohio

Post Posted December 8th, 2017, 8:44 pm

tanstaafl wrote:It doesn't matter what version of Windows you or the sender are using. You might have had encoding set to ISO-8859-1 which would work fine until you got a message from somebody who for some reason needed to use some characters that it couldn't represent. For example the euro sign € . Or used a email client that had different defaults due to that is what everybody as that company used etc.

I was wrong that there were only two people had the same problem with characters. Turned out there were more!
Many thanks to all the folks who help me with my problems. :)

MomAries

User avatar
 
Posts: 170
Joined: January 4th, 2007, 6:20 pm
Location: Ohio

Post Posted December 14th, 2017, 8:35 am

tanstaafl wrote:Did setting to unicode help?
If not, what is the contents of the first Content-Type: header?

Hi tanstaafl, I am here to say that besides changing to Unicode I also marked the box "When possible use the default text encoding in replies" at the bottom.
I think in combination with Unicode setting it helped.
NO MORE ODD CHARACTERS! :D
I DON'T KNOW WHAT I'D DO WITHOUT YOU. Thanks a bunch!!!!! :) Appreciate your help.
Many thanks to all the folks who help me with my problems. :)

MomAries

User avatar
 
Posts: 170
Joined: January 4th, 2007, 6:20 pm
Location: Ohio

Post Posted December 14th, 2017, 8:40 am

Personally I think Thunderbird has a bug related to text encoding. I have never changed the font to French, Spanish etc... No one sent me mail in other language than English.
I strongly believe the TB update does something weird to font setting, generating these odd characters.
Many thanks to all the folks who help me with my problems. :)

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 7 guests