MozillaZine

Can't add or save attachments. [Linux.]

User Help for Mozilla Thunderbird
Psychonaut

User avatar
 
Posts: 41
Joined: April 7th, 2008, 3:56 am
Location: Darmstadt

Post Posted October 11th, 2017, 6:08 am

Greetings.

Lately I've been having trouble adding attachments to e-mail messages I compose, or saving attachments from e-mail messages I am reading. The file selector dialog appears, but after selecting a location, the attachment usually doesn't get attached/saved. No error dialog is displayed, though an error message does appear in the Error Console. Usually if I repeat the process, it works the second time around.

Sample steps to reproduce: Right-click on a message attachment. Select "Save As…". File dialog pops up. Navigate to a directory in which to save the file and press "Save", or simply type a full path in the "Name" field and press enter. The file dialog disappears, but the file doesn't get saved to the directory. The following gets logged to the Error Console:
14:52:53.968 NS_ERROR_MALFORMED_URI: Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [nsIMessenger.saveAttachment] 1 msgHdrViewOverlay.js:1835
AttachmentInfo_save chrome://messenger/content/msgHdrViewOverlay.js:1835:5
HandleMultipleAttachments/actionFunction chrome://messenger/content/msgHdrViewOverlay.js:2704:50
HandleMultipleAttachments chrome://messenger/content/msgHdrViewOverlay.js:2708:11
oncommand chrome://messenger/content/messenger.xul:1:1


This happens with the openSUSE 42.3 package of Thunderbird 52.3.0 (64-bit). So far I haven't been able to reproduce it in safe mode, though it does happen in normal mode with all add-ons disabled. I haven't been able to reproduce it with the official Mozilla binaries.

Anyone else experiencing the same issue or know what the cause might be?
Last edited by LIMPET235 on October 11th, 2017, 6:14 am, edited 1 time in total.
Reason: Added [Linux] to the title.

Psychonaut

User avatar
 
Posts: 41
Joined: April 7th, 2008, 3:56 am
Location: Darmstadt

Post Posted November 17th, 2017, 2:13 am

So, no one else is having this problem? It's driving me crazy as every time I need to add or save an attachment, I have to do it twice (or sometimes even more) before it works. Can anyone suggest anything else I can do to troubleshoot?

Psychonaut

User avatar
 
Posts: 41
Joined: April 7th, 2008, 3:56 am
Location: Darmstadt

Post Posted November 17th, 2017, 2:57 am

OK, I see now that other openSUSE users are having this problem: see openSUSE Bug 1067656. The problem may be linked to the KDE integration that openSUSE applies. (It causes Thunderbird to use KDE file selection dialogs rather than the standard GTK+ ones. This has always worked in the past but maybe a bug was recently introduced.)

Grumpus

User avatar
 
Posts: 11660
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted November 17th, 2017, 7:09 am

You can go into the Preferences/Advanced/General/Configuration Editor (like about:config in Firefox)
Find this item ui.allow_platform_file_picker and change it to false by right clicking and selecting toggle.
It's easy to change back if it doesn't work
This should allow the Thunderbird file picker.

bolek
New Member
 
Posts: 1
Joined: November 28th, 2017, 5:53 am

Post Posted November 28th, 2017, 6:03 am

Wow - :shock: - that's freaking obvious....

I just upgraded from openSuSE 13.2 to 42.3, and from Thunderbird 38 (?) to 52, so I don't know exactly where the culprit arose. However, before I did the toggle to fix the "Attach" file select, drag & drop DID work...

Thanks, Grumpus, for sharing your knowledge...

Czesc

Psychonaut

User avatar
 
Posts: 41
Joined: April 7th, 2008, 3:56 am
Location: Darmstadt

Post Posted November 28th, 2017, 9:23 am

On openSUSE, you can also uninstall the kmozillahelper package to prevent the KDE file selector from being used in Firefox, SeaMonkey, and Thunderbird. You may need to lock the package in zypper/YaST to prevent it from being automatically reinstalled.

jiunnyik
New Member
 
Posts: 1
Joined: December 7th, 2017, 12:48 am

Post Posted December 7th, 2017, 12:53 am

Hi,

By toggle ui.allow_platform_file_picker to false, here come another issue

File / folder name is sorting by Capital letter follow by small capital, like this.

Ab
Bc
Cd
De
ac
be
cg
dh

If ui.allow_platform_file_picker is true, it is like this

Ab
ac
Bc
be
Cd
cg
De
dh

Is there any way to sort file / folder name by alphabet no matter it is capital letter or small letter when ui.allow_platform_file_picker is toggle to false?

Thanks.

Psychonaut

User avatar
 
Posts: 41
Joined: April 7th, 2008, 3:56 am
Location: Darmstadt

Post Posted December 7th, 2017, 2:51 am

Just a guess, but if you're running on a Unix-like system, try invoking Thunderbird with LC_COLLATE=C. (If you're not using a Unix-like system, there may be some equivalent OS-level environment variable or other mechanism you can use that controls collation.)

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 7 guests