MozillaZine


Lost my Tab Delete Buttons

User Help for Mozilla Firefox
drkenrich
 
Posts: 30
Joined: February 28th, 2006, 12:48 pm

Post Posted July 30th, 2021, 2:28 pm

I just updated and the delete button located at the right side of each tab is gone. There is a 1 pixel spot that will delete the tab, but that's hard to see.

How do I fix it?

DanRaisch
Moderator

User avatar
 
Posts: 125436
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted July 30th, 2021, 2:36 pm

Moving to Firefox Support as no specific bug has been identified here.

Have you tried starting Firefox in Mozilla Safe Mode? http://kb.mozillazine.org/Safe_mode
If no improvement using Safe Mode, do you have the same problem if you create a new profile and test it with no extensions or non-default themes installed?
http://kb.mozillazine.org/Profile_Manager
and
http://kb.mozillazine.org/Creating_a_ne ... on_Windows

jscher2000

User avatar
 
Posts: 11467
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted July 30th, 2021, 4:12 pm

drkenrich wrote:There is a 1 pixel spot that will delete the tab, but that's hard to see.

That's strange, do you use any custom style rules in a userChrome.css file?

By the way, you also can close the current tab using Ctrl+W and any tab by right-clicking the tab and clicking Close tab (or right-clicking and then tapping the C key on the keyboard).

dickvl

User avatar
 
Posts: 53550
Joined: July 18th, 2005, 3:25 am

Post Posted July 30th, 2021, 5:22 pm

... or middle-click tab with the mouse wheel.

drkenrich
 
Posts: 30
Joined: February 28th, 2006, 12:48 pm

Post Posted July 31st, 2021, 8:53 pm

Yes, I tried safe mode with all ext. addons, etc. turned off. Delete cross was back until I started adding things back in. I tried deleting addons and testing again. No fix.

I don't use style rules so That's not a fix.

Yes, middle click and ctr+w does close the current tab, but still no crosses. That's no good for closing tabs I'm not currently viewing.

DanRaisch
Moderator

User avatar
 
Posts: 125436
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted August 1st, 2021, 3:50 am

While in standard mode (not Safe Mode) try unchecking "Use hardware acceleratoon when available." See if the button reappears.

Also note that under the tab context menu (right click on a tab) there is an option to "Close Multiple tabs". Perhaps that will be useful to you in some circumstances.

dickvl

User avatar
 
Posts: 53550
Joined: July 18th, 2005, 3:25 am

Post Posted August 1st, 2021, 8:07 am

You aren't using code in userChrome.css that might be causing this ?

You can use the Browser Toolbox to check what (custom) rules are applied to the close button (.tab-close-button).
https://developer.mozilla.org/en-US/doc ... er_Toolbox

To enable the Browser Toolbox select: "Enable remote debugging" in the Web Developer Tools settings
https://developer.mozilla.org/en-US/docs/Tools/Settings

drkenrich
 
Posts: 30
Joined: February 28th, 2006, 12:48 pm

Post Posted August 1st, 2021, 1:32 pm

I gave up and uninstalled Firefox. Then I went back to a previous working version that works fine. From that vanilla installation I updated to 90. and it seems to be working now.

Thank God I've done this enough times over the years to have backups of passwords, bookmarks, settings, addons, etc. so I don't have to start from scratch. It's still a pain.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 5 guests