MozillaZine

FF75 - search bar dropdown search engine icons missing

User Help for Mozilla Firefox
Ed1
 
Posts: 966
Joined: January 30th, 2005, 2:33 pm

Post Posted April 28th, 2020, 10:59 am

I have about 15 different search engines with icons in the drop down box from the separate search bar.

Suddenly, about a third of the icons for these search engines have gone missing. The buttons missing icons are for Duck Duck Go (default), Google, Bing, Amazon, EBay and Wikipedia. The buttons for all search engines are all there, including the ones missing icons. And any of the search engines can still be selected for use.

I have tried restarting FF75, restarting FF75 in safe mode, and toggling off and on (in Settings) the search engines that are missing icons, but the icons are not restored.

Why have the icons been lost for some of my search engines? This is new behavior, just noticed today.

EDIT: Just found this thread where the identical issue is discussed in FF68. Thread stops after a post that says this issue is resolved in FF75. But not for me. Not sure how to resolve. Tried renaming search.json.mozlz4 file as mentioned in that thread. That has brought back the default engines and icons, but removed all of the additional search engines that I had added. Can't find those deleted engines, that I had obtained at mycroft.

viewtopic.php?f=38&t=3052050

UPDATE: OK, after renaming the search.json.mozlz4 file and reopening FF75, I was able to find most of my lost search engines using the Mycroft Project web site. The default and added search engines and their icons all seem to be sticking through closing and reopening FF75. Still curious why this problem occurred.

Return to Firefox Support


Who is online

Users browsing this forum: Google Adsense [Bot] and 9 guests